429df3a49e
- Add patch for GNOME bug #516074 (latest glibc breaks Camel).
50 lines
1.9 KiB
Diff
50 lines
1.9 KiB
Diff
diff -up evolution-data-server-2.21.91/camel/camel-net-utils.c.netdb-breakage evolution-data-server-2.21.91/camel/camel-net-utils.c
|
|
--- evolution-data-server-2.21.91/camel/camel-net-utils.c.netdb-breakage 2008-01-23 06:16:25.000000000 -0500
|
|
+++ evolution-data-server-2.21.91/camel/camel-net-utils.c 2008-02-12 13:25:56.000000000 -0500
|
|
@@ -44,6 +44,14 @@
|
|
|
|
#define d(x)
|
|
|
|
+/* These are GNU extensions */
|
|
+#ifndef NI_MAXHOST
|
|
+#define NI_MAXHOST 1025
|
|
+#endif
|
|
+#ifndef NI_MAXSERV
|
|
+#define NI_MAXSERV 32
|
|
+#endif
|
|
+
|
|
#ifdef G_OS_WIN32
|
|
|
|
typedef short in_port_t;
|
|
diff -up evolution-data-server-2.21.91/camel/camel-net-utils.h.netdb-breakage evolution-data-server-2.21.91/camel/camel-net-utils.h
|
|
--- evolution-data-server-2.21.91/camel/camel-net-utils.h.netdb-breakage 2007-11-29 07:53:44.000000000 -0500
|
|
+++ evolution-data-server-2.21.91/camel/camel-net-utils.h 2008-02-12 13:25:56.000000000 -0500
|
|
@@ -77,9 +77,6 @@ struct addrinfo {
|
|
#define EAI_SYSTEM -11 /* System error returned in `errno'. */
|
|
#define EAI_OVERFLOW -12 /* Argument buffer overflow. */
|
|
|
|
-#define NI_MAXHOST 1025
|
|
-#define NI_MAXSERV 32
|
|
-
|
|
#define NI_NUMERICHOST 1 /* Don't try to look up hostname. */
|
|
#define NI_NUMERICSERV 2 /* Don't convert port number to name. */
|
|
#define NI_NOFQDN 4 /* Only return nodename portion. */
|
|
diff -up evolution-data-server-2.21.91/configure.in.netdb-breakage evolution-data-server-2.21.91/configure.in
|
|
--- evolution-data-server-2.21.91/configure.in.netdb-breakage 2008-02-10 10:19:14.000000000 -0500
|
|
+++ evolution-data-server-2.21.91/configure.in 2008-02-12 13:25:56.000000000 -0500
|
|
@@ -878,6 +878,14 @@ AC_CACHE_CHECK([if system supports getad
|
|
#include <stddef.h>
|
|
|
|
],[
|
|
+ #ifndef NI_MAXHOST
|
|
+ #define NI_MAXHOST 1025
|
|
+ #endif
|
|
+
|
|
+ #ifndef NI_MAXSERV
|
|
+ #define NI_MAXSERV 32
|
|
+ #endif
|
|
+
|
|
struct addrinfo hints, *res;
|
|
struct sockaddr_in6 sin6;
|
|
int af = AF_INET6;
|