- Update to 2.21.91

- Add patch for GNOME bug #516074 (latest glibc breaks Camel).
This commit is contained in:
Matthew Barnes 2008-02-12 19:28:35 +00:00
parent 555fac0c99
commit 429df3a49e
3 changed files with 77 additions and 0 deletions

View File

@ -0,0 +1,49 @@
diff -up evolution-data-server-2.21.91/camel/camel-net-utils.c.netdb-breakage evolution-data-server-2.21.91/camel/camel-net-utils.c
--- evolution-data-server-2.21.91/camel/camel-net-utils.c.netdb-breakage 2008-01-23 06:16:25.000000000 -0500
+++ evolution-data-server-2.21.91/camel/camel-net-utils.c 2008-02-12 13:25:56.000000000 -0500
@@ -44,6 +44,14 @@
#define d(x)
+/* These are GNU extensions */
+#ifndef NI_MAXHOST
+#define NI_MAXHOST 1025
+#endif
+#ifndef NI_MAXSERV
+#define NI_MAXSERV 32
+#endif
+
#ifdef G_OS_WIN32
typedef short in_port_t;
diff -up evolution-data-server-2.21.91/camel/camel-net-utils.h.netdb-breakage evolution-data-server-2.21.91/camel/camel-net-utils.h
--- evolution-data-server-2.21.91/camel/camel-net-utils.h.netdb-breakage 2007-11-29 07:53:44.000000000 -0500
+++ evolution-data-server-2.21.91/camel/camel-net-utils.h 2008-02-12 13:25:56.000000000 -0500
@@ -77,9 +77,6 @@ struct addrinfo {
#define EAI_SYSTEM -11 /* System error returned in `errno'. */
#define EAI_OVERFLOW -12 /* Argument buffer overflow. */
-#define NI_MAXHOST 1025
-#define NI_MAXSERV 32
-
#define NI_NUMERICHOST 1 /* Don't try to look up hostname. */
#define NI_NUMERICSERV 2 /* Don't convert port number to name. */
#define NI_NOFQDN 4 /* Only return nodename portion. */
diff -up evolution-data-server-2.21.91/configure.in.netdb-breakage evolution-data-server-2.21.91/configure.in
--- evolution-data-server-2.21.91/configure.in.netdb-breakage 2008-02-10 10:19:14.000000000 -0500
+++ evolution-data-server-2.21.91/configure.in 2008-02-12 13:25:56.000000000 -0500
@@ -878,6 +878,14 @@ AC_CACHE_CHECK([if system supports getad
#include <stddef.h>
],[
+ #ifndef NI_MAXHOST
+ #define NI_MAXHOST 1025
+ #endif
+
+ #ifndef NI_MAXSERV
+ #define NI_MAXSERV 32
+ #endif
+
struct addrinfo hints, *res;
struct sockaddr_in6 sin6;
int af = AF_INET6;

View File

@ -0,0 +1,24 @@
diff -up evolution-data-server-2.21.91/servers/exchange/storage/exchange-account.c.no-gnuc-pretty-function evolution-data-server-2.21.91/servers/exchange/storage/exchange-account.c
--- evolution-data-server-2.21.91/servers/exchange/storage/exchange-account.c.no-gnuc-pretty-function 2008-01-12 04:21:01.000000000 -0500
+++ evolution-data-server-2.21.91/servers/exchange/storage/exchange-account.c 2008-02-12 14:27:30.000000000 -0500
@@ -1886,7 +1886,7 @@ add_folder (gpointer key, gpointer value
{
EFolder *folder = value;
- d(g_print ("%s(%d):%s: key=[%s]\t folder-path=[%s]\n", __FILE__, __LINE__, G_GNUC_PRETTY_FUNCTION,
+ d(g_print ("%s:%s: key=[%s]\t folder-path=[%s]\n", G_STRLOC, G_STRFUNC,
key, e_folder_exchange_get_path (folder)));
/* Each folder appears under three different keys, but
diff -up evolution-data-server-2.21.91/addressbook/libebook/e-book.c.no-gnuc-pretty-function evolution-data-server-2.21.91/addressbook/libebook/e-book.c
--- evolution-data-server-2.21.91/addressbook/libebook/e-book.c.no-gnuc-pretty-function 2007-11-29 07:53:48.000000000 -0500
+++ evolution-data-server-2.21.91/addressbook/libebook/e-book.c 2008-02-12 14:27:30.000000000 -0500
@@ -4012,7 +4012,7 @@ e_book_dispose (GObject *object)
CORBA_exception_init (&ev);
bonobo_object_release_unref (book->priv->corba_book, &ev);
if (ev._major != CORBA_NO_EXCEPTION)
- g_warning ("%s: Exception releasing remote book interface!\n", G_GNUC_PRETTY_FUNCTION);
+ g_warning ("%s: Exception releasing remote book interface!\n", G_STRFUNC);
CORBA_exception_free (&ev);
}

View File

@ -57,6 +57,9 @@ Patch15: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
# GNOME bug #516074
Patch16: evolution-data-server-2.21.91-netdb-breakage.patch
# G_GNUC_PRETTY_FUNCTION is deprecated
Patch17: evolution-data-server-2.21.91-no-gnuc-pretty-function.patch
### Build Dependencies ###
BuildRequires: GConf2-devel
@ -136,6 +139,7 @@ This package contains developer documentation for %{name}.
%patch14 -p1 -b .camel-folder-summary-crash
%patch15 -p1 -b .fix-64bit-acinclude
%patch16 -p1 -b .netdb-breakage
%patch17 -p1 -b .no-gnuc-pretty-function
mkdir -p krb5-fakeprefix/include
mkdir -p krb5-fakeprefix/lib