- Update to 1.10.1

- Remove evolution-data-server-1.10.0-no-more-beeps.patch (fixed upstream).
This commit is contained in:
Matthew Barnes 2007-04-09 16:41:22 +00:00
parent 89d907d9b3
commit 921a69f9a4
5 changed files with 57 additions and 54 deletions

View File

@ -1 +1 @@
evolution-data-server-1.10.0.tar.bz2
evolution-data-server-1.10.1.tar.bz2

View File

@ -1076,16 +1076,6 @@
<FILE>e-source-option-menu</FILE>
<TITLE>ESourceOptionMenu</TITLE>
ESourceOptionMenu
--- evolution-data-server-1.10.0/iconv-detect.c.code-cleanup 2007-01-03 05:10:36.000000000 -0500
+++ evolution-data-server-1.10.0/iconv-detect.c 2007-04-04 12:08:04.000000000 -0400
@@ -21,6 +21,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <iconv.h>
enum {
--- evolution-data-server-1.10.0/calendar/libical/src/libicalss/icalssyacc.y.code-cleanup 2007-01-03 10:02:34.000000000 -0500
+++ evolution-data-server-1.10.0/calendar/libical/src/libicalss/icalssyacc.y 2007-04-04 12:08:04.000000000 -0400
@@ -47,6 +47,7 @@

View File

@ -1,16 +1,16 @@
--- evolution-data-server-1.9.5/configure.no-gnome-common 2007-01-21 21:49:28.000000000 -0500
+++ evolution-data-server-1.9.5/configure 2007-01-21 21:50:44.000000000 -0500
@@ -29801,141 +29801,6 @@
--- evolution-data-server-1.10.1/configure.no-gnome-common 2007-04-09 12:15:42.000000000 -0400
+++ evolution-data-server-1.10.1/configure 2007-04-09 12:16:10.000000000 -0400
@@ -32298,154 +32298,6 @@
- # Check whether --enable-compile-warnings or --disable-compile-warnings was given.
- # Check whether --enable-compile-warnings was given.
-if test "${enable_compile_warnings+set}" = set; then
- enableval="$enable_compile_warnings"
-
- enableval=$enable_compile_warnings;
-else
- enable_compile_warnings="yes"
-fi;
-fi
-
-
- warnCFLAGS=
- if test "x$GCC" != xyes; then
@ -36,8 +36,8 @@
- for option in -Wno-sign-compare; do
- SAVE_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $option"
- echo "$as_me:$LINENO: checking whether gcc understands $option" >&5
-echo $ECHO_N "checking whether gcc understands $option... $ECHO_C" >&6
- { echo "$as_me:$LINENO: checking whether gcc understands $option" >&5
-echo $ECHO_N "checking whether gcc understands $option... $ECHO_C" >&6; }
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
@ -54,24 +54,36 @@
-}
-_ACEOF
-rm -f conftest.$ac_objext
-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
- (eval $ac_compile) 2>conftest.er1
-if { (ac_try="$ac_compile"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
- (eval "$ac_compile") 2>conftest.er1
- ac_status=$?
- grep -v '^ *+' conftest.er1 >conftest.err
- rm -f conftest.er1
- cat conftest.err >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } &&
- { ac_try='test -z "$ac_c_werror_flag"
- || test ! -s conftest.err'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; } &&
- { ac_try='test -s conftest.$ac_objext'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- { (case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
- (eval "$ac_try") 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
@ -80,12 +92,13 @@
- echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-has_option=no
- has_option=no
-fi
-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
-
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$SAVE_CFLAGS"
- echo "$as_me:$LINENO: result: $has_option" >&5
-echo "${ECHO_T}$has_option" >&6
- { echo "$as_me:$LINENO: result: $has_option" >&5
-echo "${ECHO_T}$has_option" >&6; }
- if test $has_option = yes; then
- warning_flags="$warning_flags $option"
- fi
@ -104,21 +117,21 @@
- ;;
- esac
- CFLAGS="$realsave_CFLAGS"
- echo "$as_me:$LINENO: checking what warning flags to pass to the C compiler" >&5
-echo $ECHO_N "checking what warning flags to pass to the C compiler... $ECHO_C" >&6
- echo "$as_me:$LINENO: result: $warning_flags" >&5
-echo "${ECHO_T}$warning_flags" >&6
- { echo "$as_me:$LINENO: checking what warning flags to pass to the C compiler" >&5
-echo $ECHO_N "checking what warning flags to pass to the C compiler... $ECHO_C" >&6; }
- { echo "$as_me:$LINENO: result: $warning_flags" >&5
-echo "${ECHO_T}$warning_flags" >&6; }
-
- # Check whether --enable-iso-c or --disable-iso-c was given.
- # Check whether --enable-iso-c was given.
-if test "${enable_iso_c+set}" = set; then
- enableval="$enable_iso_c"
-
- enableval=$enable_iso_c;
-else
- enable_iso_c=no
-fi;
-fi
-
- echo "$as_me:$LINENO: checking what language compliance flags to pass to the C compiler" >&5
-echo $ECHO_N "checking what language compliance flags to pass to the C compiler... $ECHO_C" >&6
-
- { echo "$as_me:$LINENO: checking what language compliance flags to pass to the C compiler" >&5
-echo $ECHO_N "checking what language compliance flags to pass to the C compiler... $ECHO_C" >&6; }
- complCFLAGS=
- if test "x$enable_iso_c" != "xno"; then
- if test "x$GCC" = "xyes"; then
@ -132,8 +145,8 @@
- esac
- fi
- fi
- echo "$as_me:$LINENO: result: $complCFLAGS" >&5
-echo "${ECHO_T}$complCFLAGS" >&6
- { echo "$as_me:$LINENO: result: $complCFLAGS" >&5
-echo "${ECHO_T}$complCFLAGS" >&6; }
-
- WARN_CFLAGS="$warning_flags $complCFLAGS"
-
@ -142,9 +155,9 @@
case $CFLAGS in
*-Wall*)
# Turn off the annoying "comparison between signed and unsigned"
--- evolution-data-server-1.9.5/configure.in.no-gnome-common 2007-01-08 11:49:57.000000000 -0500
+++ evolution-data-server-1.9.5/configure.in 2007-01-21 21:49:01.000000000 -0500
@@ -1206,8 +1206,6 @@
--- evolution-data-server-1.10.1/configure.in.no-gnome-common 2007-04-09 08:44:46.000000000 -0400
+++ evolution-data-server-1.10.1/configure.in 2007-04-09 12:15:42.000000000 -0400
@@ -1209,8 +1209,6 @@
dnl CFLAGS and LIBS and stuff
dnl *************************

View File

@ -25,8 +25,8 @@
### Abstract ###
Name: evolution-data-server
Version: 1.10.0
Release: 6%{?dist}
Version: 1.10.1
Release: 1%{?dist}
License: LGPL
Group: System Environment/Libraries
Summary: Backend data server for Evolution
@ -78,9 +78,6 @@ Patch22: evolution-data-server-1.9.92-isa-support.patch
# GNOME bug #417999
Patch23: evolution-data-server-1.10.0-code-cleanup.patch
# E-D-S beeps a lot
Patch24: evolution-data-server-1.10.0-no-more-beeps.patch
### Dependencies ###
Requires: GConf2
@ -174,7 +171,6 @@ evolution-data-server.
%patch21 -p1 -b .e-passwords
%patch22 -p1 -b .isa-support
%patch23 -p1 -b .code-cleanup
%patch24 -p1 -b .no-more-beeps
mkdir -p krb5-fakeprefix/include
mkdir -p krb5-fakeprefix/lib
@ -392,6 +388,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/pkgconfig/libexchange-storage-%{eds_api_version}.pc
%changelog
* Mon Apr 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.1-1.fc7
- Update to 1.10.1
- Remove evolution-data-server-1.10.0-no-more-beeps.patch (fixed upstream).
* Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
- Revise patch for GNOME bug #417999 (another ESourceComboBox goof).

View File

@ -1 +1 @@
390ea134306b667a2d77b7e859c8cba0 evolution-data-server-1.10.0.tar.bz2
1175bf76756009975f684116e76638c3 evolution-data-server-1.10.1.tar.bz2