- Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
This commit is contained in:
parent
2187af3b01
commit
89d907d9b3
@ -1,5 +1,5 @@
|
||||
--- evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.glade.code-cleanup 2007-01-03 05:09:27.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.glade 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.glade 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -118,7 +118,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
@ -62,7 +62,7 @@
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
--- evolution-data-server-1.10.0/libedataserverui/e-name-selector-list.c.code-cleanup 2007-01-03 05:09:27.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-list.c 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-list.c 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -447,7 +447,7 @@
|
||||
|
||||
if (len > 1) {
|
||||
@ -73,7 +73,7 @@
|
||||
} else {
|
||||
menu_item = gtk_menu_item_new_with_label (email);
|
||||
--- evolution-data-server-1.10.0/libedataserverui/e-name-selector-entry.c.code-cleanup 2007-01-03 05:09:27.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-entry.c 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-entry.c 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -2136,7 +2136,7 @@
|
||||
|
||||
if (len > 1) {
|
||||
@ -84,7 +84,7 @@
|
||||
} else {
|
||||
menu_item = gtk_menu_item_new_with_label (email);
|
||||
--- evolution-data-server-1.10.0/libedataserverui/test-source-option-menu.c.code-cleanup 2007-01-03 05:09:27.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/test-source-option-menu.c 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/test-source-option-menu.c 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -1,5 +1,5 @@
|
||||
/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
|
||||
-/* test-source-option-menu.c - Test for ESourceOptionMenu.
|
||||
@ -141,7 +141,7 @@
|
||||
|
||||
g_object_unref (gconf_client);
|
||||
--- evolution-data-server-1.10.0/libedataserverui/e-source-option-menu.h.code-cleanup 2007-01-03 05:09:27.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-source-option-menu.h 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-source-option-menu.h 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -23,6 +23,8 @@
|
||||
#ifndef _E_SOURCE_OPTION_MENU_H_
|
||||
#define _E_SOURCE_OPTION_MENU_H_
|
||||
@ -158,8 +158,8 @@
|
||||
+#endif /* EDS_DISABLE_DEPRECATED */
|
||||
|
||||
#endif /* _E_SOURCE_OPTION_MENU_H_ */
|
||||
--- /dev/null 2007-03-08 09:20:11.212292094 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-source-combo-box.h 2007-03-13 15:49:50.000000000 -0400
|
||||
--- /dev/null 2007-03-30 19:30:56.246366825 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-source-combo-box.h 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -0,0 +1,79 @@
|
||||
+/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
|
||||
+/* e-source-combo-box.h
|
||||
@ -240,8 +240,8 @@
|
||||
+G_END_DECLS
|
||||
+
|
||||
+#endif /* _E_SOURCE_COMBO_BOX_H_ */
|
||||
--- evolution-data-server-1.10.0/libedataserverui/Makefile.in.code-cleanup 2007-03-13 16:40:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/Makefile.in 2007-03-13 16:41:45.000000000 -0400
|
||||
--- evolution-data-server-1.10.0/libedataserverui/Makefile.in.code-cleanup 2007-03-12 12:04:04.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/Makefile.in 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -78,8 +78,8 @@
|
||||
e-name-selector-dialog.lo e-name-selector-entry.lo \
|
||||
e-name-selector-model.lo e-name-selector-list.lo \
|
||||
@ -278,7 +278,7 @@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-source-selector-dialog.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-source-selector.Plo@am__quote@
|
||||
--- evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.h.code-cleanup 2007-01-03 05:09:27.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.h 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.h 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -58,7 +58,6 @@
|
||||
/* Private */
|
||||
|
||||
@ -288,7 +288,7 @@
|
||||
GtkTreeModelSort *contact_sort;
|
||||
|
||||
--- evolution-data-server-1.10.0/libedataserverui/Makefile.am.code-cleanup 2007-01-03 05:09:27.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/Makefile.am 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/Makefile.am 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -31,6 +31,7 @@
|
||||
e-passwords.c \
|
||||
e-source-selector.c \
|
||||
@ -305,8 +305,8 @@
|
||||
e-source-option-menu.h \
|
||||
e-tree-model-generator.h
|
||||
|
||||
--- evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.c.code-cleanup 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.c 2007-03-13 15:49:50.000000000 -0400
|
||||
--- evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.c.code-cleanup 2007-04-04 12:08:04.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-name-selector-dialog.c 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -32,7 +32,7 @@
|
||||
#include <gtk/gtkscrolledwindow.h>
|
||||
#include <gtk/gtkstock.h>
|
||||
@ -556,9 +556,9 @@
|
||||
}
|
||||
|
||||
static void
|
||||
--- /dev/null 2007-03-08 09:20:11.212292094 -0500
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-source-combo-box.c 2007-03-13 15:49:50.000000000 -0400
|
||||
@@ -0,0 +1,461 @@
|
||||
--- /dev/null 2007-03-30 19:30:56.246366825 -0400
|
||||
+++ evolution-data-server-1.10.0/libedataserverui/e-source-combo-box.c 2007-04-04 12:09:51.000000000 -0400
|
||||
@@ -0,0 +1,457 @@
|
||||
+/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
|
||||
+/* e-source-option-menu.c
|
||||
+ *
|
||||
@ -665,10 +665,6 @@
|
||||
+ -1);
|
||||
+ g_free (indented_name);
|
||||
+
|
||||
+ if (gtk_combo_box_get_active (combo_box) == -1)
|
||||
+ gtk_combo_box_set_active_iter (
|
||||
+ combo_box, &iter);
|
||||
+
|
||||
+ uid = e_source_peek_uid (sources->data);
|
||||
+ path = gtk_tree_model_get_path (model, &iter);
|
||||
+ g_hash_table_insert (
|
||||
@ -1021,7 +1017,7 @@
|
||||
+ gtk_combo_box_set_active_iter (combo_box, &iter);
|
||||
+}
|
||||
--- evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui-docs.sgml.code-cleanup 2007-03-12 01:23:42.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui-docs.sgml 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui-docs.sgml 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -19,6 +19,7 @@
|
||||
<xi:include href="xml/e-name-selector-list.xml"/>
|
||||
<xi:include href="xml/e-name-selector-model.xml"/>
|
||||
@ -1031,7 +1027,7 @@
|
||||
<xi:include href="xml/e-source-selector.xml"/>
|
||||
<xi:include href="xml/e-source-selector-dialog.xml"/>
|
||||
--- evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui.types.code-cleanup 2007-03-12 01:23:42.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui.types 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui.types 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -6,6 +6,7 @@
|
||||
#include <libedataserverui/e-name-selector-entry.h>
|
||||
#include <libedataserverui/e-name-selector-list.h>
|
||||
@ -1049,7 +1045,7 @@
|
||||
e_source_selector_get_type
|
||||
e_source_selector_dialog_get_type
|
||||
--- evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui-sections.txt.code-cleanup 2007-03-12 01:23:42.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui-sections.txt 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/docs/reference/libedataserverui/libedataserverui-sections.txt 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -25,6 +25,29 @@
|
||||
</SECTION>
|
||||
|
||||
@ -1081,7 +1077,7 @@
|
||||
<TITLE>ESourceOptionMenu</TITLE>
|
||||
ESourceOptionMenu
|
||||
--- evolution-data-server-1.10.0/iconv-detect.c.code-cleanup 2007-01-03 05:10:36.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/iconv-detect.c 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/iconv-detect.c 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -21,6 +21,7 @@
|
||||
*/
|
||||
|
||||
@ -1091,7 +1087,7 @@
|
||||
|
||||
enum {
|
||||
--- evolution-data-server-1.10.0/calendar/libical/src/libicalss/icalssyacc.y.code-cleanup 2007-01-03 10:02:34.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/calendar/libical/src/libicalss/icalssyacc.y 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/calendar/libical/src/libicalss/icalssyacc.y 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -47,6 +47,7 @@
|
||||
static void ssyacc_add_from(struct icalgauge_impl* impl, char* str1);
|
||||
static void set_logic(struct icalgauge_impl* impl,icalgaugelogic l);
|
||||
@ -1101,7 +1097,7 @@
|
||||
%}
|
||||
|
||||
--- evolution-data-server-1.10.0/calendar/libical/src/libicalvcal/vcc.y.code-cleanup 2007-01-03 10:02:34.000000000 -0500
|
||||
+++ evolution-data-server-1.10.0/calendar/libical/src/libicalvcal/vcc.y 2007-03-13 15:49:50.000000000 -0400
|
||||
+++ evolution-data-server-1.10.0/calendar/libical/src/libicalvcal/vcc.y 2007-04-04 12:08:04.000000000 -0400
|
||||
@@ -170,6 +170,7 @@
|
||||
static void enterAttr(const char *s1, const char *s2);
|
||||
static void enterValues(const char *value);
|
||||
|
@ -26,7 +26,7 @@
|
||||
|
||||
Name: evolution-data-server
|
||||
Version: 1.10.0
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
Summary: Backend data server for Evolution
|
||||
@ -392,6 +392,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/pkgconfig/libexchange-storage-%{eds_api_version}.pc
|
||||
|
||||
%changelog
|
||||
* Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
|
||||
- Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
|
||||
|
||||
* Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
|
||||
- Make the new ESourceComboBox widget work properly (RH bug #234760).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user