Update to 2.91.3
Remove evince-page-range.patch
This commit is contained in:
parent
4243ac0596
commit
e5b476f9a8
@ -1,32 +0,0 @@
|
|||||||
commit a3b87cb28e46958b37e384a47604032ea0889807
|
|
||||||
Author: Carlos Garcia Campos <carlosgc@gnome.org>
|
|
||||||
Date: Sun Nov 21 12:27:21 2010 +0100
|
|
||||||
|
|
||||||
libview: Make sure we have a valid page range before getting/setting selection list
|
|
||||||
|
|
||||||
Fixes bug #630999.
|
|
||||||
|
|
||||||
diff --git a/libview/ev-pixbuf-cache.c b/libview/ev-pixbuf-cache.c
|
|
||||||
index 367f70d..ee68354 100644
|
|
||||||
--- a/libview/ev-pixbuf-cache.c
|
|
||||||
+++ b/libview/ev-pixbuf-cache.c
|
|
||||||
@@ -1035,6 +1035,9 @@ ev_pixbuf_cache_set_selection_list (EvPixbufCache *pixbuf_cache,
|
|
||||||
if (!EV_IS_SELECTION (pixbuf_cache->document))
|
|
||||||
return;
|
|
||||||
|
|
||||||
+ if (pixbuf_cache->start_page == -1 || pixbuf_cache->end_page == -1)
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
/* We check each area to see what needs updating, and what needs freeing; */
|
|
||||||
page = pixbuf_cache->start_page - pixbuf_cache->preload_cache_size;
|
|
||||||
for (i = 0; i < pixbuf_cache->preload_cache_size; i++) {
|
|
||||||
@@ -1114,6 +1117,9 @@ ev_pixbuf_cache_get_selection_list (EvPixbufCache *pixbuf_cache)
|
|
||||||
|
|
||||||
g_return_val_if_fail (EV_IS_PIXBUF_CACHE (pixbuf_cache), NULL);
|
|
||||||
|
|
||||||
+ if (pixbuf_cache->start_page == -1 || pixbuf_cache->end_page == -1)
|
|
||||||
+ return NULL;
|
|
||||||
+
|
|
||||||
/* We check each area to see what needs updating, and what needs freeing; */
|
|
||||||
page = pixbuf_cache->start_page - pixbuf_cache->preload_cache_size;
|
|
||||||
for (i = 0; i < pixbuf_cache->preload_cache_size; i++) {
|
|
11
evince.spec
11
evince.spec
@ -4,8 +4,8 @@
|
|||||||
%global theme_version 2.17.1
|
%global theme_version 2.17.1
|
||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 2.91.2
|
Version: 2.91.3
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
License: GPLv2+ and GFDL
|
License: GPLv2+ and GFDL
|
||||||
@ -14,8 +14,6 @@ URL: http://projects.gnome.org/evince/
|
|||||||
Source0: http://download.gnome.org/sources/%{name}/2.91/%{name}-%{version}.tar.bz2
|
Source0: http://download.gnome.org/sources/%{name}/2.91/%{name}-%{version}.tar.bz2
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=562648
|
# https://bugzilla.redhat.com/show_bug.cgi?id=562648
|
||||||
Patch2: evince-t1font-mapping.patch
|
Patch2: evince-t1font-mapping.patch
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=647689
|
|
||||||
Patch3: evince-page-range.patch
|
|
||||||
|
|
||||||
BuildRequires: gtk3-devel
|
BuildRequires: gtk3-devel
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
@ -109,7 +107,6 @@ It adds an additional tab called "Document" to the file properties dialog.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch2 -p1 -b .t1font-map
|
%patch2 -p1 -b .t1font-map
|
||||||
%patch3 -p1 -b .page-range
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
automake
|
automake
|
||||||
@ -243,6 +240,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
|
|||||||
%{_libdir}/nautilus/extensions-2.0/libevince-properties-page.so
|
%{_libdir}/nautilus/extensions-2.0/libevince-properties-page.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 1 2010 Marek Kasik <mkasik@redhat.com> - 2.91.3-1
|
||||||
|
- Update to 2.91.3
|
||||||
|
- Remove evince-page-range.patch
|
||||||
|
|
||||||
* Mon Nov 22 2010 Marek Kasik <mkasik@redhat.com> - 2.91.2-2
|
* Mon Nov 22 2010 Marek Kasik <mkasik@redhat.com> - 2.91.2-2
|
||||||
- Fix crash in clear_job_selection()
|
- Fix crash in clear_job_selection()
|
||||||
- Remove unused patches
|
- Remove unused patches
|
||||||
|
Loading…
Reference in New Issue
Block a user