Fix crash in clear_job_selection()
Remove unused patches Resolves: #647689
This commit is contained in:
parent
e5728a8c73
commit
4243ac0596
@ -1,11 +0,0 @@
|
||||
--- evince-2.31.5/libmisc/ev-page-action-widget.c 2010-04-05 11:21:59.000000000 +0200
|
||||
+++ evince-2.31.5/libmisc/ev-page-action-widget.c 2010-07-21 16:30:30.000000000 +0200
|
||||
@@ -271,7 +271,7 @@ ev_page_action_widget_class_init (EvPage
|
||||
g_signal_new ("activate_link",
|
||||
G_OBJECT_CLASS_TYPE (object_class),
|
||||
G_SIGNAL_RUN_LAST | G_SIGNAL_ACTION,
|
||||
- G_STRUCT_OFFSET (EvPageActionClass, activate_link),
|
||||
+ G_STRUCT_OFFSET (EvPageActionWidgetClass, activate_link),
|
||||
NULL, NULL,
|
||||
g_cclosure_marshal_VOID__OBJECT,
|
||||
G_TYPE_NONE, 1,
|
@ -1,26 +0,0 @@
|
||||
From b3d46a631c7a105b865d51b6f774e95e703d03fc Mon Sep 17 00:00:00 2001
|
||||
From: Marek Kasik <mkasik@redhat.com>
|
||||
Date: Mon, 13 Sep 2010 14:28:53 +0200
|
||||
Subject: [PATCH] Make "Shrink to Printable Area" default option for Page Scaling
|
||||
|
||||
Shrink big pages to printable area by default.
|
||||
---
|
||||
libview/ev-print-operation.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/libview/ev-print-operation.c b/libview/ev-print-operation.c
|
||||
index b39aa4a..d14c9e7 100644
|
||||
--- a/libview/ev-print-operation.c
|
||||
+++ b/libview/ev-print-operation.c
|
||||
@@ -1846,7 +1846,7 @@ ev_print_operation_print_create_custom_widget (EvPrintOperationPrint *print,
|
||||
gboolean use_source_size;
|
||||
|
||||
settings = gtk_print_operation_get_print_settings (print->op);
|
||||
- page_scale = gtk_print_settings_get_int_with_default (settings, EV_PRINT_SETTING_PAGE_SCALE, 0);
|
||||
+ page_scale = gtk_print_settings_get_int_with_default (settings, EV_PRINT_SETTING_PAGE_SCALE, 1);
|
||||
autorotate = gtk_print_settings_has_key (settings, EV_PRINT_SETTING_AUTOROTATE) ?
|
||||
gtk_print_settings_get_bool (settings, EV_PRINT_SETTING_AUTOROTATE) :
|
||||
TRUE;
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- evince-2.91.1/evince-document.pc.in 2010-10-09 16:10:38.000000000 +0200
|
||||
+++ evince-2.91.1/evince-document.pc.in 2010-10-26 14:52:48.000000000 +0200
|
||||
@@ -7,6 +7,6 @@ backenddir=@libdir@/evince/@EV_BINARY_VE
|
||||
Name: Evince Document
|
||||
Description: GNOME document viewer backend library
|
||||
Version: @VERSION@
|
||||
-Requires: gio-2.0 >= @GLIB_REQUIRED@ gtk+-3 >= @GTK_REQUIRED@
|
||||
+Requires: gio-2.0 >= @GLIB_REQUIRED@ gtk+-3.0 >= @GTK_REQUIRED@
|
||||
Libs: -L${libdir} -levdocument3
|
||||
Cflags: -I${includedir}
|
32
evince-page-range.patch
Normal file
32
evince-page-range.patch
Normal file
@ -0,0 +1,32 @@
|
||||
commit a3b87cb28e46958b37e384a47604032ea0889807
|
||||
Author: Carlos Garcia Campos <carlosgc@gnome.org>
|
||||
Date: Sun Nov 21 12:27:21 2010 +0100
|
||||
|
||||
libview: Make sure we have a valid page range before getting/setting selection list
|
||||
|
||||
Fixes bug #630999.
|
||||
|
||||
diff --git a/libview/ev-pixbuf-cache.c b/libview/ev-pixbuf-cache.c
|
||||
index 367f70d..ee68354 100644
|
||||
--- a/libview/ev-pixbuf-cache.c
|
||||
+++ b/libview/ev-pixbuf-cache.c
|
||||
@@ -1035,6 +1035,9 @@ ev_pixbuf_cache_set_selection_list (EvPixbufCache *pixbuf_cache,
|
||||
if (!EV_IS_SELECTION (pixbuf_cache->document))
|
||||
return;
|
||||
|
||||
+ if (pixbuf_cache->start_page == -1 || pixbuf_cache->end_page == -1)
|
||||
+ return;
|
||||
+
|
||||
/* We check each area to see what needs updating, and what needs freeing; */
|
||||
page = pixbuf_cache->start_page - pixbuf_cache->preload_cache_size;
|
||||
for (i = 0; i < pixbuf_cache->preload_cache_size; i++) {
|
||||
@@ -1114,6 +1117,9 @@ ev_pixbuf_cache_get_selection_list (EvPixbufCache *pixbuf_cache)
|
||||
|
||||
g_return_val_if_fail (EV_IS_PIXBUF_CACHE (pixbuf_cache), NULL);
|
||||
|
||||
+ if (pixbuf_cache->start_page == -1 || pixbuf_cache->end_page == -1)
|
||||
+ return NULL;
|
||||
+
|
||||
/* We check each area to see what needs updating, and what needs freeing; */
|
||||
page = pixbuf_cache->start_page - pixbuf_cache->preload_cache_size;
|
||||
for (i = 0; i < pixbuf_cache->preload_cache_size; i++) {
|
10
evince.spec
10
evince.spec
@ -5,7 +5,7 @@
|
||||
|
||||
Name: evince
|
||||
Version: 2.91.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Document viewer
|
||||
|
||||
License: GPLv2+ and GFDL
|
||||
@ -14,6 +14,8 @@ URL: http://projects.gnome.org/evince/
|
||||
Source0: http://download.gnome.org/sources/%{name}/2.91/%{name}-%{version}.tar.bz2
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=562648
|
||||
Patch2: evince-t1font-mapping.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=647689
|
||||
Patch3: evince-page-range.patch
|
||||
|
||||
BuildRequires: gtk3-devel
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
@ -107,6 +109,7 @@ It adds an additional tab called "Document" to the file properties dialog.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch2 -p1 -b .t1font-map
|
||||
%patch3 -p1 -b .page-range
|
||||
|
||||
%build
|
||||
automake
|
||||
@ -240,6 +243,11 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
|
||||
%{_libdir}/nautilus/extensions-2.0/libevince-properties-page.so
|
||||
|
||||
%changelog
|
||||
* Mon Nov 22 2010 Marek Kasik <mkasik@redhat.com> - 2.91.2-2
|
||||
- Fix crash in clear_job_selection()
|
||||
- Remove unused patches
|
||||
- Resolves: #647689
|
||||
|
||||
* Thu Nov 11 2010 Matthias Clasen <mclasen@redhat.com> - 2.91.2-1
|
||||
- Update to 2.91.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user