Attempt to fix internal xulrunner compiler error, due to later compiler.
This commit is contained in:
parent
f2041c7865
commit
a082559745
12
esc-1.1.1-fix3.patch
Normal file
12
esc-1.1.1-fix3.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp.fix3 ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp
|
||||||
|
--- ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp.fix3 2018-06-07 18:38:45.365998075 -0700
|
||||||
|
+++ ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp 2018-06-07 18:40:52.597296294 -0700
|
||||||
|
@@ -10,7 +10,7 @@
|
||||||
|
|
||||||
|
#include "mozilla/ArrayUtils.h"
|
||||||
|
#include "mozilla/Attributes.h"
|
||||||
|
-
|
||||||
|
+#include <sys/sysmacros.h>
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <sys/stat.h>
|
||||||
|
#include <unistd.h>
|
2
esc.spec
2
esc.spec
@ -12,6 +12,7 @@ Group: Applications/Internet
|
|||||||
|
|
||||||
Patch1: esc-1.1.1-fix1.patch
|
Patch1: esc-1.1.1-fix1.patch
|
||||||
Patch2: esc-1.1.1-fix2.patch
|
Patch2: esc-1.1.1-fix2.patch
|
||||||
|
Patch3: esc-1.1.1-fix3.patch
|
||||||
|
|
||||||
BuildRequires: doxygen fontconfig-devel
|
BuildRequires: doxygen fontconfig-devel
|
||||||
BuildRequires: glib2-devel atk-devel
|
BuildRequires: glib2-devel atk-devel
|
||||||
@ -123,6 +124,7 @@ cryptographic smartcards.
|
|||||||
|
|
||||||
%patch1 -p1 -b .fix1
|
%patch1 -p1 -b .fix1
|
||||||
%patch2 -p1 -b .fix2
|
%patch2 -p1 -b .fix2
|
||||||
|
%patch3 -p1 -b .fix3
|
||||||
|
|
||||||
r=$(uname -r | sed -e 's/\(^[^.]*\.[^.]*\).*/\1/')
|
r=$(uname -r | sed -e 's/\(^[^.]*\.[^.]*\).*/\1/')
|
||||||
[ -f esc/coreconf/Linux$r.mk ] || ln -s Linux3.5.mk esc/coreconf/Linux$r.mk
|
[ -f esc/coreconf/Linux$r.mk ] || ln -s Linux3.5.mk esc/coreconf/Linux$r.mk
|
||||||
|
Loading…
Reference in New Issue
Block a user