Remove coolkey dependency and have esc work against opensc, port to master.
This commit is contained in:
parent
379ec37680
commit
f2041c7865
2
esc
2
esc
@ -44,6 +44,8 @@ COMPREG_DAT=compreg.dat
|
||||
LOCK_FILE=lock
|
||||
PARENT_LOCK_FILE=.parentlock
|
||||
|
||||
export OPENSC_CONF=$ESC_PATH/opensc.esc.conf
|
||||
|
||||
function isProgRunning {
|
||||
|
||||
userID=$(whoami)
|
||||
|
8237
esc-1.1.1-fix1.patch
Normal file
8237
esc-1.1.1-fix1.patch
Normal file
File diff suppressed because it is too large
Load Diff
11
esc-1.1.1-fix2.patch
Normal file
11
esc-1.1.1-fix2.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -up ./esc/src/xulrunner/xulrunner-mozconfig.fix2 ./esc/src/xulrunner/xulrunner-mozconfig
|
||||
--- ./esc/src/xulrunner/xulrunner-mozconfig.fix2 2018-04-30 13:48:53.944086197 -0700
|
||||
+++ ./esc/src/xulrunner/xulrunner-mozconfig 2018-04-30 13:49:22.804921349 -0700
|
||||
@@ -37,6 +37,7 @@ ac_add_options --disable-skia
|
||||
ac_add_options --with-system-nspr
|
||||
ac_add_options --with-system-nss
|
||||
ac_add_options --disable-crashreporter
|
||||
+ac_add_options --disable-startupcache
|
||||
|
||||
export BUILD_OFFICIAL=1
|
||||
export MOZILLA_OFFICIAL=1
|
27
esc.spec
27
esc.spec
@ -1,6 +1,6 @@
|
||||
Name: esc
|
||||
Version: 1.1.1
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Enterprise Security Client Smart Card Client
|
||||
License: GPL+
|
||||
URL: http://directory.fedora.redhat.com/wiki/CoolKey
|
||||
@ -10,6 +10,8 @@ Group: Applications/Internet
|
||||
%global libnotify_version 0.7.0
|
||||
%global libvpx_version 1.0.0
|
||||
|
||||
Patch1: esc-1.1.1-fix1.patch
|
||||
Patch2: esc-1.1.1-fix2.patch
|
||||
|
||||
BuildRequires: doxygen fontconfig-devel
|
||||
BuildRequires: glib2-devel atk-devel
|
||||
@ -17,7 +19,7 @@ BuildRequires: pkgconfig
|
||||
BuildRequires: nspr-devel nss-devel nss-static
|
||||
BuildRequires: libX11-devel libXt-devel
|
||||
|
||||
BuildRequires: pcsc-lite-devel coolkey-devel
|
||||
BuildRequires: pcsc-lite-devel
|
||||
BuildRequires: desktop-file-utils zip binutils
|
||||
BuildRequires: libnotify-devel >= %{libnotify_version}
|
||||
BuildRequires: dbus-devel
|
||||
@ -46,10 +48,11 @@ BuildRequires: yasm
|
||||
BuildRequires: dbus-glib-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: opensc
|
||||
Requires: sqlite
|
||||
|
||||
|
||||
Requires: pcsc-lite coolkey nss nspr
|
||||
Requires: pcsc-lite nss nspr
|
||||
Requires: zip dbus >= 0.90 libnotify >= 0.4.2
|
||||
Requires: mozilla-filesystem
|
||||
Requires: nspr-devel
|
||||
@ -72,12 +75,14 @@ Requires: alsa-lib-devel
|
||||
Requires: libnotify-devel
|
||||
Requires: mesa-libGL-devel
|
||||
Requires: libvpx-devel >= %{libvpx_version}
|
||||
Requires: opensc
|
||||
|
||||
|
||||
# 390 does not have coolkey or smartCards
|
||||
# 390 does not have smartCards
|
||||
ExcludeArch: s390 s390x
|
||||
#xulrunner doesn't seem to support this one
|
||||
ExcludeArch: aarch64
|
||||
#xulrunner doesn't seem to support these right now
|
||||
#Temporary anyway, since xulrunner is going away soon.
|
||||
ExcludeArch: aarch64 i686
|
||||
|
||||
# We can't allow the internal xulrunner to leak out
|
||||
AutoReqProv: 0
|
||||
@ -116,6 +121,9 @@ cryptographic smartcards.
|
||||
|
||||
#patch esc
|
||||
|
||||
%patch1 -p1 -b .fix1
|
||||
%patch2 -p1 -b .fix2
|
||||
|
||||
r=$(uname -r | sed -e 's/\(^[^.]*\.[^.]*\).*/\1/')
|
||||
[ -f esc/coreconf/Linux$r.mk ] || ln -s Linux3.5.mk esc/coreconf/Linux$r.mk
|
||||
|
||||
@ -210,10 +218,13 @@ chmod 755 $RPM_BUILD_ROOT/%{escdir}/application.ini
|
||||
%license %{docdir}/LICENSE
|
||||
|
||||
%{escdir}/esc
|
||||
%attr(755, root, root) %{escdir}/esc
|
||||
%{escdir}/escd
|
||||
%{escbindir}/esc
|
||||
%{escdir}/application.ini
|
||||
|
||||
%{escdir}/opensc.esc.conf
|
||||
%dir %{escdir}/chrome
|
||||
%dir %{escdir}/defaults
|
||||
%{escdir}/chrome.manifest
|
||||
%{escdir}/chrome/chrome.manifest
|
||||
|
||||
@ -236,6 +247,8 @@ killall --exact -q escd
|
||||
exit 0
|
||||
|
||||
%changelog
|
||||
* Mon Apr 23 2018 Jack Magne <jmagne@redhat.com> - 1.1.1-4
|
||||
- Remove coolkey dependencies, replace with opensc.
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user