Attempt to fix internal xulrunner compiler error, due to later compiler.

This commit is contained in:
Jack Magne 2018-06-08 10:36:42 -07:00
parent f2041c7865
commit a082559745
2 changed files with 14 additions and 0 deletions

12
esc-1.1.1-fix3.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp.fix3 ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp
--- ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp.fix3 2018-06-07 18:38:45.365998075 -0700
+++ ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp 2018-06-07 18:40:52.597296294 -0700
@@ -10,7 +10,7 @@
#include "mozilla/ArrayUtils.h"
#include "mozilla/Attributes.h"
-
+#include <sys/sysmacros.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <unistd.h>

View File

@ -12,6 +12,7 @@ Group: Applications/Internet
Patch1: esc-1.1.1-fix1.patch
Patch2: esc-1.1.1-fix2.patch
Patch3: esc-1.1.1-fix3.patch
BuildRequires: doxygen fontconfig-devel
BuildRequires: glib2-devel atk-devel
@ -123,6 +124,7 @@ cryptographic smartcards.
%patch1 -p1 -b .fix1
%patch2 -p1 -b .fix2
%patch3 -p1 -b .fix3
r=$(uname -r | sed -e 's/\(^[^.]*\.[^.]*\).*/\1/')
[ -f esc/coreconf/Linux$r.mk ] || ln -s Linux3.5.mk esc/coreconf/Linux$r.mk