Another attempt to solve compilation issue.

This commit is contained in:
Jack Magne 2018-06-08 16:51:51 -07:00
parent a082559745
commit 5f2975a440
2 changed files with 32 additions and 0 deletions

30
esc-1.1.1-fix4.patch Normal file
View File

@ -0,0 +1,30 @@
diff -up ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/config/system-headers.fix4 ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/config/system-headers
--- ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/config/system-headers.fix4 2018-06-08 16:19:38.502459087 -0700
+++ ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/config/system-headers 2018-06-08 16:20:33.330152105 -0700
@@ -1067,6 +1067,7 @@ sys/statvfs.h
sys/syscall.h
sys/sysctl.h
sys/sysinfo.h
+sys/sysmacros.h
sys/sysmp.h
sys/syssgi.h
sys/system_properties.h
diff -up ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp.fix4 ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp
--- ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp.fix4 2018-06-08 16:17:21.337227098 -0700
+++ ./esc/src/xulrunner/xulrunner-45.9.0/firefox-45.9.0esr/xpcom/io/nsLocalFileUnix.cpp 2018-06-08 16:18:16.820916423 -0700
@@ -10,7 +10,6 @@
#include "mozilla/ArrayUtils.h"
#include "mozilla/Attributes.h"
-#include <sys/sysmacros.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <unistd.h>
@@ -28,6 +27,7 @@
#define USE_LINUX_QUOTACTL
#include <sys/mount.h>
#include <sys/quota.h>
+#include <sys/sysmacros.h>
#ifndef BLOCK_SIZE
#define BLOCK_SIZE 1024 /* kernel block size */
#endif

View File

@ -13,6 +13,7 @@ Group: Applications/Internet
Patch1: esc-1.1.1-fix1.patch
Patch2: esc-1.1.1-fix2.patch
Patch3: esc-1.1.1-fix3.patch
Patch4: esc-1.1.1-fix4.patch
BuildRequires: doxygen fontconfig-devel
BuildRequires: glib2-devel atk-devel
@ -125,6 +126,7 @@ cryptographic smartcards.
%patch1 -p1 -b .fix1
%patch2 -p1 -b .fix2
%patch3 -p1 -b .fix3
%patch4 -p1 -b .fix4
r=$(uname -r | sed -e 's/\(^[^.]*\.[^.]*\).*/\1/')
[ -f esc/coreconf/Linux$r.mk ] || ln -s Linux3.5.mk esc/coreconf/Linux$r.mk