enchant2/enchant_aspell.patch
2022-08-05 00:34:12 +02:00

24 lines
1.2 KiB
Diff

diff -rupN enchant-2.3.3/configure.ac enchant-2.3.3-new/configure.ac
--- enchant-2.3.3/configure.ac 2022-04-16 17:54:39.000000000 +0200
+++ enchant-2.3.3-new/configure.ac 2022-04-17 16:45:50.345963145 +0200
@@ -214,7 +214,7 @@ build_providers=
dnl Standard providers
ENCHANT_CHECK_PKG_CONFIG_PROVIDER([hunspell], [HUNSPELL])
ENCHANT_CHECK_PKG_CONFIG_PROVIDER([nuspell], [NUSPELL], [nuspell >= 5.1.0])
-ENCHANT_CHECK_LIB_PROVIDER([aspell], [ASPELL], [get_aspell_dict_info_list])
+ENCHANT_CHECK_PKG_CONFIG_PROVIDER([aspell], [ASPELL])
ENCHANT_CHECK_LIB_PROVIDER([hspell], [HSPELL], [hspell_get_dictionary_path],, [-lz])
ENCHANT_CHECK_PKG_CONFIG_PROVIDER([voikko], [VOIKKO], [libvoikko])
dnl FIXME: The test below assumes GCC(-compatible) ObjC++ compiler, but
diff -rupN enchant-2.3.3/providers/Makefile.am enchant-2.3.3-new/providers/Makefile.am
--- enchant-2.3.3/providers/Makefile.am 2020-02-27 14:05:18.000000000 +0100
+++ enchant-2.3.3-new/providers/Makefile.am 2022-04-17 16:45:37.671869795 +0200
@@ -12,6 +12,7 @@ AM_LDFLAGS = -module -avoid-version -no-
if WITH_ASPELL
provider_LTLIBRARIES += enchant_aspell.la
endif
+enchant_aspell_la_LIBADD = $(ASPELL_LIBS)
if WITH_HSPELL
provider_LTLIBRARIES += enchant_hspell.la