Update to 2.3.3
This commit is contained in:
parent
7aa8c9386e
commit
698af5bf38
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
||||
/enchant-2.3.0.tar.gz
|
||||
/enchant-2.3.1.tar.gz
|
||||
/enchant-2.3.2.tar.gz
|
||||
/enchant-2.3.3.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: enchant2
|
||||
Version: 2.3.2
|
||||
Release: 8%{?snap}%{?dist}
|
||||
Version: 2.3.3
|
||||
Release: 1%{?snap}%{?dist}
|
||||
Summary: An Enchanting Spell Checking Library
|
||||
|
||||
License: LGPLv2+
|
||||
@ -14,28 +14,31 @@ Patch0: enchant_aspell.patch
|
||||
BuildRequires: automake autoconf libtool
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: make
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: aspell-devel
|
||||
BuildRequires: hunspell-devel
|
||||
BuildRequires: libvoikko-devel
|
||||
%if !0%{?rhel}
|
||||
BuildRequires: nuspell-devel >= 4.1.0
|
||||
BuildRequires: nuspell-devel
|
||||
%endif
|
||||
BuildRequires: make
|
||||
|
||||
BuildRequires: mingw32-filesystem >= 131
|
||||
BuildRequires: mingw32-gcc
|
||||
BuildRequires: mingw32-gcc-c++
|
||||
BuildRequires: mingw32-binutils
|
||||
BuildRequires: mingw32-glib2
|
||||
BuildRequires: mingw32-hunspell
|
||||
%if !0%{?rhel}
|
||||
BuildRequires: mingw32-nuspell
|
||||
%endif
|
||||
|
||||
|
||||
BuildRequires: mingw64-filesystem >= 131
|
||||
BuildRequires: mingw64-gcc
|
||||
BuildRequires: mingw64-gcc-c++
|
||||
BuildRequires: mingw64-binutils
|
||||
BuildRequires: mingw64-glib2
|
||||
BuildRequires: mingw64-hunspell
|
||||
%if !0%{?rhel}
|
||||
BuildRequires: mingw64-nuspell
|
||||
%endif
|
||||
|
||||
Provides: bundled(gnulib)
|
||||
|
||||
@ -188,6 +191,8 @@ find %{buildroot} -name '*.la' -delete
|
||||
%dir %{mingw32_libdir}/enchant-2/
|
||||
%{mingw32_libdir}/enchant-2/enchant_hunspell.dll
|
||||
%{mingw32_libdir}/enchant-2/enchant_hunspell.dll.a
|
||||
%{mingw32_libdir}/enchant-2/enchant_nuspell.dll
|
||||
%{mingw32_libdir}/enchant-2/enchant_nuspell.dll.a
|
||||
%{mingw32_libdir}/libenchant-2.dll.a
|
||||
%{mingw32_libdir}/pkgconfig/enchant-2.pc
|
||||
%{mingw32_datadir}/enchant-2/
|
||||
@ -201,12 +206,17 @@ find %{buildroot} -name '*.la' -delete
|
||||
%dir %{mingw64_libdir}/enchant-2/
|
||||
%{mingw64_libdir}/enchant-2/enchant_hunspell.dll
|
||||
%{mingw64_libdir}/enchant-2/enchant_hunspell.dll.a
|
||||
%{mingw64_libdir}/enchant-2/enchant_nuspell.dll
|
||||
%{mingw64_libdir}/enchant-2/enchant_nuspell.dll.a
|
||||
%{mingw64_libdir}/libenchant-2.dll.a
|
||||
%{mingw64_libdir}/pkgconfig/enchant-2.pc
|
||||
%{mingw64_datadir}/enchant-2/
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 01 2022 Sandro Mani <manisandro@gmail.com> - 2.3.3-1
|
||||
- Update to 2.3.3
|
||||
|
||||
* Mon Aug 01 2022 Frantisek Zatloukal <fzatlouk@redhat.com> - 2.3.2-8
|
||||
- Rebuilt for ICU 71.1
|
||||
|
||||
|
@ -1,18 +1,18 @@
|
||||
diff -rupN --no-dereference enchant-2.3.1/configure.ac enchant-2.3.1-new/configure.ac
|
||||
--- enchant-2.3.1/configure.ac 2021-08-10 11:15:37.000000000 +0200
|
||||
+++ enchant-2.3.1-new/configure.ac 2021-08-11 07:51:50.048642397 +0200
|
||||
@@ -210,7 +210,7 @@ build_providers=
|
||||
diff -rupN enchant-2.3.3/configure.ac enchant-2.3.3-new/configure.ac
|
||||
--- enchant-2.3.3/configure.ac 2022-04-16 17:54:39.000000000 +0200
|
||||
+++ enchant-2.3.3-new/configure.ac 2022-04-17 16:45:50.345963145 +0200
|
||||
@@ -214,7 +214,7 @@ build_providers=
|
||||
dnl Standard providers
|
||||
ENCHANT_CHECK_PKG_CONFIG_PROVIDER([hunspell], [HUNSPELL])
|
||||
ENCHANT_CHECK_PKG_CONFIG_PROVIDER([nuspell], [NUSPELL], [nuspell >= 4.1.0])
|
||||
ENCHANT_CHECK_PKG_CONFIG_PROVIDER([nuspell], [NUSPELL], [nuspell >= 5.1.0])
|
||||
-ENCHANT_CHECK_LIB_PROVIDER([aspell], [ASPELL], [get_aspell_dict_info_list])
|
||||
+ENCHANT_CHECK_PKG_CONFIG_PROVIDER([aspell], [ASPELL])
|
||||
ENCHANT_CHECK_LIB_PROVIDER([hspell], [HSPELL], [hspell_get_dictionary_path],, [-lz])
|
||||
ENCHANT_CHECK_PKG_CONFIG_PROVIDER([voikko], [VOIKKO], [libvoikko])
|
||||
dnl FIXME: The test below assumes GCC(-compatible) ObjC++ compiler, but
|
||||
diff -rupN --no-dereference enchant-2.3.1/providers/Makefile.am enchant-2.3.1-new/providers/Makefile.am
|
||||
--- enchant-2.3.1/providers/Makefile.am 2020-10-16 11:51:01.000000000 +0200
|
||||
+++ enchant-2.3.1-new/providers/Makefile.am 2021-08-11 07:51:50.049642391 +0200
|
||||
diff -rupN enchant-2.3.3/providers/Makefile.am enchant-2.3.3-new/providers/Makefile.am
|
||||
--- enchant-2.3.3/providers/Makefile.am 2020-02-27 14:05:18.000000000 +0100
|
||||
+++ enchant-2.3.3-new/providers/Makefile.am 2022-04-17 16:45:37.671869795 +0200
|
||||
@@ -12,6 +12,7 @@ AM_LDFLAGS = -module -avoid-version -no-
|
||||
if WITH_ASPELL
|
||||
provider_LTLIBRARIES += enchant_aspell.la
|
||||
@ -21,9 +21,3 @@ diff -rupN --no-dereference enchant-2.3.1/providers/Makefile.am enchant-2.3.1-ne
|
||||
|
||||
if WITH_HSPELL
|
||||
provider_LTLIBRARIES += enchant_hspell.la
|
||||
diff -rupN --no-dereference enchant-2.3.1/tests/test.pwl.orig enchant-2.3.1-new/tests/test.pwl.orig
|
||||
--- enchant-2.3.1/tests/test.pwl.orig 2017-02-04 18:34:34.000000000 +0100
|
||||
+++ enchant-2.3.1-new/tests/test.pwl.orig 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,2 +0,0 @@
|
||||
-hello
|
||||
-tag
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (enchant-2.3.2.tar.gz) = 886635bb55c5f0c774445e4a0f14d39e2d08eeb964257037062c2e97c2cf3348be8c631ff5e7a13144936127761964bdc60ff1e0dd6f63b292a655626f91ef62
|
||||
SHA512 (enchant-2.3.3.tar.gz) = c97764a8f219033b440cbfb820624f54993b19ba1f38b56f20336889304f753c7c513008bb92cd1424bfbf528c2d473f35bef93d9140063612e3a270fd000deb
|
||||
|
Loading…
Reference in New Issue
Block a user