New upstream release v1.42.11

This commit is contained in:
Eric Sandeen 2014-07-11 09:56:16 -05:00
parent eadfb58aa9
commit 5c68a6340a
5 changed files with 7 additions and 77 deletions

1
.gitignore vendored
View File

@ -18,3 +18,4 @@ e2fsprogs-1.41.12.tar.gz
/e2fsprogs-1.42.8.tar.gz
/e2fsprogs-1.42.9.tar.xz
/e2fsprogs-1.42.10.tar.xz
/e2fsprogs-1.42.11.tar.xz

View File

@ -1,42 +0,0 @@
[PATCH] mke2fs: use ext2fs_open_file() in check_plausibility()
The commit:
802146c mke2fs: create a regular file if necessary
caused a regression on 32-bit machines; the open() fails if
the file size is > 4G.
Using ext2fs_open_file() fixes it.
Resolves: Red Hat Bugzilla #1099892
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
---
V2: against master! Sorry, first patch was against the
bisection point.
TBH I don't know if this should be using ext2fs_open_file(),
or some other magic like O_LARGEFILE, but this works for me,
and we use the stat/fstat wrapper here too, so ...
diff --git a/misc/util.c b/misc/util.c
index 1c0818f..9475fc6 100644
--- a/misc/util.c
+++ b/misc/util.c
@@ -194,10 +194,10 @@ int check_plausibility(const char *device, int flags, int *ret_is_dev)
char *fs_type = NULL;
char *fs_label = NULL;
- fd = open(device, fl, 0666);
+ fd = ext2fs_open_file(device, fl, 0666);
if ((fd < 0) && (errno == ENOENT) && (flags & CREATE_FILE)) {
fl |= O_CREAT;
- fd = open(device, fl, 0666);
+ fd = ext2fs_open_file(device, fl, 0666);
if (fd >= 0 && (flags & VERBOSE_CREATE))
printf(_("Creating regular file %s\n"), device);
}

View File

@ -1,28 +0,0 @@
From 5c15bf5f978bae01f1ca3cbe6414ab1d355a6adf Mon Sep 17 00:00:00 2001
From: Theodore Ts'o <tytso@mit.edu>
Date: Thu, 22 May 2014 18:52:27 -0400
Subject: e2fsck: fix Makefile dependency for quota.o
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
diff --git a/e2fsck/Makefile.in b/e2fsck/Makefile.in
index 4b10f6f..f773fea 100644
--- a/e2fsck/Makefile.in
+++ b/e2fsck/Makefile.in
@@ -552,3 +552,13 @@ logfile.o: $(srcdir)/logfile.c $(top_builddir)/lib/config.h \
$(top_srcdir)/lib/quota/dqblk_v2.h $(top_srcdir)/lib/quota/quotaio_tree.h \
$(top_srcdir)/lib/../e2fsck/dict.h
prof_err.o: prof_err.c
+quota.o: $(srcdir)/quota.c $(top_builddir)/lib/config.h \
+ $(top_builddir)/lib/dirpaths.h $(srcdir)/e2fsck.h \
+ $(top_srcdir)/lib/ext2fs/ext2_fs.h $(top_builddir)/lib/ext2fs/ext2_types.h \
+ $(top_srcdir)/lib/ext2fs/ext2fs.h $(top_srcdir)/lib/ext2fs/ext3_extents.h \
+ $(top_srcdir)/lib/et/com_err.h $(top_srcdir)/lib/ext2fs/ext2_io.h \
+ $(top_builddir)/lib/ext2fs/ext2_err.h \
+ $(top_srcdir)/lib/ext2fs/ext2_ext_attr.h $(top_srcdir)/lib/ext2fs/bitops.h \
+ $(srcdir)/profile.h prof_err.h $(top_srcdir)/lib/quota/quotaio.h \
+ $(top_srcdir)/lib/quota/dqblk_v2.h $(top_srcdir)/lib/quota/quotaio_tree.h \
+ $(top_srcdir)/lib/../e2fsck/dict.h $(srcdir)/problem.h
--
cgit v0.10.1

View File

@ -1,7 +1,7 @@
Summary: Utilities for managing ext2, ext3, and ext4 filesystems
Name: e2fsprogs
Version: 1.42.10
Release: 5%{?dist}
Version: 1.42.11
Release: 1%{?dist}
# License tags based on COPYING file distinctions for various components
License: GPLv2
@ -11,8 +11,6 @@ Source1: ext2_types-wrapper.h
Source2: e2fsck.conf
Patch1: e2fsprogs-1.40.4-sb_feature_check_ignore.patch
Patch2: e2fsprogs-1.42.10-largefile.patch
Patch3: e2fsprogs-1.42.10-quota-deps.patch
Url: http://e2fsprogs.sourceforge.net/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -152,8 +150,6 @@ It was originally inspired by the Multics SubSystem library.
# mildly unsafe but 'til I get something better, avoid full fsck
# after an selinux install...
%patch1 -p1 -b .featurecheck
%patch2 -p1
%patch3 -p1
%build
%configure --enable-elf-shlibs --enable-nls --disable-uuidd --disable-fsck \
@ -329,6 +325,9 @@ exit 0
%{_libdir}/pkgconfig/ss.pc
%changelog
* Fri Jul 11 2014 Eric Sandeen <sandeen@redhat.com> 1.42.11-1
- New upstream release
* Tue Jul 01 2014 Dan Horák <dan@danny.cz> - 1.42.10-5
- Rebuilt for buggy rpm 4.12 alpha -
https://lists.fedoraproject.org/pipermail/devel/2014-June/200633.html

View File

@ -1 +1 @@
eace3779a1ddc2a0d7886061ef8eade9 e2fsprogs-1.42.10.tar.xz
cc267f88eaedf81709b144d1fe722f8c e2fsprogs-1.42.11.tar.xz