updated to 2.1.7
- v2.1.5: Using "~/" as mail_location or elsewhere failed to actually expand it to home directory. - dbox: Fixed potential assert-crash when reading dbox files. - trash plugin: Fixed behavior when quota is already over limit. - mail_log plugin: Logging "copy" event didn't work. - Proxying to backend server with SSL: Verifying server certificate name always failed, because it was compared to an IP address.
This commit is contained in:
parent
e9950ef716
commit
8176def266
1
.gitignore
vendored
1
.gitignore
vendored
@ -48,3 +48,4 @@ pigeonhole-snap0592366457df.tar.bz2
|
|||||||
/dovecot-2.1.4.tar.gz
|
/dovecot-2.1.4.tar.gz
|
||||||
/dovecot-2.1.5.tar.gz
|
/dovecot-2.1.5.tar.gz
|
||||||
/dovecot-2.1.6.tar.gz
|
/dovecot-2.1.6.tar.gz
|
||||||
|
/dovecot-2.1.7.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up dovecot-2.1.6/src/master/service-listen.c.systemdfix dovecot-2.1.6/src/master/service-listen.c
|
|
||||||
--- dovecot-2.1.6/src/master/service-listen.c.systemdfix 2012-05-04 23:14:02.000000000 +0200
|
|
||||||
+++ dovecot-2.1.6/src/master/service-listen.c 2012-05-09 13:07:39.827730993 +0200
|
|
||||||
@@ -339,7 +339,7 @@ int services_listen(struct service_list
|
|
||||||
}
|
|
||||||
|
|
||||||
#ifdef HAVE_SYSTEMD
|
|
||||||
- if (ret == 0)
|
|
||||||
+ if (ret > 0)
|
|
||||||
services_verify_systemd(service_list);
|
|
||||||
#endif
|
|
||||||
return ret;
|
|
16
dovecot.spec
16
dovecot.spec
@ -1,9 +1,9 @@
|
|||||||
Summary: Secure imap and pop3 server
|
Summary: Secure imap and pop3 server
|
||||||
Name: dovecot
|
Name: dovecot
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.1.6
|
Version: 2.1.7
|
||||||
#global prever .rc6
|
#global prever .rc6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
|
||||||
License: MIT and LGPLv2
|
License: MIT and LGPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -27,7 +27,6 @@ Patch1: dovecot-2.0-defaultconfig.patch
|
|||||||
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
|
||||||
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
|
||||||
Patch4: dovecot-2.1-privatetmp.patch
|
Patch4: dovecot-2.1-privatetmp.patch
|
||||||
Patch5: dovecot-2.1.6-systemdfix.patch
|
|
||||||
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
|
||||||
@ -112,7 +111,6 @@ This package provides the development files for dovecot.
|
|||||||
%patch2 -p1 -b .mkcert-permissions
|
%patch2 -p1 -b .mkcert-permissions
|
||||||
%patch3 -p1 -b .mkcert-paths
|
%patch3 -p1 -b .mkcert-paths
|
||||||
%patch4 -p1 -b .privatetmp
|
%patch4 -p1 -b .privatetmp
|
||||||
%patch5 -p1 -b .systemdfix
|
|
||||||
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -429,6 +427,16 @@ make check
|
|||||||
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
%{_libdir}/%{name}/dict/libdriver_pgsql.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 30 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1.7-1
|
||||||
|
- updated to 2.1.7
|
||||||
|
- v2.1.5: Using "~/" as mail_location or elsewhere failed to actually
|
||||||
|
expand it to home directory.
|
||||||
|
- dbox: Fixed potential assert-crash when reading dbox files.
|
||||||
|
- trash plugin: Fixed behavior when quota is already over limit.
|
||||||
|
- mail_log plugin: Logging "copy" event didn't work.
|
||||||
|
- Proxying to backend server with SSL: Verifying server certificate
|
||||||
|
name always failed, because it was compared to an IP address.
|
||||||
|
|
||||||
* Wed May 09 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1.6-2
|
* Wed May 09 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1.6-2
|
||||||
- fix socket activation again, fix in 2.1.6 is incomplete
|
- fix socket activation again, fix in 2.1.6 is incomplete
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user