fix socket activation again, fix in 2.1.6 is incomplete

This commit is contained in:
Michal Hlavinka 2012-05-09 17:03:55 +02:00
parent 04f6a1d889
commit e9950ef716
2 changed files with 18 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up dovecot-2.1.6/src/master/service-listen.c.systemdfix dovecot-2.1.6/src/master/service-listen.c
--- dovecot-2.1.6/src/master/service-listen.c.systemdfix 2012-05-04 23:14:02.000000000 +0200
+++ dovecot-2.1.6/src/master/service-listen.c 2012-05-09 13:07:39.827730993 +0200
@@ -339,7 +339,7 @@ int services_listen(struct service_list
}
#ifdef HAVE_SYSTEMD
- if (ret == 0)
+ if (ret > 0)
services_verify_systemd(service_list);
#endif
return ret;

View File

@ -3,7 +3,7 @@ Name: dovecot
Epoch: 1
Version: 2.1.6
#global prever .rc6
Release: 1%{?dist}
Release: 2%{?dist}
#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
License: MIT and LGPLv2
Group: System Environment/Daemons
@ -27,6 +27,7 @@ Patch1: dovecot-2.0-defaultconfig.patch
Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
Patch3: dovecot-1.0.rc7-mkcert-paths.patch
Patch4: dovecot-2.1-privatetmp.patch
Patch5: dovecot-2.1.6-systemdfix.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: openssl-devel, pam-devel, zlib-devel, bzip2-devel, libcap-devel
@ -111,6 +112,7 @@ This package provides the development files for dovecot.
%patch2 -p1 -b .mkcert-permissions
%patch3 -p1 -b .mkcert-paths
%patch4 -p1 -b .privatetmp
%patch5 -p1 -b .systemdfix
sed -i '/DEFAULT_INCLUDES *=/s|$| '"$(pkg-config --cflags libclucene-core)|" src/plugins/fts-lucene/Makefile.in
%build
@ -427,6 +429,9 @@ make check
%{_libdir}/%{name}/dict/libdriver_pgsql.so
%changelog
* Wed May 09 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1.6-2
- fix socket activation again, fix in 2.1.6 is incomplete
* Wed May 09 2012 Michal Hlavinka <mhlavink@redhat.com> - 1:2.1.6-1
- v2.1.5: Using "~/" as mail_location or elsewhere failed to actually
expand it to home directory.