import dotnet5.0-5.0.202-2.el8

This commit is contained in:
CentOS Sources 2021-05-05 22:15:25 +00:00 committed by Andrew Lukoshko
parent ce59e4036f
commit b956265dcb
6 changed files with 18 additions and 60 deletions

View File

@ -1 +1 @@
4c29720e364b8d4c2cf8809085da20141b849c17 SOURCES/dotnet-v5.0.104-SDK.tar.gz
1c965a7ecefcf4745de02ad9d17de1fefb5f2165 SOURCES/dotnet-v5.0.202-SDK.tar.gz

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/dotnet-v5.0.104-SDK.tar.gz
SOURCES/dotnet-v5.0.202-SDK.tar.gz

View File

@ -1,21 +0,0 @@
diff --git a/src/installer/corehost/cli/apphost/static/CMakeLists.txt b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
index 85ea6ffe642..e6369f6b9ad 100644
--- a/src/installer/corehost/cli/apphost/static/CMakeLists.txt
+++ b/src/installer/corehost/cli/apphost/static/CMakeLists.txt
@@ -207,12 +207,12 @@
libhostcommon
${CORECLR_LIBRARIES}
- ${ZLIB_LIBRARIES}
- ${LIBGSS}
- ${NATIVE_LIBS_EXTRA}
-
${START_WHOLE_ARCHIVE}
${RUNTIMEINFO_LIB}
${NATIVE_LIBS}
${END_WHOLE_ARCHIVE}
+
+ ${ZLIB_LIBRARIES}
+ ${LIBGSS}
+ ${NATIVE_LIBS_EXTRA}
)

View File

@ -15,4 +15,4 @@ index de1ebb9e6..6bbf479de 100644
+
DebugHelper.HandleDebugSwitch(ref args);
new MulticoreJitActivator().TryActivateMulticoreJit();
// Capture the current timestamp to calculate the host overhead.

View File

@ -1,13 +0,0 @@
--- a/patches/runtime/0010-Fix-singlefilehost-build-in-non-portable-mode-42415.patch
+++ b/patches/runtime/0010-Fix-singlefilehost-build-in-non-portable-mode-42415.patch
@@ -45,8 +45,8 @@
# These options are used to force every object to be included even if it's unused.
set(START_WHOLE_ARCHIVE -Wl,--whole-archive)
@@ -216,3 +221,10 @@ target_link_libraries(
- ${NATIVE_LIBS}
- ${END_WHOLE_ARCHIVE}
+ ${LIBGSS}
+ ${NATIVE_LIBS_EXTRA}
)
+
+if(NOT FEATURE_DISTRO_AGNOSTIC_SSL)

View File

@ -20,10 +20,10 @@
# until that's done, disable LTO. This has to happen before setting the flags below.
%define _lto_cflags %{nil}
%global host_version 5.0.4
%global runtime_version 5.0.4
%global host_version 5.0.5
%global runtime_version 5.0.5
%global aspnetcore_runtime_version %{runtime_version}
%global sdk_version 5.0.104
%global sdk_version 5.0.202
%global templates_version %{runtime_version}
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
@ -67,12 +67,6 @@ Source0: dotnet-v%{src_version}-SDK.tar.gz
Source1: check-debug-symbols.py
Source2: dotnet.sh.in
Patch1: source-build-runtime-fixup-linker-order.patch
# https://github.com/dotnet/runtime/pull/42094
# Fix linker order when linking with --as-needed
Patch100: runtime-linker-order.patch
# Disable telemetry by default; make it opt-in
Patch500: sdk-telemetry-optout.patch
@ -86,9 +80,9 @@ ExclusiveArch: x86_64
BuildRequires: clang
BuildRequires: cmake
BuildRequires: coreutils
BuildRequires: dotnet-sdk-5.0
%if %{without bootstrap}
BuildRequires: dotnet-build-reference-packages
BuildRequires: dotnet-sdk-5.0
BuildRequires: dotnet-sdk-5.0-source-built-artifacts
%endif
BuildRequires: findutils
@ -336,10 +330,7 @@ sed -i 's|/usr/share/dotnet|%{_libdir}/dotnet|' src/dotnet-runtime.*/src/install
# Disable warnings
sed -i 's|skiptests|skiptests ignorewarnings|' repos/runtime.common.props
%patch1 -p1
pushd src/dotnet-runtime.*
%patch100 -p1
popd
pushd src/dotnet-sdk.*
@ -359,9 +350,9 @@ find -iname 'nuget.config' -exec echo {}: \; -exec cat {} \; -exec echo \;
%build
cat /etc/os-release
cp -a %{_libdir}/dotnet previously-built-dotnet
%if %{without bootstrap}
# We need to create a copy because we will mutate this
cp -a %{_libdir}/dotnet previously-built-dotnet
%endif
%if 0%{?fedora} > 32 || 0%{?rhel} > 8
@ -403,8 +394,8 @@ unset LDFLAGS
#%%endif
VERBOSE=1 ./build.sh \
%if %{without bootstrap}
--with-sdk previously-built-dotnet \
%if %{without bootstrap}
%endif
-- \
/v:n \
@ -467,8 +458,8 @@ echo "%{_libdir}/dotnet" >> install_location
install -dm 0755 %{buildroot}%{_sysconfdir}/dotnet
install install_location %{buildroot}%{_sysconfdir}/dotnet/
#install -dm 0755 %%{buildroot}%%{_libdir}/dotnet/source-built-artifacts
#install artifacts/%%{runtime_arch}/Release/Private.SourceBuilt.Artifacts.*.tar.gz %%{buildroot}/%%{_libdir}/dotnet/source-built-artifacts/
install -dm 0755 %{buildroot}%{_libdir}/dotnet/source-built-artifacts
install artifacts/%{runtime_arch}/Release/Private.SourceBuilt.Artifacts.*.tar.gz %{buildroot}/%{_libdir}/dotnet/source-built-artifacts/
# Check debug symbols in all elf objects. This is not in %%check
# because native binaries are stripped by rpm-build after %%install.
@ -522,15 +513,16 @@ echo "Testing build results for debug symbols..."
%{_libdir}/dotnet/sdk/%{sdk_version}
%dir %{_libdir}/dotnet/packs
#%%files -n dotnet-sdk-5.0-source-built-artifacts
#%%dir %%{_libdir}/dotnet
#%%{_libdir}/dotnet/source-built-artifacts
%files -n dotnet-sdk-5.0-source-built-artifacts
%dir %{_libdir}/dotnet
%{_libdir}/dotnet/source-built-artifacts
%changelog
* Tue Mar 09 2021 Omair Majid <omajid@redhat.com> - 5.0.104-2
- Update to .NET SDK 5.0.104 and Runtime 5.0.4
- Resolves: RHBZ#1934241
* Thu Apr 22 2021 Omair Majid <omajid@redhat.com> - 5.0.202-2
- Update to .NET SDK 5.0.202 and Runtime 5.0.5
- Create -source-built-artifacts subpackage
- Resolves: RHBZ#1947600
* Wed Feb 10 2021 Omair Majid <omajid@redhat.com> - 5.0.103-2
- Update to .NET SDK 5.0.103 and Runtime 5.0.3