add patch to respact baseurl in metadata rhbz#1245286
This commit is contained in:
parent
7608f7102f
commit
85b88dbcae
16
baseurl.patch
Normal file
16
baseurl.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -Naur a/py3/dnf/package.py b/py3/dnf/package.py
|
||||
--- a/dnf/package.py 2015-06-09 06:46:26.000000000 -0400
|
||||
+++ b/dnf/package.py 2015-07-21 12:26:00.000000000 -0400
|
||||
@@ -164,6 +164,11 @@
|
||||
loc = self.location
|
||||
if not self.repo.local:
|
||||
loc = os.path.basename(loc)
|
||||
+ if self.baseurl:
|
||||
+ path = os.path.join(self.baseurl, self.location)
|
||||
+ if path.startswith("file://"):
|
||||
+ path = path[7:]
|
||||
+ return path
|
||||
return os.path.join(self.repo.pkgdir, loc)
|
||||
|
||||
# yum compatibility method
|
||||
|
8
dnf.spec
8
dnf.spec
@ -11,7 +11,7 @@
|
||||
|
||||
Name: dnf
|
||||
Version: 1.0.2
|
||||
Release: 2%{?snapshot}%{?dist}
|
||||
Release: 2%{?snapshot}%{?dist}.1
|
||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
@ -22,6 +22,8 @@ URL: https://github.com/rpm-software-management/dnf
|
||||
# ./archive
|
||||
# tarball will be generated in $HOME/rpmbuild/sources/
|
||||
Source0: http://rpm-software-management.fedorapeople.org/dnf-%{version}.tar.gz
|
||||
Patch0: baseurl.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -119,6 +121,7 @@ Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
|
||||
|
||||
%prep
|
||||
%setup -q -n dnf-%{version}
|
||||
%patch0 -p1
|
||||
rm -rf py3
|
||||
mkdir ../py3
|
||||
cp -a . ../py3/
|
||||
@ -250,6 +253,9 @@ exit 0
|
||||
%systemd_postun_with_restart dnf-automatic.timer
|
||||
|
||||
%changelog
|
||||
* Tue Jul 21 2015 Dennis Gilmore <dennis@ausil.us> 1.0.2-2.1
|
||||
- add patch to respact baseurl in metadata rhbz#1245286
|
||||
|
||||
* Tue Jul 21 2015 Jan Silhan <jsilhan@redhat.com> 1.0.2-2
|
||||
- fixed python3 syntax error from f427aa2 (Jan Silhan)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user