Update dnf to 1.0.2-2
This commit is contained in:
parent
ea9a716cb0
commit
7608f7102f
1
.gitignore
vendored
1
.gitignore
vendored
@ -76,3 +76,4 @@
|
||||
/dnf-0.6.5.tar.gz
|
||||
/dnf-1.0.0.tar.gz
|
||||
/dnf-1.0.1.tar.gz
|
||||
/dnf-1.0.2.tar.gz
|
||||
|
@ -1,40 +0,0 @@
|
||||
From f676801b93c6a3b9261e9524f8da249bd341e2a8 Mon Sep 17 00:00:00 2001
|
||||
From: Michal Luscon <mluscon@redhat.com>
|
||||
Date: Tue, 9 Jun 2015 15:15:30 +0200
|
||||
Subject: [PATCH 1/3] conf: change minrate threshold to librepo default
|
||||
(RhBug:1212320)
|
||||
|
||||
---
|
||||
dnf/yum/config.py | 2 +-
|
||||
doc/conf_ref.rst | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/dnf/yum/config.py b/dnf/yum/config.py
|
||||
index 1be7167..803eb3b 100644
|
||||
--- a/dnf/yum/config.py
|
||||
+++ b/dnf/yum/config.py
|
||||
@@ -772,7 +772,7 @@ class YumConf(BaseConfig):
|
||||
enablegroups = BoolOption(True)
|
||||
|
||||
bandwidth = BytesOption(0)
|
||||
- minrate = BytesOption(0)
|
||||
+ minrate = BytesOption(1000)
|
||||
ip_resolve = CaselessSelectionOption(
|
||||
allowed=('ipv4', 'ipv6', 'whatever'),
|
||||
mapper={'4': 'ipv4', '6': 'ipv6'})
|
||||
diff --git a/doc/conf_ref.rst b/doc/conf_ref.rst
|
||||
index 0dbf87e..958e9fd 100644
|
||||
--- a/doc/conf_ref.rst
|
||||
+++ b/doc/conf_ref.rst
|
||||
@@ -294,7 +294,7 @@ configuration.
|
||||
``minrate``
|
||||
storage size
|
||||
|
||||
- This sets the low speed threshold in bytes per second. If the server is sending data at the same or slower speed than this value for at least :ref:`timeout option <timeout-label>` seconds, DNF aborts the connection. The default is 0. Valid units are 'k', 'M', 'G'.
|
||||
+ This sets the low speed threshold in bytes per second. If the server is sending data at the same or slower speed than this value for at least :ref:`timeout option <timeout-label>` seconds, DNF aborts the connection. The default is 1000. Valid units are 'k', 'M', 'G'.
|
||||
|
||||
``proxy``
|
||||
string
|
||||
--
|
||||
2.4.2
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 784501a9b3b2c30610e67754ec4aaa2a26096022 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Silhan <jsilhan@redhat.com>
|
||||
Date: Wed, 10 Jun 2015 15:11:31 +0200
|
||||
Subject: [PATCH 2/3] group: fixed installing of already installed environment
|
||||
|
||||
---
|
||||
dnf/base.py | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/dnf/base.py b/dnf/base.py
|
||||
index e1b32e6..2be68f2 100644
|
||||
--- a/dnf/base.py
|
||||
+++ b/dnf/base.py
|
||||
@@ -1193,8 +1193,9 @@ class Base(object):
|
||||
types = self._translate_comps_pkg_types(types)
|
||||
trans = dnf.comps.install_or_skip(solver.environment_install,
|
||||
env, types, exclude or set())
|
||||
- if trans:
|
||||
- return self._add_comps_trans(trans)
|
||||
+ if not trans:
|
||||
+ return 0
|
||||
+ return self._add_comps_trans(trans)
|
||||
|
||||
def environment_remove(self, env):
|
||||
solver = self.build_comps_solver()
|
||||
--
|
||||
2.4.2
|
||||
|
76
dnf.spec
76
dnf.spec
@ -1,4 +1,4 @@
|
||||
%global hawkey_version 0.5.5
|
||||
%global hawkey_version 0.5.9
|
||||
%global librepo_version 1.7.16
|
||||
%global libcomps_version 0.1.6
|
||||
%global rpm_version 4.12.0
|
||||
@ -10,8 +10,8 @@
|
||||
%global py3pluginpath %{python3_sitelib}/dnf-plugins
|
||||
|
||||
Name: dnf
|
||||
Version: 1.0.1
|
||||
Release: 3%{?snapshot}%{?dist}
|
||||
Version: 1.0.2
|
||||
Release: 2%{?snapshot}%{?dist}
|
||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
@ -22,8 +22,6 @@ URL: https://github.com/rpm-software-management/dnf
|
||||
# ./archive
|
||||
# tarball will be generated in $HOME/rpmbuild/sources/
|
||||
Source0: http://rpm-software-management.fedorapeople.org/dnf-%{version}.tar.gz
|
||||
Patch0: 0001-conf-change-minrate-threshold-to-librepo-default-RhB.patch
|
||||
Patch1: 0002-group-fixed-installing-of-already-installed-environm.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -121,8 +119,6 @@ Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
|
||||
|
||||
%prep
|
||||
%setup -q -n dnf-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
rm -rf py3
|
||||
mkdir ../py3
|
||||
cp -a . ../py3/
|
||||
@ -148,6 +144,7 @@ mkdir -p $RPM_BUILD_ROOT%{pluginconfpath}
|
||||
mkdir -p $RPM_BUILD_ROOT%{py2pluginpath}
|
||||
mkdir -p $RPM_BUILD_ROOT%{py3pluginpath}/__pycache__
|
||||
mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log
|
||||
mkdir -p $RPM_BUILD_ROOT%{_var}/cache/dnf
|
||||
touch $RPM_BUILD_ROOT%{_localstatedir}/log/%{name}.log
|
||||
%if 0%{?fedora} >= 23
|
||||
ln -sr $RPM_BUILD_ROOT%{_bindir}/dnf-3 $RPM_BUILD_ROOT%{_bindir}/dnf
|
||||
@ -172,6 +169,7 @@ popd
|
||||
%{_mandir}/man8/yum2dnf.8.gz
|
||||
%{_unitdir}/dnf-makecache.service
|
||||
%{_unitdir}/dnf-makecache.timer
|
||||
%{_var}/cache/dnf
|
||||
|
||||
%files conf
|
||||
%doc AUTHORS README.rst COPYING PACKAGE-LICENSING
|
||||
@ -235,6 +233,13 @@ popd
|
||||
%postun
|
||||
%systemd_postun_with_restart dnf-makecache.timer
|
||||
|
||||
%posttrans
|
||||
# cleanup pre-1.0.2 style cache
|
||||
for arch in armv7hl i686 x86_64 ; do
|
||||
rm -rf /var/cache/dnf/$arch
|
||||
done
|
||||
exit 0
|
||||
|
||||
%post automatic
|
||||
%systemd_post dnf-automatic.timer
|
||||
|
||||
@ -245,8 +250,61 @@ popd
|
||||
%systemd_postun_with_restart dnf-automatic.timer
|
||||
|
||||
%changelog
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
* Tue Jul 21 2015 Jan Silhan <jsilhan@redhat.com> 1.0.2-2
|
||||
- fixed python3 syntax error from f427aa2 (Jan Silhan)
|
||||
|
||||
* Fri Jul 17 2015 Michal Luscon <mluscon@redhat.com> 1.0.2-1
|
||||
- give --allowerasing hint when error occurs during resolution (RhBug:1148630)
|
||||
(Jan Silhan)
|
||||
- show --best hint with skipped packages everytime (RhBug:1176351) (Jan Silhan)
|
||||
- notify about skipped packages when upgrade (RhBug:1210445) (Jan Silhan)
|
||||
- dnf-automatic: Document apply_updates=no behavior wrt keepcache (Ville
|
||||
Skyttä)
|
||||
- persistor: share functionality of JSONDB (Jan Silhan)
|
||||
- keepcache=0 persists packages till next successful transaction
|
||||
(RhBug:1220074) (Jan Silhan)
|
||||
- do not use releasever in cache path (related to RhBug:1173107) (Michael
|
||||
Mraka)
|
||||
- doc: add dnf list use case (Michal Luscon)
|
||||
- repo: allow ntlm proxy auth (RhBug:1219199) (Michal Luscon)
|
||||
- add a script which updates release notes (Radek Holy)
|
||||
- doc: reverse the order of release notes (Radek Holy)
|
||||
- completion_helper: fix tb if list XXX is not known arg (RhBug:1220040) (Igor
|
||||
Gnatenko)
|
||||
- configurable maximum number of parallel downloads (RhBug:1230975) (Igor
|
||||
Gnatenko)
|
||||
- add info to bash_completion (1nsan3)
|
||||
- dnf upgrade does not try to upgrade uninstalled packages (RhBug: 1234763)
|
||||
(Adam Salih)
|
||||
- dnf group list now checks every package and prints out only invalid ones
|
||||
(Adam Salih)
|
||||
- install: return zero exit code if group is already installed (RhBug:1232815)
|
||||
(Michal Luscon)
|
||||
- doc: add -b which does the same as --best (Igor Gnatenko)
|
||||
- support category groups (Michael Mraka)
|
||||
- cli test update for repofrompath (Michael Mraka)
|
||||
- documentation for --repofrompath (Michael Mraka)
|
||||
- implemented --repofrompath option (RhBug:1113384) (Michael Mraka)
|
||||
- doc: document filter provides and obsoletes (Michal Luscon)
|
||||
- doc: extend --quiet explanation (RhBug:1133979) (Jan Silhan)
|
||||
- fixed dnf-automatic email emitter unicode error (RhBug:1238958) (Jan Silhan)
|
||||
- doc: be specific what 'available' means in list/info (Jan Silhan)
|
||||
- cosmetic: fixed typo (RhBug:1238252) (Jan Silhan)
|
||||
- groups: clean dependencies (Michal Luscon)
|
||||
- groups: fix removing of env that contains previously removed group (Michal
|
||||
Luscon)
|
||||
- groups: fix removing of empty group (Michal Luscon)
|
||||
- AUTHORS: updated (Jan Silhan)
|
||||
- bash-completion: ignore sqlite3 user configuration (Peter Simonyi)
|
||||
- Fix package name for rawhide .repo files (Frank Dana)
|
||||
- Add 'transaction_display' to DemandSheet (Will Woods)
|
||||
- translation: update (Jan Silhan)
|
||||
- translation: use zanata instead of transifex (Jan Silhan)
|
||||
- Updated Polish translation (Piotr Drąg)
|
||||
- updated georgian translation (George Machitidze)
|
||||
- group: fixed installing of already installed environment (Jan Silhan)
|
||||
- conf: change minrate threshold to librepo default (RhBug:1212320) (Michal
|
||||
Luscon)
|
||||
|
||||
* Tue Jun 09 2015 Michal Luscon <mluscon@redhat.com> 1.0.1-2
|
||||
- conf: change minrate threshold to librepo default (RhBug:1212320)
|
||||
|
Loading…
Reference in New Issue
Block a user