Update dnf to 1.1.7-1
This commit is contained in:
parent
cabd88e9bd
commit
7b59b46ec6
1
.gitignore
vendored
1
.gitignore
vendored
@ -84,3 +84,4 @@
|
||||
/dnf-1.1.4.tar.gz
|
||||
/dnf-1.1.5.tar.gz
|
||||
/dnf-1.1.6.tar.gz
|
||||
/dnf-1.1.7.tar.gz
|
||||
|
31
dnf.spec
31
dnf.spec
@ -10,15 +10,13 @@
|
||||
%global py3pluginpath %{python3_sitelib}/dnf-plugins
|
||||
|
||||
Name: dnf
|
||||
Version: 1.1.6
|
||||
Release: 2%{?snapshot}%{?dist}
|
||||
Version: 1.1.7
|
||||
Release: 1%{?snapshot}%{?dist}
|
||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
URL: https://github.com/rpm-software-management/dnf
|
||||
Source0: https://github.com/rpm-software-management/dnf/archive/%{name}-%{version}.tar.gz
|
||||
Patch0: fix-dnf-history-traceback.patch
|
||||
Patch1: zanata-update.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -140,8 +138,6 @@ Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
|
||||
|
||||
%prep
|
||||
%setup -q -n dnf-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
rm -rf py3
|
||||
mkdir ../py3
|
||||
cp -a . ../py3/
|
||||
@ -179,6 +175,9 @@ mv $RPM_BUILD_ROOT%{_bindir}/dnf-automatic-2 $RPM_BUILD_ROOT%{_bindir}/dnf-autom
|
||||
rm $RPM_BUILD_ROOT%{_bindir}/dnf-automatic-3
|
||||
%endif
|
||||
|
||||
# This will eventually be the new default location for repo files
|
||||
mkdir $RPM_BUILD_ROOT%{_sysconfdir}/distro.repos.d
|
||||
|
||||
%check
|
||||
make ARGS="-V" test
|
||||
pushd py3
|
||||
@ -198,6 +197,7 @@ popd
|
||||
%{_unitdir}/dnf-makecache.service
|
||||
%{_unitdir}/dnf-makecache.timer
|
||||
%{_var}/cache/dnf
|
||||
%ghost %{_sysconfdir}/distro.repos.d
|
||||
|
||||
%files conf
|
||||
%license COPYING PACKAGE-LICENSING
|
||||
@ -285,9 +285,22 @@ exit 0
|
||||
%systemd_postun_with_restart dnf-automatic.timer
|
||||
|
||||
%changelog
|
||||
* Wed Feb 03 2016 Michal Luscon <mluscon@redhat.com> 1.1.6-2
|
||||
- fix dnf history traceback (RhBug:1303149)
|
||||
- zanata update (RhBug:1302934)
|
||||
* Thu Feb 25 2016 Michal Luscon <mluscon@redhat.com> 1.1.7-1
|
||||
- Add `/etc/distro.repos.d` as a path owned by the dnf package (Neal Gompa
|
||||
(ニール・ゴンパ))
|
||||
- Change order of search and add new default repodirs (RhBug:1286477) (Neal
|
||||
Gompa (ニール・ゴンパ))
|
||||
- group: don't mark available packages as installed (RhBug:1305356) (Jan
|
||||
Silhan)
|
||||
- history: adjust demands for particular subcommands (RhBug:1258503) (Michal
|
||||
Luscon)
|
||||
- Added extension command for group list (RhBug:1283432) (Abhijeet Kasurde)
|
||||
- perf: dnf repository-packages <repo> upgrade (RhBug:1306304) (Jan Silhan)
|
||||
- sack: Pass base.conf.substitutions["arch"] to sack in build_sack() function.
|
||||
(Daniel Mach)
|
||||
- build: make python2/3 binaries at build time (Michal Domonkos)
|
||||
- fix dnf history traceback (RhBug:1303149) (Jan Silhan)
|
||||
- cli: truncate expiration msg (RhBug:1302217) (Michal Luscon)
|
||||
|
||||
* Mon Jan 25 2016 Michal Luscon <mluscon@redhat.com> 1.1.6-1
|
||||
- history: don't fail if there is no history (RhBug:1291895) (Michal Luscon)
|
||||
|
@ -1,27 +0,0 @@
|
||||
From c9217ab14cc5bee85d5a93d8a8b740651cc99aee Mon Sep 17 00:00:00 2001
|
||||
From: Jan Silhan <jsilhan@redhat.com>
|
||||
Date: Tue, 2 Feb 2016 18:18:34 +0100
|
||||
Subject: [PATCH 1/3] fix dnf history traceback (RhBug:1303149)
|
||||
|
||||
fixed regression introduced in 2731b00
|
||||
---
|
||||
dnf/yum/history.py | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dnf/yum/history.py b/dnf/yum/history.py
|
||||
index 3eb1246..c0bc5f4 100644
|
||||
--- a/dnf/yum/history.py
|
||||
+++ b/dnf/yum/history.py
|
||||
@@ -163,7 +163,8 @@ class YumHistoryPackage(object):
|
||||
def __le__(self, other):
|
||||
"""Test whether the *self* is less than or equal to the *other*."""
|
||||
s = self.to_nevra()
|
||||
- o = other.to_nevra()
|
||||
+ o = hawkey.NEVRA(other.name, int(other.epoch), other.version,
|
||||
+ other.release, other.arch)
|
||||
if s != o:
|
||||
return s < o
|
||||
|
||||
--
|
||||
2.7.0
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
1e6f68a11d561fb2d3ab9273d8255cd5 dnf-1.1.6.tar.gz
|
||||
babbd9136639ecbee90d060152a716a6 dnf-1.1.7.tar.gz
|
||||
|
1831
zanata-update.patch
1831
zanata-update.patch
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user