bugfix update 1.1.6-2
This commit is contained in:
parent
cf0fc6a2f5
commit
cabd88e9bd
10
dnf.spec
10
dnf.spec
@ -11,12 +11,14 @@
|
||||
|
||||
Name: dnf
|
||||
Version: 1.1.6
|
||||
Release: 1%{?snapshot}%{?dist}
|
||||
Release: 2%{?snapshot}%{?dist}
|
||||
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
|
||||
# For a breakdown of the licensing, see PACKAGE-LICENSING
|
||||
License: GPLv2+ and GPLv2 and GPL
|
||||
URL: https://github.com/rpm-software-management/dnf
|
||||
Source0: https://github.com/rpm-software-management/dnf/archive/%{name}-%{version}.tar.gz
|
||||
Patch0: fix-dnf-history-traceback.patch
|
||||
Patch1: zanata-update.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gettext
|
||||
@ -138,6 +140,8 @@ Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
|
||||
|
||||
%prep
|
||||
%setup -q -n dnf-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
rm -rf py3
|
||||
mkdir ../py3
|
||||
cp -a . ../py3/
|
||||
@ -281,6 +285,10 @@ exit 0
|
||||
%systemd_postun_with_restart dnf-automatic.timer
|
||||
|
||||
%changelog
|
||||
* Wed Feb 03 2016 Michal Luscon <mluscon@redhat.com> 1.1.6-2
|
||||
- fix dnf history traceback (RhBug:1303149)
|
||||
- zanata update (RhBug:1302934)
|
||||
|
||||
* Mon Jan 25 2016 Michal Luscon <mluscon@redhat.com> 1.1.6-1
|
||||
- history: don't fail if there is no history (RhBug:1291895) (Michal Luscon)
|
||||
- Allow dnf to use a socks5 proxy, since curl support it (RhBug:1256587)
|
||||
|
27
fix-dnf-history-traceback.patch
Normal file
27
fix-dnf-history-traceback.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From c9217ab14cc5bee85d5a93d8a8b740651cc99aee Mon Sep 17 00:00:00 2001
|
||||
From: Jan Silhan <jsilhan@redhat.com>
|
||||
Date: Tue, 2 Feb 2016 18:18:34 +0100
|
||||
Subject: [PATCH 1/3] fix dnf history traceback (RhBug:1303149)
|
||||
|
||||
fixed regression introduced in 2731b00
|
||||
---
|
||||
dnf/yum/history.py | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dnf/yum/history.py b/dnf/yum/history.py
|
||||
index 3eb1246..c0bc5f4 100644
|
||||
--- a/dnf/yum/history.py
|
||||
+++ b/dnf/yum/history.py
|
||||
@@ -163,7 +163,8 @@ class YumHistoryPackage(object):
|
||||
def __le__(self, other):
|
||||
"""Test whether the *self* is less than or equal to the *other*."""
|
||||
s = self.to_nevra()
|
||||
- o = other.to_nevra()
|
||||
+ o = hawkey.NEVRA(other.name, int(other.epoch), other.version,
|
||||
+ other.release, other.arch)
|
||||
if s != o:
|
||||
return s < o
|
||||
|
||||
--
|
||||
2.7.0
|
||||
|
1831
zanata-update.patch
Normal file
1831
zanata-update.patch
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user