import dlm-4.0.9-3.el8
This commit is contained in:
parent
e6cf87de60
commit
97f9440d1f
@ -1 +1 @@
|
||||
ceaf73af4f369af3f951ac0a6bdec18444c2d820 SOURCES/dlm-4.0.6.tar.gz
|
||||
3655865fa215e6b50e6b82ba66cb13f2d8005f67 SOURCES/dlm-4.0.9.tar.gz
|
||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/dlm-4.0.6.tar.gz
|
||||
SOURCES/dlm-4.0.9.tar.gz
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 2eefc91150a3292c2be82f4139207e06b4c4bba4 Mon Sep 17 00:00:00 2001
|
||||
From: David Teigland <teigland@redhat.com>
|
||||
Date: Fri, 10 Jun 2016 13:13:48 -0500
|
||||
Subject: [PATCH] dlm_controld: libsystemd broke itself
|
||||
|
||||
---
|
||||
dlm_controld/Makefile | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/dlm_controld/Makefile b/dlm_controld/Makefile
|
||||
index 13d6339ab263..cf556c9d72b8 100644
|
||||
--- a/dlm_controld/Makefile
|
||||
+++ b/dlm_controld/Makefile
|
||||
@@ -62,9 +62,9 @@ LIB_CFLAGS += $(BIN_CFLAGS)
|
||||
LIB_LDFLAGS += -Wl,-z,relro -pie
|
||||
|
||||
ifeq ($(USE_SD_NOTIFY),yes)
|
||||
- BIN_CFLAGS += $(shell pkg-config --cflags libsystemd-daemon) \
|
||||
+ BIN_CFLAGS += $(shell pkg-config --cflags libsystemd) \
|
||||
-DUSE_SD_NOTIFY
|
||||
- BIN_LDFLAGS += $(shell pkg-config --libs libsystemd-daemon)
|
||||
+ BIN_LDFLAGS += $(shell pkg-config --libs libsystemd)
|
||||
endif
|
||||
|
||||
all: $(LIB_TARGET) $(BIN_TARGET)
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,41 +0,0 @@
|
||||
From 3a5d91435a557932b2ff674ec8e7c22e880da42f Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Sat, 24 Mar 2018 08:55:06 +0000
|
||||
Subject: [PATCH] New location of major() and minor() macros for glibc 2.27.
|
||||
|
||||
glibc 2.27 moves the major() and minor() macros to the
|
||||
<sys/sysmacros.h> header file.
|
||||
|
||||
Signed-off-by: Richard W.M. Jones <rjones@redhat.com>
|
||||
---
|
||||
dlm_controld/dlm_daemon.h | 1 +
|
||||
libdlm/libdlm.c | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/dlm_controld/dlm_daemon.h b/dlm_controld/dlm_daemon.h
|
||||
index 6cb0f11c1335..731818c53c9b 100644
|
||||
--- a/dlm_controld/dlm_daemon.h
|
||||
+++ b/dlm_controld/dlm_daemon.h
|
||||
@@ -40,6 +40,7 @@
|
||||
#include <sched.h>
|
||||
#include <signal.h>
|
||||
#include <dirent.h>
|
||||
+#include <sys/sysmacros.h>
|
||||
|
||||
#include <corosync/cpg.h>
|
||||
|
||||
diff --git a/libdlm/libdlm.c b/libdlm/libdlm.c
|
||||
index a9e6195579aa..ebfba4576fa8 100644
|
||||
--- a/libdlm/libdlm.c
|
||||
+++ b/libdlm/libdlm.c
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <stdio.h>
|
||||
#include <dirent.h>
|
||||
#include <linux/major.h>
|
||||
+#include <sys/sysmacros.h>
|
||||
#ifdef HAVE_SELINUX
|
||||
#include <selinux/selinux.h>
|
||||
#endif
|
||||
--
|
||||
2.7.5
|
||||
|
@ -1,217 +0,0 @@
|
||||
From db875a3d07f9f6a633951ed886cec80b91efea43 Mon Sep 17 00:00:00 2001
|
||||
From: David Teigland <teigland@redhat.com>
|
||||
Date: Tue, 2 Oct 2018 11:22:39 -0500
|
||||
Subject: [PATCH] update makefile gcc flags
|
||||
|
||||
---
|
||||
dlm_controld/Makefile | 41 ++++++++++++++---------------------------
|
||||
dlm_tool/Makefile | 44 ++++++++++++++++----------------------------
|
||||
fence/Makefile | 46 +++++++++++++++++-----------------------------
|
||||
libdlm/Makefile | 6 +++++-
|
||||
4 files changed, 52 insertions(+), 85 deletions(-)
|
||||
|
||||
diff --git a/dlm_controld/Makefile b/dlm_controld/Makefile
|
||||
index cf556c9d72b8..85c2db12883a 100644
|
||||
--- a/dlm_controld/Makefile
|
||||
+++ b/dlm_controld/Makefile
|
||||
@@ -31,35 +31,22 @@ BIN_SOURCE = action.c \
|
||||
rbtree.c
|
||||
LIB_SOURCE = lib.c
|
||||
|
||||
-BIN_CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
- -Wall \
|
||||
- -Wformat \
|
||||
- -Wformat-security \
|
||||
- -Wmissing-prototypes \
|
||||
- -Wnested-externs \
|
||||
- -Wpointer-arith \
|
||||
- -Wextra -Wshadow \
|
||||
- -Wcast-align \
|
||||
- -Wwrite-strings \
|
||||
- -Waggregate-return \
|
||||
- -Wstrict-prototypes \
|
||||
- -Winline \
|
||||
- -Wredundant-decls \
|
||||
- -Wno-sign-compare \
|
||||
- -Wno-unused-parameter \
|
||||
- -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
- -fexceptions \
|
||||
- -fasynchronous-unwind-tables \
|
||||
- -fdiagnostics-show-option \
|
||||
-
|
||||
-BIN_CFLAGS += -fPIE -DPIE
|
||||
+CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
+ -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs \
|
||||
+ -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings \
|
||||
+ -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls \
|
||||
+ -Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
+ -fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
|
||||
+ -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
|
||||
+ -fstack-clash-protection -Wl,-z,now
|
||||
+
|
||||
+BIN_CFLAGS += $(CFLAGS) -fPIE -DPIE
|
||||
BIN_CFLAGS += -I../include -I../libdlm
|
||||
+LIB_CFLAGS += $(CFLAGS) -fPIC
|
||||
|
||||
-BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie
|
||||
+BIN_LDFLAGS += $(LDFLAGS) -Wl,-z,relro -pie
|
||||
BIN_LDFLAGS += -lpthread -lrt -lcpg -lcmap -lcfg -lquorum
|
||||
-
|
||||
-LIB_CFLAGS += $(BIN_CFLAGS)
|
||||
-LIB_LDFLAGS += -Wl,-z,relro -pie
|
||||
+LIB_LDFLAGS += $(LDFLAGS) -Wl,-z,relro -pie
|
||||
|
||||
ifeq ($(USE_SD_NOTIFY),yes)
|
||||
BIN_CFLAGS += $(shell pkg-config --cflags libsystemd) \
|
||||
@@ -73,7 +60,7 @@ $(BIN_TARGET): $(BIN_SOURCE)
|
||||
$(CC) $(BIN_SOURCE) $(BIN_CFLAGS) $(BIN_LDFLAGS) -o $@ -L.
|
||||
|
||||
$(LIB_TARGET): $(LIB_SOURCE)
|
||||
- $(CC) $^ $(LIB_CFLAGS) $(LIB_LDFLAGS) -shared -fPIC -o $@ -Wl,-soname=$(LIB_SMAJOR)
|
||||
+ $(CC) $^ $(LIB_CFLAGS) $(LIB_LDFLAGS) -shared -o $@ -Wl,-soname=$(LIB_SMAJOR)
|
||||
ln -sf $(LIB_TARGET) $(LIB_SO)
|
||||
ln -sf $(LIB_TARGET) $(LIB_SMAJOR)
|
||||
|
||||
diff --git a/dlm_tool/Makefile b/dlm_tool/Makefile
|
||||
index c16d8f537225..80d7725791f3 100644
|
||||
--- a/dlm_tool/Makefile
|
||||
+++ b/dlm_tool/Makefile
|
||||
@@ -8,38 +8,26 @@ MAN_TARGET = dlm_tool.8
|
||||
|
||||
BIN_SOURCE = main.c
|
||||
|
||||
-BIN_CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
- -Wall \
|
||||
- -Wformat \
|
||||
- -Wformat-security \
|
||||
- -Wmissing-prototypes \
|
||||
- -Wnested-externs \
|
||||
- -Wpointer-arith \
|
||||
- -Wextra -Wshadow \
|
||||
- -Wcast-align \
|
||||
- -Wwrite-strings \
|
||||
- -Waggregate-return \
|
||||
- -Wstrict-prototypes \
|
||||
- -Winline \
|
||||
- -Wredundant-decls \
|
||||
- -Wno-sign-compare \
|
||||
- -Wno-unused-parameter \
|
||||
- -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
- -fexceptions \
|
||||
- -fasynchronous-unwind-tables \
|
||||
- -fdiagnostics-show-option \
|
||||
-
|
||||
-BIN_CFLAGS += -fPIE -DPIE
|
||||
-BIN_CFLAGS += -I../include -I../libdlm -I../dlm_controld
|
||||
-
|
||||
-BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie
|
||||
-BIN_LDFLAGS += -L../libdlm -L../dlm_controld
|
||||
-BIN_LDFLAGS += -lpthread -ldlm -ldlmcontrol
|
||||
+CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
+ -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs \
|
||||
+ -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings \
|
||||
+ -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls \
|
||||
+ -Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
+ -fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
|
||||
+ -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
|
||||
+ -fstack-clash-protection -Wl,-z,now
|
||||
+
|
||||
+CFLAGS += -fPIE -DPIE
|
||||
+CFLAGS += -I../include -I../libdlm -I../dlm_controld
|
||||
+
|
||||
+LDFLAGS += -Wl,-z,relro -pie
|
||||
+LDFLAGS += -L../libdlm -L../dlm_controld
|
||||
+LDFLAGS += -lpthread -ldlm -ldlmcontrol
|
||||
|
||||
all: $(BIN_TARGET)
|
||||
|
||||
$(BIN_TARGET): $(BIN_SOURCE)
|
||||
- $(CC) $(BIN_SOURCE) $(BIN_CFLAGS) $(BIN_LDFLAGS) -o $@
|
||||
+ $(CC) $(BIN_SOURCE) $(CFLAGS) $(LDFLAGS) -o $@
|
||||
|
||||
clean:
|
||||
rm -f *.o *.so *.so.* $(BIN_TARGET)
|
||||
diff --git a/fence/Makefile b/fence/Makefile
|
||||
index 77bf0fd15be8..b927879eb141 100644
|
||||
--- a/fence/Makefile
|
||||
+++ b/fence/Makefile
|
||||
@@ -8,39 +8,27 @@ MAN_TARGET = dlm_stonith.8
|
||||
|
||||
BIN_SOURCE = stonith_helper.c
|
||||
|
||||
-BIN_CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
- -Wall \
|
||||
- -Wformat \
|
||||
- -Wformat-security \
|
||||
- -Wmissing-prototypes \
|
||||
- -Wnested-externs \
|
||||
- -Wpointer-arith \
|
||||
- -Wextra -Wshadow \
|
||||
- -Wcast-align \
|
||||
- -Wwrite-strings \
|
||||
- -Waggregate-return \
|
||||
- -Wstrict-prototypes \
|
||||
- -Winline \
|
||||
- -Wredundant-decls \
|
||||
- -Wno-sign-compare \
|
||||
- -Wno-unused-parameter \
|
||||
- -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
- -fexceptions \
|
||||
- -fasynchronous-unwind-tables \
|
||||
- -fdiagnostics-show-option \
|
||||
-
|
||||
-BIN_CFLAGS += -fPIE -DPIE
|
||||
-BIN_CFLAGS += `xml2-config --cflags`
|
||||
-BIN_CFLAGS += -I../include
|
||||
-
|
||||
-BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie
|
||||
-BIN_LDFLAGS += `xml2-config --libs`
|
||||
-BIN_LDFLAGS += -ldl
|
||||
+CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
+ -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs \
|
||||
+ -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings \
|
||||
+ -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls \
|
||||
+ -Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
|
||||
+ -fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
|
||||
+ -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
|
||||
+ -fstack-clash-protection -Wl,-z,now
|
||||
+
|
||||
+CFLAGS += -fPIE -DPIE
|
||||
+CFLAGS += `xml2-config --cflags`
|
||||
+CFLAGS += -I../include
|
||||
+
|
||||
+LDFLAGS += -Wl,-z,relro -pie
|
||||
+LDFLAGS += `xml2-config --libs`
|
||||
+LDFLAGS += -ldl
|
||||
|
||||
all: $(BIN_TARGET)
|
||||
|
||||
$(BIN_TARGET): $(BIN_SOURCE)
|
||||
- $(CC) $(BIN_SOURCE) $(BIN_CFLAGS) $(BIN_LDFLAGS) -o $@ -L.
|
||||
+ $(CC) $(BIN_SOURCE) $(CFLAGS) $(LDFLAGS) -o $@ -L.
|
||||
|
||||
clean:
|
||||
rm -f *.o *.so *.so.* $(BIN_TARGET)
|
||||
diff --git a/libdlm/Makefile b/libdlm/Makefile
|
||||
index 336c22e7edb4..ab32761912b3 100644
|
||||
--- a/libdlm/Makefile
|
||||
+++ b/libdlm/Makefile
|
||||
@@ -72,10 +72,14 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
|
||||
-Wno-sign-compare \
|
||||
-Wno-unused-parameter \
|
||||
-Wp,-D_FORTIFY_SOURCE=2 \
|
||||
+ -Wp,-D_GLIBCXX_ASSERTIONS \
|
||||
+ -fstack-protector-strong \
|
||||
+ -fstack-clash-protection \
|
||||
-fexceptions \
|
||||
-fasynchronous-unwind-tables \
|
||||
-fdiagnostics-show-option \
|
||||
- -fPIC
|
||||
+ -fPIC \
|
||||
+ -Wl,-z,now
|
||||
|
||||
LIB_CFLAGS += $(CFLAGS) -D_REENTRANT
|
||||
LLT_CFLAGS += $(CFLAGS)
|
||||
--
|
||||
2.7.5
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 58f1d500b6da18d62eef35b5f55a030ce8b9b0ce Mon Sep 17 00:00:00 2001
|
||||
From: David Teigland <teigland@redhat.com>
|
||||
Date: Mon, 14 Jan 2019 15:47:07 -0600
|
||||
Subject: [PATCH] dlm_controld: ignore unwanted uevent strings
|
||||
|
||||
---
|
||||
dlm_controld/main.c | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dlm_controld/main.c b/dlm_controld/main.c
|
||||
index 40816aae3b24..ca1349bae241 100644
|
||||
--- a/dlm_controld/main.c
|
||||
+++ b/dlm_controld/main.c
|
||||
@@ -350,7 +350,10 @@ static void process_uevent(int ci)
|
||||
act = argv[0];
|
||||
sys = argv[2];
|
||||
|
||||
- if ((strlen(sys) != strlen("dlm")) || strcmp(sys, "dlm"))
|
||||
+ if (!act || !sys || !argv[3])
|
||||
+ return;
|
||||
+
|
||||
+ if (strncmp(sys, "dlm", 3))
|
||||
return;
|
||||
|
||||
log_debug("kernel: %s %s", act, argv[3]);
|
||||
--
|
||||
2.7.5
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: dlm
|
||||
Version: 4.0.6
|
||||
Release: 10%{?dist}
|
||||
Version: 4.0.9
|
||||
Release: 3%{?dist}
|
||||
License: GPLv2 and GPLv2+ and LGPLv2+
|
||||
# For a breakdown of the licensing, see README.license
|
||||
Group: System Environment/Kernel
|
||||
@ -14,10 +14,7 @@ BuildRequires: systemd-units
|
||||
BuildRequires: systemd-devel
|
||||
Source0: https://releases.pagure.org/dlm/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch0: 0001-dlm_controld-libsystemd-broke-itself.patch
|
||||
Patch1: 0002-New-location-of-major-and-minor-macros-for-glibc-2.2.patch
|
||||
Patch2: 0003-update-makefile-gcc-flags.patch
|
||||
Patch3: 0004-dlm_controld-ignore-unwanted-uevent-strings.patch
|
||||
# Patch0: 0001-foo.patch
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||
ExclusiveArch: i686 x86_64
|
||||
@ -36,10 +33,7 @@ The kernel dlm requires a user daemon to control membership.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .0001-dlm_controld-libsystemd-broke-itself.patch
|
||||
%patch1 -p1 -b .0002-New-location-of-major-and-minor-macros-for-glibc-2.2.patch
|
||||
%patch2 -p1 -b .0003-update-makefile-gcc-flags.patch
|
||||
%patch3 -p1 -b .0004-dlm_controld-ignore-unwanted-uevent-strings.patch
|
||||
# %patch0 -p1 -b .0001-foo.patch
|
||||
|
||||
%build
|
||||
# upstream does not require configure
|
||||
@ -111,6 +105,15 @@ developing applications that use %{name}.
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
%changelog
|
||||
* Wed Jun 12 2019 David Teigland <teigland@redhat.com> - 4.0.9-3
|
||||
- kick gating system
|
||||
|
||||
* Wed Jun 12 2019 David Teigland <teigland@redhat.com> - 4.0.9-2
|
||||
- try to kick gating system
|
||||
|
||||
* Tue Jun 11 2019 David Teigland <teigland@redhat.com> - 4.0.9-1
|
||||
- update to 4.0.9
|
||||
|
||||
* Wed Jan 23 2019 David Teigland <teigland@redhat.com> - 4.0.6-10
|
||||
- dlm_controld: ignore unwanted uevent strings
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user