import dlm-4.0.6-10.el8

This commit is contained in:
CentOS Sources 2019-05-07 08:56:44 -04:00 committed by Andrew Lukoshko
commit e6cf87de60
7 changed files with 560 additions and 0 deletions

1
.dlm.metadata Normal file
View File

@ -0,0 +1 @@
ceaf73af4f369af3f951ac0a6bdec18444c2d820 SOURCES/dlm-4.0.6.tar.gz

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/dlm-4.0.6.tar.gz

View File

@ -0,0 +1,28 @@
From 2eefc91150a3292c2be82f4139207e06b4c4bba4 Mon Sep 17 00:00:00 2001
From: David Teigland <teigland@redhat.com>
Date: Fri, 10 Jun 2016 13:13:48 -0500
Subject: [PATCH] dlm_controld: libsystemd broke itself
---
dlm_controld/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/dlm_controld/Makefile b/dlm_controld/Makefile
index 13d6339ab263..cf556c9d72b8 100644
--- a/dlm_controld/Makefile
+++ b/dlm_controld/Makefile
@@ -62,9 +62,9 @@ LIB_CFLAGS += $(BIN_CFLAGS)
LIB_LDFLAGS += -Wl,-z,relro -pie
ifeq ($(USE_SD_NOTIFY),yes)
- BIN_CFLAGS += $(shell pkg-config --cflags libsystemd-daemon) \
+ BIN_CFLAGS += $(shell pkg-config --cflags libsystemd) \
-DUSE_SD_NOTIFY
- BIN_LDFLAGS += $(shell pkg-config --libs libsystemd-daemon)
+ BIN_LDFLAGS += $(shell pkg-config --libs libsystemd)
endif
all: $(LIB_TARGET) $(BIN_TARGET)
--
1.8.3.1

View File

@ -0,0 +1,41 @@
From 3a5d91435a557932b2ff674ec8e7c22e880da42f Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 24 Mar 2018 08:55:06 +0000
Subject: [PATCH] New location of major() and minor() macros for glibc 2.27.
glibc 2.27 moves the major() and minor() macros to the
<sys/sysmacros.h> header file.
Signed-off-by: Richard W.M. Jones <rjones@redhat.com>
---
dlm_controld/dlm_daemon.h | 1 +
libdlm/libdlm.c | 1 +
2 files changed, 2 insertions(+)
diff --git a/dlm_controld/dlm_daemon.h b/dlm_controld/dlm_daemon.h
index 6cb0f11c1335..731818c53c9b 100644
--- a/dlm_controld/dlm_daemon.h
+++ b/dlm_controld/dlm_daemon.h
@@ -40,6 +40,7 @@
#include <sched.h>
#include <signal.h>
#include <dirent.h>
+#include <sys/sysmacros.h>
#include <corosync/cpg.h>
diff --git a/libdlm/libdlm.c b/libdlm/libdlm.c
index a9e6195579aa..ebfba4576fa8 100644
--- a/libdlm/libdlm.c
+++ b/libdlm/libdlm.c
@@ -24,6 +24,7 @@
#include <stdio.h>
#include <dirent.h>
#include <linux/major.h>
+#include <sys/sysmacros.h>
#ifdef HAVE_SELINUX
#include <selinux/selinux.h>
#endif
--
2.7.5

View File

@ -0,0 +1,217 @@
From db875a3d07f9f6a633951ed886cec80b91efea43 Mon Sep 17 00:00:00 2001
From: David Teigland <teigland@redhat.com>
Date: Tue, 2 Oct 2018 11:22:39 -0500
Subject: [PATCH] update makefile gcc flags
---
dlm_controld/Makefile | 41 ++++++++++++++---------------------------
dlm_tool/Makefile | 44 ++++++++++++++++----------------------------
fence/Makefile | 46 +++++++++++++++++-----------------------------
libdlm/Makefile | 6 +++++-
4 files changed, 52 insertions(+), 85 deletions(-)
diff --git a/dlm_controld/Makefile b/dlm_controld/Makefile
index cf556c9d72b8..85c2db12883a 100644
--- a/dlm_controld/Makefile
+++ b/dlm_controld/Makefile
@@ -31,35 +31,22 @@ BIN_SOURCE = action.c \
rbtree.c
LIB_SOURCE = lib.c
-BIN_CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
- -Wall \
- -Wformat \
- -Wformat-security \
- -Wmissing-prototypes \
- -Wnested-externs \
- -Wpointer-arith \
- -Wextra -Wshadow \
- -Wcast-align \
- -Wwrite-strings \
- -Waggregate-return \
- -Wstrict-prototypes \
- -Winline \
- -Wredundant-decls \
- -Wno-sign-compare \
- -Wno-unused-parameter \
- -Wp,-D_FORTIFY_SOURCE=2 \
- -fexceptions \
- -fasynchronous-unwind-tables \
- -fdiagnostics-show-option \
-
-BIN_CFLAGS += -fPIE -DPIE
+CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
+ -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs \
+ -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings \
+ -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls \
+ -Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
+ -fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
+ -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
+ -fstack-clash-protection -Wl,-z,now
+
+BIN_CFLAGS += $(CFLAGS) -fPIE -DPIE
BIN_CFLAGS += -I../include -I../libdlm
+LIB_CFLAGS += $(CFLAGS) -fPIC
-BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie
+BIN_LDFLAGS += $(LDFLAGS) -Wl,-z,relro -pie
BIN_LDFLAGS += -lpthread -lrt -lcpg -lcmap -lcfg -lquorum
-
-LIB_CFLAGS += $(BIN_CFLAGS)
-LIB_LDFLAGS += -Wl,-z,relro -pie
+LIB_LDFLAGS += $(LDFLAGS) -Wl,-z,relro -pie
ifeq ($(USE_SD_NOTIFY),yes)
BIN_CFLAGS += $(shell pkg-config --cflags libsystemd) \
@@ -73,7 +60,7 @@ $(BIN_TARGET): $(BIN_SOURCE)
$(CC) $(BIN_SOURCE) $(BIN_CFLAGS) $(BIN_LDFLAGS) -o $@ -L.
$(LIB_TARGET): $(LIB_SOURCE)
- $(CC) $^ $(LIB_CFLAGS) $(LIB_LDFLAGS) -shared -fPIC -o $@ -Wl,-soname=$(LIB_SMAJOR)
+ $(CC) $^ $(LIB_CFLAGS) $(LIB_LDFLAGS) -shared -o $@ -Wl,-soname=$(LIB_SMAJOR)
ln -sf $(LIB_TARGET) $(LIB_SO)
ln -sf $(LIB_TARGET) $(LIB_SMAJOR)
diff --git a/dlm_tool/Makefile b/dlm_tool/Makefile
index c16d8f537225..80d7725791f3 100644
--- a/dlm_tool/Makefile
+++ b/dlm_tool/Makefile
@@ -8,38 +8,26 @@ MAN_TARGET = dlm_tool.8
BIN_SOURCE = main.c
-BIN_CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
- -Wall \
- -Wformat \
- -Wformat-security \
- -Wmissing-prototypes \
- -Wnested-externs \
- -Wpointer-arith \
- -Wextra -Wshadow \
- -Wcast-align \
- -Wwrite-strings \
- -Waggregate-return \
- -Wstrict-prototypes \
- -Winline \
- -Wredundant-decls \
- -Wno-sign-compare \
- -Wno-unused-parameter \
- -Wp,-D_FORTIFY_SOURCE=2 \
- -fexceptions \
- -fasynchronous-unwind-tables \
- -fdiagnostics-show-option \
-
-BIN_CFLAGS += -fPIE -DPIE
-BIN_CFLAGS += -I../include -I../libdlm -I../dlm_controld
-
-BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie
-BIN_LDFLAGS += -L../libdlm -L../dlm_controld
-BIN_LDFLAGS += -lpthread -ldlm -ldlmcontrol
+CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
+ -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs \
+ -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings \
+ -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls \
+ -Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
+ -fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
+ -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
+ -fstack-clash-protection -Wl,-z,now
+
+CFLAGS += -fPIE -DPIE
+CFLAGS += -I../include -I../libdlm -I../dlm_controld
+
+LDFLAGS += -Wl,-z,relro -pie
+LDFLAGS += -L../libdlm -L../dlm_controld
+LDFLAGS += -lpthread -ldlm -ldlmcontrol
all: $(BIN_TARGET)
$(BIN_TARGET): $(BIN_SOURCE)
- $(CC) $(BIN_SOURCE) $(BIN_CFLAGS) $(BIN_LDFLAGS) -o $@
+ $(CC) $(BIN_SOURCE) $(CFLAGS) $(LDFLAGS) -o $@
clean:
rm -f *.o *.so *.so.* $(BIN_TARGET)
diff --git a/fence/Makefile b/fence/Makefile
index 77bf0fd15be8..b927879eb141 100644
--- a/fence/Makefile
+++ b/fence/Makefile
@@ -8,39 +8,27 @@ MAN_TARGET = dlm_stonith.8
BIN_SOURCE = stonith_helper.c
-BIN_CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
- -Wall \
- -Wformat \
- -Wformat-security \
- -Wmissing-prototypes \
- -Wnested-externs \
- -Wpointer-arith \
- -Wextra -Wshadow \
- -Wcast-align \
- -Wwrite-strings \
- -Waggregate-return \
- -Wstrict-prototypes \
- -Winline \
- -Wredundant-decls \
- -Wno-sign-compare \
- -Wno-unused-parameter \
- -Wp,-D_FORTIFY_SOURCE=2 \
- -fexceptions \
- -fasynchronous-unwind-tables \
- -fdiagnostics-show-option \
-
-BIN_CFLAGS += -fPIE -DPIE
-BIN_CFLAGS += `xml2-config --cflags`
-BIN_CFLAGS += -I../include
-
-BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie
-BIN_LDFLAGS += `xml2-config --libs`
-BIN_LDFLAGS += -ldl
+CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
+ -Wall -Wformat -Wformat-security -Wmissing-prototypes -Wnested-externs \
+ -Wpointer-arith -Wextra -Wshadow -Wcast-align -Wwrite-strings \
+ -Waggregate-return -Wstrict-prototypes -Winline -Wredundant-decls \
+ -Wno-sign-compare -Wno-unused-parameter -Wp,-D_FORTIFY_SOURCE=2 \
+ -fexceptions -fasynchronous-unwind-tables -fdiagnostics-show-option \
+ -Wp,-D_GLIBCXX_ASSERTIONS -fstack-protector-strong \
+ -fstack-clash-protection -Wl,-z,now
+
+CFLAGS += -fPIE -DPIE
+CFLAGS += `xml2-config --cflags`
+CFLAGS += -I../include
+
+LDFLAGS += -Wl,-z,relro -pie
+LDFLAGS += `xml2-config --libs`
+LDFLAGS += -ldl
all: $(BIN_TARGET)
$(BIN_TARGET): $(BIN_SOURCE)
- $(CC) $(BIN_SOURCE) $(BIN_CFLAGS) $(BIN_LDFLAGS) -o $@ -L.
+ $(CC) $(BIN_SOURCE) $(CFLAGS) $(LDFLAGS) -o $@ -L.
clean:
rm -f *.o *.so *.so.* $(BIN_TARGET)
diff --git a/libdlm/Makefile b/libdlm/Makefile
index 336c22e7edb4..ab32761912b3 100644
--- a/libdlm/Makefile
+++ b/libdlm/Makefile
@@ -72,10 +72,14 @@ CFLAGS += -D_GNU_SOURCE -O2 -ggdb \
-Wno-sign-compare \
-Wno-unused-parameter \
-Wp,-D_FORTIFY_SOURCE=2 \
+ -Wp,-D_GLIBCXX_ASSERTIONS \
+ -fstack-protector-strong \
+ -fstack-clash-protection \
-fexceptions \
-fasynchronous-unwind-tables \
-fdiagnostics-show-option \
- -fPIC
+ -fPIC \
+ -Wl,-z,now
LIB_CFLAGS += $(CFLAGS) -D_REENTRANT
LLT_CFLAGS += $(CFLAGS)
--
2.7.5

View File

@ -0,0 +1,28 @@
From 58f1d500b6da18d62eef35b5f55a030ce8b9b0ce Mon Sep 17 00:00:00 2001
From: David Teigland <teigland@redhat.com>
Date: Mon, 14 Jan 2019 15:47:07 -0600
Subject: [PATCH] dlm_controld: ignore unwanted uevent strings
---
dlm_controld/main.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/dlm_controld/main.c b/dlm_controld/main.c
index 40816aae3b24..ca1349bae241 100644
--- a/dlm_controld/main.c
+++ b/dlm_controld/main.c
@@ -350,7 +350,10 @@ static void process_uevent(int ci)
act = argv[0];
sys = argv[2];
- if ((strlen(sys) != strlen("dlm")) || strcmp(sys, "dlm"))
+ if (!act || !sys || !argv[3])
+ return;
+
+ if (strncmp(sys, "dlm", 3))
return;
log_debug("kernel: %s %s", act, argv[3]);
--
2.7.5

244
SPECS/dlm.spec Normal file
View File

@ -0,0 +1,244 @@
Name: dlm
Version: 4.0.6
Release: 10%{?dist}
License: GPLv2 and GPLv2+ and LGPLv2+
# For a breakdown of the licensing, see README.license
Group: System Environment/Kernel
Summary: dlm control daemon and tool
URL: https://pagure.io/dlm
BuildRequires: glibc-kernheaders
BuildRequires: corosynclib-devel >= 1.99.9
BuildRequires: pacemaker-libs-devel >= 1.1.7
BuildRequires: libxml2-devel
BuildRequires: systemd-units
BuildRequires: systemd-devel
Source0: https://releases.pagure.org/dlm/%{name}-%{version}.tar.gz
Patch0: 0001-dlm_controld-libsystemd-broke-itself.patch
Patch1: 0002-New-location-of-major-and-minor-macros-for-glibc-2.2.patch
Patch2: 0003-update-makefile-gcc-flags.patch
Patch3: 0004-dlm_controld-ignore-unwanted-uevent-strings.patch
%if 0%{?rhel} && 0%{?rhel} <= 7
ExclusiveArch: i686 x86_64
%endif
Requires: %{name}-lib = %{version}-%{release}
Requires: corosync >= 1.99.9
%{?fedora:Requires: kernel-modules-extra}
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
Conflicts: cman
%description
The kernel dlm requires a user daemon to control membership.
%prep
%setup -q
%patch0 -p1 -b .0001-dlm_controld-libsystemd-broke-itself.patch
%patch1 -p1 -b .0002-New-location-of-major-and-minor-macros-for-glibc-2.2.patch
%patch2 -p1 -b .0003-update-makefile-gcc-flags.patch
%patch3 -p1 -b .0004-dlm_controld-ignore-unwanted-uevent-strings.patch
%build
# upstream does not require configure
# upstream does not support _smp_mflags
CFLAGS+=$RPM_OPT_FLAGS make
CFLAGS+=$RPM_OPT_FLAGS make -C fence
%install
rm -rf $RPM_BUILD_ROOT
make install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
make -C fence install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
install -Dm 0644 init/dlm.service %{buildroot}%{_unitdir}/dlm.service
install -Dm 0644 init/dlm.sysconfig %{buildroot}/etc/sysconfig/dlm
%post
%systemd_post dlm.service
%preun
%systemd_preun dlm.service
%postun
%systemd_postun_with_restart dlm.service
%files
%defattr(-,root,root,-)
%doc README.license
%{_unitdir}/dlm.service
%{_sbindir}/dlm_controld
%{_sbindir}/dlm_tool
%{_sbindir}/dlm_stonith
%{_mandir}/man8/dlm*
%{_mandir}/man5/dlm*
%{_mandir}/man3/*dlm*
%config(noreplace) %{_sysconfdir}/sysconfig/dlm
%package lib
Summary: Library for %{name}
Group: System Environment/Libraries
Conflicts: clusterlib
%description lib
The %{name}-lib package contains the libraries needed to use the dlm
from userland applications.
%post lib -p /sbin/ldconfig
%postun lib -p /sbin/ldconfig
%files lib
%defattr(-,root,root,-)
%{_prefix}/lib/udev/rules.d/*-dlm.rules
%{_libdir}/libdlm*.so.*
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name}-lib = %{version}-%{release}
Conflicts: clusterlib-devel
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%files devel
%defattr(-,root,root,-)
%{_libdir}/libdlm*.so
%{_includedir}/libdlm*.h
%{_libdir}/pkgconfig/*.pc
%changelog
* Wed Jan 23 2019 David Teigland <teigland@redhat.com> - 4.0.6-10
- dlm_controld: ignore unwanted uevent strings
* Tue Oct 02 2018 David Teigland <teigland@redhat.com> - 4.0.6-9
- update makefile gcc flags
* Thu Aug 09 2018 David Teigland <teigland@redhat.com> - 4.0.6-8
- Work around glibc regression for major/minor header
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.6-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Tue Oct 10 2017 Troy Dawson <tdawson@redhat.com> - 4.0.6-5
- Cleanup spec file conditionals
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.6-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Jun 10 2016 David Teigland <teigland@redhat.com> - 4.0.6-2
- try fixing broken libsystemd
* Fri Jun 10 2016 David Teigland <teigland@redhat.com> - 4.0.6-1
- New upstream release
* Tue Apr 26 2016 David Teigland <teigland@redhat.com> - 4.0.5-1
- New upstream release
* Mon Feb 22 2016 David Teigland <teigland@redhat.com> - 4.0.4-1
- New upstream release dlm-4.0.4
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Wed Mar 06 2013 David Teigland <teigland@redhat.com> - 4.0.1-1
- New usptream release, fencing fixes
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Tue Nov 06 2012 David Teigland <teigland@redhat.com> - 4.0.0-1
- New upstream release, systemd fixes
* Wed Sep 05 2012 Václav Pavlín <vpavlin@redhat.com> - 3.99.5-7
- Scriptlets replaced with new systemd macros (#850093)
* Tue Aug 28 2012 David Teigland <teigland@redhat.com> - 3.99.5-6
- only fedora requires kernel-modules-extra
* Thu Aug 16 2012 David Teigland <teigland@redhat.com> - 3.99.5-5
- dlm_controld: remove fence_all from cli
* Thu Aug 16 2012 David Teigland <teigland@redhat.com> - 3.99.5-4
- dlm_stonith: include errno.h
* Thu Aug 16 2012 David Teigland <teigland@redhat.com> - 3.99.5-3
- dlm_controld: fix uninitialized mem for fence_all config
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.99.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Thu Jun 21 2012 David Teigland <teigland@redhat.com> - 3.99.5-1
- New upstream release
* Wed May 30 2012 David Teigland <teigland@redhat.com> - 3.99.4-2
- Limit rhel arches
* Mon May 21 2012 David Teigland <teigland@redhat.com> - 3.99.4-1
- New upstream release
* Mon May 14 2012 David Teigland <teigland@redhat.com> - 3.99.3-1
- New upstream release
* Wed Apr 11 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.2-1
- New upstream release
* Thu Mar 29 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.1-4
- Merge back from F17
* Wed Mar 21 2012 David Teigland <teigland@redhat.com> - 3.99.1-3
- Fix dlm_stonith linking
* Wed Mar 21 2012 David Teigland <teigland@redhat.com> - 3.99.1-2
- Require pacemaker-libs-devel to build dlm_stonith
* Wed Mar 21 2012 David Teigland <teigland@redhat.com> - 3.99.1-1
- Update to 3.99.1
* Fri Mar 16 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.0-8
- Rebuild against new corosync (soname change).
* Thu Feb 16 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.0-7
- Update to upstream HEAD 2ad89c869git.
- Bump BuildRequires and Requires to new corosync
* Mon Feb 13 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.0-6
- Fix init/systemd service to use /etc/sysconfig/dlm
* Mon Feb 6 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.0-5
- Fix systemd service to recognize /etc/sysconfig/dlm_controld
* Fri Feb 3 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.0-4
- Fix systemd service to modprobe dlm
* Fri Feb 3 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.0-3
- Add patch to fix udev rules and make sure dlm_controld can find
its devices
* Thu Feb 2 2012 Fabio M. Di Nitto <fdinitto@redhat.com> - 3.99.0-2
- Add Conflicts with clusterlib/cman as necessary
* Tue Jan 24 2012 David Teigland <teigland@redhat.com> - 3.99.0-1
- initial package