New upstream release 0.4.0

https://fedorahosted.org/sssd/wiki/Releases/DingNotes-0.4.0
This commit is contained in:
Jakub Hrozek 2014-05-29 08:56:10 +02:00
parent 41f600a079
commit b14fa0b722
5 changed files with 9 additions and 298 deletions

View File

@ -1,26 +0,0 @@
From c42187dbbec1380ed632782315226220385b2af7 Mon Sep 17 00:00:00 2001
From: Ondrej Kos <okos@redhat.com>
Date: Mon, 6 May 2013 11:41:50 +0200
Subject: [PATCH] INI: Bump version-info
https://fedorahosted.org/sssd/ticket/1908
---
Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index 3045ac5ce18e08f09faebce569f89893135e4b04..69f761474a464623e1082c945ee74fe9377fcfc4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -245,7 +245,7 @@ libini_config_la_LIBADD = \
libref_array.la \
libbasicobjects.la
libini_config_la_LDFLAGS = \
- -version-info 3:0:0
+ -version-info 4:0:1
dist_noinst_DATA += \
ini/ini.conf \
--
1.8.2.1

View File

@ -1,166 +0,0 @@
From 8390d1d432330e143832734d5799528013e79178 Mon Sep 17 00:00:00 2001
From: Dmitri Pal <dpal@redhat.com>
Date: Mon, 23 Sep 2013 16:03:30 -0400
Subject: [PATCH] Trim trailing spaces
This patch addressed issue https://fedorahosted.org/sssd/ticket/2095
The new parser in fact stopped trimming trailing spaces.
This is now corrected.
---
ini/ini.d/real.conf | 2 +-
ini/ini_parse.c | 7 ++++
ini/ini_parse_ut.c | 100 ++++++++++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 108 insertions(+), 1 deletion(-)
diff --git a/ini/ini.d/real.conf b/ini/ini.d/real.conf
index 32bc9dae0c40ce46dc4c375963b5d0cf2a05e17b..1e155b820061001695d85edfeca1819e799e2a4b 100644
--- a/ini/ini.d/real.conf
+++ b/ini/ini.d/real.conf
@@ -40,7 +40,7 @@ legacy = FALSE
enumerate = 3
[domains/EXAMPLE.COM]
-description = Example domain served by IPA
+description = Example domain served by IPA
provider = ipa
server = ipaserver1.example.com
server = ipabackupserver.example.com
diff --git a/ini/ini_parse.c b/ini/ini_parse.c
index 60ef1169986f2ea27596931ebf16fab166c71937..9a1c0ec63013adb986b627c977c9759c1d5a210e 100644
--- a/ini/ini_parse.c
+++ b/ini/ini_parse.c
@@ -968,6 +968,13 @@ static int handle_kvp(struct parser_obj *po, uint32_t *action)
full_len--;
}
+ /* Trucate trailing spaces */
+ /* Make sure not to step before the beginning */
+ while (full_len && isspace(str[full_len - 1])) {
+ str[full_len - 1] = '\0';
+ full_len--;
+ }
+
/* Check if we have the key */
if (*(str) == '=') {
po->last_error = ERR_NOKEY;
diff --git a/ini/ini_parse_ut.c b/ini/ini_parse_ut.c
index 32c59e7a3a36a5b719620ae42cf070154d4eb416..2655d7e8e11a391db324a9c022004f7cbbeb092e 100644
--- a/ini/ini_parse_ut.c
+++ b/ini/ini_parse_ut.c
@@ -2650,6 +2650,105 @@ int space_test(void)
return EOK;
}
+
+int trim_test(void)
+{
+ int error;
+ struct ini_cfgfile *file_ctx = NULL;
+ struct ini_cfgobj *ini_config = NULL;
+ char **error_list = NULL;
+ char infile[PATH_MAX];
+ char *srcdir = NULL;
+ const char *value;
+ struct value_obj *vo = NULL;
+
+ INIOUT(printf("\n\n<==== TRIM TEST START =====>\n"));
+
+ srcdir = getenv("srcdir");
+ snprintf(infile, PATH_MAX, "%s/ini/ini.d/real.conf",
+ (srcdir == NULL) ? "." : srcdir);
+
+
+ INIOUT(printf("Reading file %s\n", infile));
+ error = ini_config_file_open(infile,
+ 0,
+ &file_ctx);
+ if (error) {
+ printf("Failed to open file for reading. Error %d.\n", error);
+ return error;
+ }
+
+ INIOUT(printf("Creating configuration object\n"));
+ error = ini_config_create(&ini_config);
+ if (error) {
+ printf("Failed to create object. Error %d.\n", error);
+ ini_config_file_destroy(file_ctx);
+ return error;
+ }
+ INIOUT(printf("Parsing\n"));
+ error = ini_config_parse(file_ctx,
+ INI_STOP_ON_NONE,
+ 0,
+ 0,
+ ini_config);
+ if (error) {
+ INIOUT(printf("Failed to parse configuration. "
+ "Error %d.\n", error));
+
+ if (ini_config_error_count(ini_config)) {
+ INIOUT(printf("Errors detected while parsing: %s\n",
+ ini_config_get_filename(file_ctx)));
+ ini_config_get_errors(ini_config, &error_list);
+ INIOUT(ini_config_print_errors(stdout, error_list));
+ ini_config_free_errors(error_list);
+ }
+ ini_config_file_destroy(file_ctx);
+ return error;
+ }
+
+ INIOUT(col_debug_collection(ini_config->cfg, COL_TRAVERSE_DEFAULT));
+ ini_config_file_destroy(file_ctx);
+
+ vo = NULL;
+ error = ini_get_config_valueobj("domains/EXAMPLE.COM",
+ "description",
+ ini_config,
+ INI_GET_FIRST_VALUE,
+ &vo);
+ if(error) {
+ printf("Expected success but got error! %d\n",error);
+ ini_config_destroy(ini_config);
+ return error;
+ }
+
+ /* Value should be found */
+ if (vo == NULL) {
+ printf("Expected success but got NULL.\n");
+ ini_config_destroy(ini_config);
+ return -1;
+ }
+
+ value = ini_get_const_string_config_value(vo, NULL);
+
+ if (value == NULL) {
+ printf("No value.\n");
+ ini_config_destroy(ini_config);
+ return -1;
+ }
+
+ if(value[strlen(value) - 1] == ' ') {
+ printf("Trailing space is not trimmed.\n");
+ ini_config_destroy(ini_config);
+ return -1;
+ }
+
+ INIOUT(printf("[%s]\n", value));
+
+ ini_config_destroy(ini_config);
+
+ INIOUT(printf("\n<==== TRIM TEST END =====>\n\n"));
+ return EOK;
+}
/* Main function of the unit test */
int main(int argc, char *argv[])
{
@@ -2663,6 +2762,7 @@ int main(int argc, char *argv[])
reload_test,
get_test,
space_test,
+ trim_test,
NULL };
test_fn t;
int i = 0;
--
1.8.3.1

View File

@ -1,82 +0,0 @@
From 723ce0cd957d2b17618ca9698bcc66e61b9b6110 Mon Sep 17 00:00:00 2001
From: Ondrej Kos <okos@redhat.com>
Date: Fri, 12 Jul 2013 14:05:23 +0200
Subject: [PATCH 1/2] DOXY: Don't generate timestamp
https://fedorahosted.org/sssd/ticket/2003
---
basicobjects/basicobjects.cfg.doxy.in | 2 +-
collection/collection.cfg.doxy.in | 2 +-
ini/ini_config.cfg.doxy.in | 2 +-
path_utils/path_utils.cfg.doxy.in | 2 +-
refarray/ref_array.cfg.doxy.in | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/basicobjects/basicobjects.cfg.doxy.in b/basicobjects/basicobjects.cfg.doxy.in
index fed0cfbe1256c3ffcd9010d7de34babe3d266de4..f70e19c00a4e7c11c178b3c1281a00694158157a 100644
--- a/basicobjects/basicobjects.cfg.doxy.in
+++ b/basicobjects/basicobjects.cfg.doxy.in
@@ -810,7 +810,7 @@ HTML_STYLESHEET =
# page will contain the date and time when the page was generated. Setting
# this to NO can help when comparing the output of multiple runs.
-HTML_TIMESTAMP = YES
+HTML_TIMESTAMP = NO
# If the HTML_ALIGN_MEMBERS tag is set to YES, the members of classes,
# files or namespaces will be aligned in HTML using tables. If set to
diff --git a/collection/collection.cfg.doxy.in b/collection/collection.cfg.doxy.in
index 77e42df81f4dd7159798816d75312f2993f5447a..ec134e88cb019543e461ff0131b6cd1b7eed6a87 100644
--- a/collection/collection.cfg.doxy.in
+++ b/collection/collection.cfg.doxy.in
@@ -810,7 +810,7 @@ HTML_STYLESHEET =
# page will contain the date and time when the page was generated. Setting
# this to NO can help when comparing the output of multiple runs.
-HTML_TIMESTAMP = YES
+HTML_TIMESTAMP = NO
# If the HTML_ALIGN_MEMBERS tag is set to YES, the members of classes,
# files or namespaces will be aligned in HTML using tables. If set to
diff --git a/ini/ini_config.cfg.doxy.in b/ini/ini_config.cfg.doxy.in
index ee87fa77aa69b4df9e48aa92c75dbf07429e793b..f92dbdecdbbfab86f38eb419062110d737b1b538 100644
--- a/ini/ini_config.cfg.doxy.in
+++ b/ini/ini_config.cfg.doxy.in
@@ -810,7 +810,7 @@ HTML_STYLESHEET =
# page will contain the date and time when the page was generated. Setting
# this to NO can help when comparing the output of multiple runs.
-HTML_TIMESTAMP = YES
+HTML_TIMESTAMP = NO
# If the HTML_ALIGN_MEMBERS tag is set to YES, the members of classes,
# files or namespaces will be aligned in HTML using tables. If set to
diff --git a/path_utils/path_utils.cfg.doxy.in b/path_utils/path_utils.cfg.doxy.in
index 306f8ec5eb247609606d9f49cbca8f3a376a3074..2b99a3f91f32ebaef0b8aaddf13a4b9822bcc862 100644
--- a/path_utils/path_utils.cfg.doxy.in
+++ b/path_utils/path_utils.cfg.doxy.in
@@ -810,7 +810,7 @@ HTML_STYLESHEET =
# page will contain the date and time when the page was generated. Setting
# this to NO can help when comparing the output of multiple runs.
-HTML_TIMESTAMP = YES
+HTML_TIMESTAMP = NO
# If the HTML_ALIGN_MEMBERS tag is set to YES, the members of classes,
# files or namespaces will be aligned in HTML using tables. If set to
diff --git a/refarray/ref_array.cfg.doxy.in b/refarray/ref_array.cfg.doxy.in
index 37f3356819ce20be4b3c429e618c8eea0802a54c..120f1f19d9f7108a70a208b7be76427e037a2793 100644
--- a/refarray/ref_array.cfg.doxy.in
+++ b/refarray/ref_array.cfg.doxy.in
@@ -810,7 +810,7 @@ HTML_STYLESHEET =
# page will contain the date and time when the page was generated. Setting
# this to NO can help when comparing the output of multiple runs.
-HTML_TIMESTAMP = YES
+HTML_TIMESTAMP = NO
# If the HTML_ALIGN_MEMBERS tag is set to YES, the members of classes,
# files or namespaces will be aligned in HTML using tables. If set to
--
1.8.1.4

View File

@ -1,11 +0,0 @@
--- ding-libs-0.3.0.1/configure.ac.orig 2014-01-18 13:50:44.952835994 +0000
+++ ding-libs-0.3.0.1/configure.ac 2014-01-18 13:50:57.947147437 +0000
@@ -5,7 +5,7 @@
AC_CONFIG_SRCDIR([README])
AC_CONFIG_AUX_DIR([build])
AC_GNU_SOURCE
-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AM_PROG_CC_C_O
m4_pattern_allow([AM_PROG_AR])
AM_PROG_AR

View File

@ -1,6 +1,6 @@
Name: ding-libs
Version: 0.3.0.1
Release: 21%{?dist}
Version: 0.4.0
Release: 22%{?dist}
Summary: "Ding is not GLib" assorted utility libraries
Group: Development/Libraries
License: LGPLv3+
@ -14,15 +14,11 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
%global path_utils_version 0.2.1
%global dhash_version 0.4.3
%global collection_version 0.6.2
%global ref_array_version 0.1.3
%global basicobjects_version 0.1.0
%global ini_config_version 1.0.0.1
%global ref_array_version 0.1.4
%global basicobjects_version 0.1.1
%global ini_config_version 1.1.0
### Patches ###
Patch0001: 0001-INI-Bump-version-info.patch
Patch0002: 0002-Trim-trailing-spaces.patch
Patch0003: 0003-DOXY-Don-t-generate-timestamp.patch
Patch0004: ding-libs-fix-build.patch
### Dependencies ###
# ding-libs is a meta-package that will pull in all of its own
@ -312,10 +308,6 @@ structure
%prep
%setup -q
%patch0001 -p1 -b .version
%patch0002 -p1 -b .whitespace
%patch0003 -p1 -b .doxygen
%patch0004 -p1 -b .automake-fix
%build
autoreconf -ivf
@ -345,6 +337,10 @@ rm -f \
rm -f */doc/html/installdox
%changelog
* Thu May 29 2014 Jakub Hrozek <jhrozek@redhat.com> 0.4.0-22
- New upstream release 0.4.0
- https://fedorahosted.org/sssd/wiki/Releases/DingNotes-0.4.0
* Sat Jan 18 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.3.0.1-21
- Fix FTBFS on rawhide
- update spec