Fix FTBFS on rawhide, update spec
This commit is contained in:
parent
235afa51fe
commit
41f600a079
11
ding-libs-fix-build.patch
Normal file
11
ding-libs-fix-build.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ding-libs-0.3.0.1/configure.ac.orig 2014-01-18 13:50:44.952835994 +0000
|
||||
+++ ding-libs-0.3.0.1/configure.ac 2014-01-18 13:50:57.947147437 +0000
|
||||
@@ -5,7 +5,7 @@
|
||||
AC_CONFIG_SRCDIR([README])
|
||||
AC_CONFIG_AUX_DIR([build])
|
||||
AC_GNU_SOURCE
|
||||
-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
|
||||
+AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
|
||||
AM_PROG_CC_C_O
|
||||
m4_pattern_allow([AM_PROG_AR])
|
||||
AM_PROG_AR
|
@ -1,6 +1,6 @@
|
||||
Name: ding-libs
|
||||
Version: 0.3.0.1
|
||||
Release: 20%{?dist}
|
||||
Release: 21%{?dist}
|
||||
Summary: "Ding is not GLib" assorted utility libraries
|
||||
Group: Development/Libraries
|
||||
License: LGPLv3+
|
||||
@ -22,6 +22,7 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
Patch0001: 0001-INI-Bump-version-info.patch
|
||||
Patch0002: 0002-Trim-trailing-spaces.patch
|
||||
Patch0003: 0003-DOXY-Don-t-generate-timestamp.patch
|
||||
Patch0004: ding-libs-fix-build.patch
|
||||
|
||||
### Dependencies ###
|
||||
# ding-libs is a meta-package that will pull in all of its own
|
||||
@ -90,12 +91,10 @@ Utility functions to manipulate filesystem pathnames
|
||||
%postun -n libpath_utils -p /sbin/ldconfig
|
||||
|
||||
%files -n libpath_utils
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING COPYING.LESSER
|
||||
%{_libdir}/libpath_utils.so.*
|
||||
|
||||
%files -n libpath_utils-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/path_utils.h
|
||||
%{_libdir}/libpath_utils.so
|
||||
%{_libdir}/pkgconfig/path_utils.pc
|
||||
@ -132,12 +131,10 @@ time properties
|
||||
%postun -n libdhash -p /sbin/ldconfig
|
||||
|
||||
%files -n libdhash
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING COPYING.LESSER
|
||||
%{_libdir}/libdhash.so.*
|
||||
|
||||
%files -n libdhash-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/dhash.h
|
||||
%{_libdir}/libdhash.so
|
||||
%{_libdir}/pkgconfig/dhash.pc
|
||||
@ -174,13 +171,11 @@ and serialization
|
||||
|
||||
|
||||
%files -n libcollection
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%doc COPYING.LESSER
|
||||
%{_libdir}/libcollection.so.*
|
||||
|
||||
%files -n libcollection-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/collection.h
|
||||
%{_includedir}/collection_tools.h
|
||||
%{_includedir}/collection_queue.h
|
||||
@ -217,13 +212,11 @@ A dynamically-growing, reference-counted array
|
||||
%postun -n libref_array -p /sbin/ldconfig
|
||||
|
||||
%files -n libref_array
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%doc COPYING.LESSER
|
||||
%{_libdir}/libref_array.so.*
|
||||
|
||||
%files -n libref_array-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/ref_array.h
|
||||
%{_libdir}/libref_array.so
|
||||
%{_libdir}/pkgconfig/ref_array.pc
|
||||
@ -258,13 +251,11 @@ Basic object types
|
||||
%postun -n libbasicobjects -p /sbin/ldconfig
|
||||
|
||||
%files -n libbasicobjects
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%doc COPYING.LESSER
|
||||
%{_libdir}/libbasicobjects.so.*
|
||||
|
||||
%files -n libbasicobjects-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/simplebuffer.h
|
||||
%{_libdir}/libbasicobjects.so
|
||||
%{_libdir}/pkgconfig/basicobjects.pc
|
||||
@ -301,13 +292,11 @@ structure
|
||||
%postun -n libini_config -p /sbin/ldconfig
|
||||
|
||||
%files -n libini_config
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%doc COPYING.LESSER
|
||||
%{_libdir}/libini_config.so.*
|
||||
|
||||
%files -n libini_config-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/ini_config.h
|
||||
%{_includedir}/ini_comment.h
|
||||
%{_includedir}/ini_configobj.h
|
||||
@ -326,6 +315,7 @@ structure
|
||||
%patch0001 -p1 -b .version
|
||||
%patch0002 -p1 -b .whitespace
|
||||
%patch0003 -p1 -b .doxygen
|
||||
%patch0004 -p1 -b .automake-fix
|
||||
|
||||
%build
|
||||
autoreconf -ivf
|
||||
@ -338,8 +328,6 @@ make %{?_smp_mflags} all docs
|
||||
make %{?_smp_mflags} check
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
# Remove .la files created by libtool
|
||||
@ -356,10 +344,11 @@ rm -f \
|
||||
# Remove document install script. RPM is handling this
|
||||
rm -f */doc/html/installdox
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Sat Jan 18 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.3.0.1-21
|
||||
- Fix FTBFS on rawhide
|
||||
- update spec
|
||||
|
||||
* Fri Sep 27 2013 Jakub Hrozek <jhrozek@redhat.com> - 0.3.0.1-20
|
||||
- Merge Doxygen patch from f19 branch to avoid regressions
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user