- -fvisibility fails me again
This commit is contained in:
parent
23231df2e7
commit
fcaadbef6a
@ -1,6 +1,6 @@
|
||||
diff -up dhcp-4.0.0/configure.ac.libdhcp4client dhcp-4.0.0/configure.ac
|
||||
--- dhcp-4.0.0/configure.ac.libdhcp4client 2007-12-14 08:24:56.000000000 -1000
|
||||
+++ dhcp-4.0.0/configure.ac 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/configure.ac 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -1,5 +1,32 @@
|
||||
AC_INIT([DHCP], [4.0.0], [dhcp-users@isc.org])
|
||||
|
||||
@ -46,7 +46,7 @@ diff -up dhcp-4.0.0/configure.ac.libdhcp4client dhcp-4.0.0/configure.ac
|
||||
# we sometimes need to know byte order for building packets
|
||||
diff -up dhcp-4.0.0/omapip/Makefile.am.libdhcp4client dhcp-4.0.0/omapip/Makefile.am
|
||||
--- dhcp-4.0.0/omapip/Makefile.am.libdhcp4client 2007-05-29 06:32:11.000000000 -1000
|
||||
+++ dhcp-4.0.0/omapip/Makefile.am 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/omapip/Makefile.am 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -1,10 +1,18 @@
|
||||
lib_LIBRARIES = libomapi.a
|
||||
+noinst_LIBRARIES = libomapiLIBDHCP.a
|
||||
@ -68,7 +68,7 @@ diff -up dhcp-4.0.0/omapip/Makefile.am.libdhcp4client dhcp-4.0.0/omapip/Makefile
|
||||
|
||||
diff -up dhcp-4.0.0/omapip/dispatch.c.libdhcp4client dhcp-4.0.0/omapip/dispatch.c
|
||||
--- dhcp-4.0.0/omapip/dispatch.c.libdhcp4client 2007-11-30 11:51:43.000000000 -1000
|
||||
+++ dhcp-4.0.0/omapip/dispatch.c 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/omapip/dispatch.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -37,7 +37,7 @@
|
||||
#include <omapip/omapip_p.h>
|
||||
#include <sys/time.h>
|
||||
@ -79,8 +79,8 @@ diff -up dhcp-4.0.0/omapip/dispatch.c.libdhcp4client dhcp-4.0.0/omapip/dispatch.
|
||||
|
||||
OMAPI_OBJECT_ALLOC (omapi_io,
|
||||
diff -up dhcp-4.0.0/omapip/errwarn.c.libdhcp4client dhcp-4.0.0/omapip/errwarn.c
|
||||
--- dhcp-4.0.0/omapip/errwarn.c.libdhcp4client 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/omapip/errwarn.c 2008-01-13 12:51:31.000000000 -1000
|
||||
--- dhcp-4.0.0/omapip/errwarn.c.libdhcp4client 2008-01-14 13:03:05.000000000 -1000
|
||||
+++ dhcp-4.0.0/omapip/errwarn.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -37,6 +37,11 @@
|
||||
#include <errno.h>
|
||||
#include <syslog.h>
|
||||
@ -200,7 +200,7 @@ diff -up dhcp-4.0.0/omapip/errwarn.c.libdhcp4client dhcp-4.0.0/omapip/errwarn.c
|
||||
|
||||
diff -up dhcp-4.0.0/omapip/alloc.c.libdhcp4client dhcp-4.0.0/omapip/alloc.c
|
||||
--- dhcp-4.0.0/omapip/alloc.c.libdhcp4client 2007-07-12 20:43:42.000000000 -1000
|
||||
+++ dhcp-4.0.0/omapip/alloc.c 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/omapip/alloc.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -37,6 +37,33 @@
|
||||
|
||||
#include <omapip/omapip_p.h>
|
||||
@ -257,8 +257,8 @@ diff -up dhcp-4.0.0/omapip/alloc.c.libdhcp4client dhcp-4.0.0/omapip/alloc.c
|
||||
|
||||
#if defined (DEBUG_MEMORY_LEAKAGE) || defined (DEBUG_MALLOC_POOL) || \
|
||||
diff -up dhcp-4.0.0/dst/Makefile.am.libdhcp4client dhcp-4.0.0/dst/Makefile.am
|
||||
--- dhcp-4.0.0/dst/Makefile.am.libdhcp4client 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/dst/Makefile.am 2008-01-13 12:52:19.000000000 -1000
|
||||
--- dhcp-4.0.0/dst/Makefile.am.libdhcp4client 2008-01-14 13:03:05.000000000 -1000
|
||||
+++ dhcp-4.0.0/dst/Makefile.am 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -2,7 +2,7 @@ AM_CPPFLAGS = -DMINIRES_LIB -DHMAC_MD5
|
||||
|
||||
lib_LIBRARIES = libdst.a
|
||||
@ -279,7 +279,7 @@ diff -up dhcp-4.0.0/dst/Makefile.am.libdhcp4client dhcp-4.0.0/dst/Makefile.am
|
||||
EXTRA_DIST = dst_internal.h md5.h md5_locl.h
|
||||
diff -up dhcp-4.0.0/dst/hmac_link.c.libdhcp4client dhcp-4.0.0/dst/hmac_link.c
|
||||
--- dhcp-4.0.0/dst/hmac_link.c.libdhcp4client 2007-12-05 14:50:22.000000000 -1000
|
||||
+++ dhcp-4.0.0/dst/hmac_link.c 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/dst/hmac_link.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -39,6 +39,10 @@ static const char rcsid[] = "$Header: /p
|
||||
|
||||
#include "dst_internal.h"
|
||||
@ -367,7 +367,7 @@ diff -up dhcp-4.0.0/dst/hmac_link.c.libdhcp4client dhcp-4.0.0/dst/hmac_link.c
|
||||
memset(dst_t_func[KEY_HMAC_MD5], 0, sizeof(struct dst_func));
|
||||
diff -up dhcp-4.0.0/common/Makefile.am.libdhcp4client dhcp-4.0.0/common/Makefile.am
|
||||
--- dhcp-4.0.0/common/Makefile.am.libdhcp4client 2007-11-16 01:04:11.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/Makefile.am 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/Makefile.am 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -1,11 +1,17 @@
|
||||
AM_CPPFLAGS = -I.. -DLOCALSTATEDIR='"@localstatedir@"'
|
||||
|
||||
@ -389,7 +389,7 @@ diff -up dhcp-4.0.0/common/Makefile.am.libdhcp4client dhcp-4.0.0/common/Makefile
|
||||
|
||||
diff -up dhcp-4.0.0/common/discover.c.libdhcp4client dhcp-4.0.0/common/discover.c
|
||||
--- dhcp-4.0.0/common/discover.c.libdhcp4client 2007-10-05 12:29:51.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/discover.c 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/discover.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -883,6 +883,10 @@ add_ipv6_addr_to_interface(struct interf
|
||||
register that interface with the network I/O software, figure out what
|
||||
subnet it's on, and add it to the list of interfaces. */
|
||||
@ -431,7 +431,7 @@ diff -up dhcp-4.0.0/common/discover.c.libdhcp4client dhcp-4.0.0/common/discover.
|
||||
if (fallback_interface) {
|
||||
diff -up dhcp-4.0.0/common/tree.c.libdhcp4client dhcp-4.0.0/common/tree.c
|
||||
--- dhcp-4.0.0/common/tree.c.libdhcp4client 2007-08-22 03:41:37.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/tree.c 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/tree.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -41,7 +41,7 @@
|
||||
# include <regex.h>
|
||||
#endif
|
||||
@ -451,7 +451,7 @@ diff -up dhcp-4.0.0/common/tree.c.libdhcp4client dhcp-4.0.0/common/tree.c
|
||||
struct data_string *result;
|
||||
diff -up dhcp-4.0.0/common/options.c.libdhcp4client dhcp-4.0.0/common/options.c
|
||||
--- dhcp-4.0.0/common/options.c.libdhcp4client 2007-11-30 11:51:43.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/options.c 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/options.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -3392,6 +3392,7 @@ fqdn6_universe_decode(struct option_stat
|
||||
return 0;
|
||||
}
|
||||
@ -461,8 +461,8 @@ diff -up dhcp-4.0.0/common/options.c.libdhcp4client dhcp-4.0.0/common/options.c
|
||||
struct client_state *client_state,
|
||||
struct option_state *in_options,
|
||||
diff -up dhcp-4.0.0/common/dispatch.c.libdhcp4client dhcp-4.0.0/common/dispatch.c
|
||||
--- dhcp-4.0.0/common/dispatch.c.libdhcp4client 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/dispatch.c 2008-01-13 12:51:31.000000000 -1000
|
||||
--- dhcp-4.0.0/common/dispatch.c.libdhcp4client 2008-01-14 13:03:05.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/dispatch.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -34,8 +34,24 @@
|
||||
|
||||
#include "dhcpd.h"
|
||||
@ -734,7 +734,7 @@ diff -up dhcp-4.0.0/common/dispatch.c.libdhcp4client dhcp-4.0.0/common/dispatch.
|
||||
}
|
||||
diff -up dhcp-4.0.0/common/alloc.c.libdhcp4client dhcp-4.0.0/common/alloc.c
|
||||
--- dhcp-4.0.0/common/alloc.c.libdhcp4client 2007-10-23 14:54:11.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/alloc.c 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/common/alloc.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -1004,7 +1004,11 @@ int executable_statement_reference (ptr,
|
||||
return 1;
|
||||
}
|
||||
@ -748,8 +748,8 @@ diff -up dhcp-4.0.0/common/alloc.c.libdhcp4client dhcp-4.0.0/common/alloc.c
|
||||
#if defined (DEBUG_MEMORY_LEAKAGE) || \
|
||||
defined (DEBUG_MEMORY_LEAKAGE_ON_EXIT)
|
||||
diff -up dhcp-4.0.0/includes/dhcpd.h.libdhcp4client dhcp-4.0.0/includes/dhcpd.h
|
||||
--- dhcp-4.0.0/includes/dhcpd.h.libdhcp4client 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/includes/dhcpd.h 2008-01-13 12:51:31.000000000 -1000
|
||||
--- dhcp-4.0.0/includes/dhcpd.h.libdhcp4client 2008-01-14 13:03:05.000000000 -1000
|
||||
+++ dhcp-4.0.0/includes/dhcpd.h 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -1199,14 +1199,6 @@ struct hardware_link {
|
||||
|
||||
typedef void (*tvref_t)(void *, void *, const char *, int);
|
||||
@ -783,8 +783,8 @@ diff -up dhcp-4.0.0/includes/dhcpd.h.libdhcp4client dhcp-4.0.0/includes/dhcpd.h
|
||||
extern trace_type_t *interface_trace;
|
||||
diff -up dhcp-4.0.0/client/Makefile.am.libdhcp4client dhcp-4.0.0/client/Makefile.am
|
||||
--- dhcp-4.0.0/client/Makefile.am.libdhcp4client 2007-12-12 09:23:42.000000000 -1000
|
||||
+++ dhcp-4.0.0/client/Makefile.am 2008-01-13 12:51:31.000000000 -1000
|
||||
@@ -1,10 +1,19 @@
|
||||
+++ dhcp-4.0.0/client/Makefile.am 2008-01-14 13:03:24.000000000 -1000
|
||||
@@ -1,10 +1,18 @@
|
||||
dist_sysconf_DATA = dhclient.conf
|
||||
sbin_PROGRAMS = dhclient
|
||||
+lib_LTLIBRARIES = libdhcp4client.la
|
||||
@ -793,8 +793,7 @@ diff -up dhcp-4.0.0/client/Makefile.am.libdhcp4client dhcp-4.0.0/client/Makefile
|
||||
scripts/nextstep scripts/openbsd scripts/solaris
|
||||
dhclient_LDADD = ../common/libdhcp.a ../minires/libres.a \
|
||||
../omapip/libomapi.a ../dst/libdst.a
|
||||
+libdhcp4client_la_CFLAGS = -DLIBDHCP -DLOCALSTATEDIR='"@localstatedir@"' \
|
||||
+ -fvisibility=hidden
|
||||
+libdhcp4client_la_CFLAGS = -DLIBDHCP -DLOCALSTATEDIR='"@localstatedir@"'
|
||||
+libdhcp4client_la_LDFLAGS = -version-info \
|
||||
+ $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
|
||||
+ -release $(LT_RELEASE)
|
||||
@ -805,8 +804,8 @@ diff -up dhcp-4.0.0/client/Makefile.am.libdhcp4client dhcp-4.0.0/client/Makefile
|
||||
EXTRA_DIST = $(man_MANS)
|
||||
|
||||
diff -up dhcp-4.0.0/client/dhclient.c.libdhcp4client dhcp-4.0.0/client/dhclient.c
|
||||
--- dhcp-4.0.0/client/dhclient.c.libdhcp4client 2008-01-13 12:51:31.000000000 -1000
|
||||
+++ dhcp-4.0.0/client/dhclient.c 2008-01-13 12:51:31.000000000 -1000
|
||||
--- dhcp-4.0.0/client/dhclient.c.libdhcp4client 2008-01-14 13:03:05.000000000 -1000
|
||||
+++ dhcp-4.0.0/client/dhclient.c 2008-01-14 13:03:05.000000000 -1000
|
||||
@@ -83,14 +83,50 @@ int nowait=0;
|
||||
char *mockup_relay = NULL;
|
||||
int bootp_broadcast_always = 0;
|
||||
|
@ -4,7 +4,7 @@
|
||||
Summary: DHCP (Dynamic Host Configuration Protocol) server and relay agent
|
||||
Name: dhcp
|
||||
Version: 4.0.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# NEVER CHANGE THE EPOCH on this package. The previous maintainer made
|
||||
# incorrect use of the epoch and that's why it is at 12 now. It should have
|
||||
# never been used, but it was. So we are stuck with it.
|
||||
@ -400,6 +400,9 @@ fi
|
||||
%{_libdir}/libdhcp4client.so
|
||||
|
||||
%changelog
|
||||
* Mon Jan 14 2008 David Cantrell <dcantrell@redhat.com> - 12:4.0.0-2
|
||||
- -fvisibility fails me again
|
||||
|
||||
* Mon Jan 14 2008 David Cantrell <dcantrell@redhat.com> - 12:4.0.0-1
|
||||
- Upgrade to ISC dhcp-4.0.0 (#426634)
|
||||
- first ISC release to incorporate DHCPv6 protocol support
|
||||
|
Loading…
Reference in New Issue
Block a user