- Upgrade to ISC dhcp-4.0.0 (#426634)

- first ISC release to incorporate DHCPv6 protocol support
- source tree now uses GNU autoconf/automake
- Removed the libdhcp4client-static package
This commit is contained in:
David Cantrell 2008-01-14 21:05:18 +00:00
parent dcf32f5236
commit 23231df2e7
2 changed files with 19 additions and 20 deletions

View File

@ -1,6 +1,6 @@
diff -up dhcp-4.0.0/server/Makefile.am.ldap dhcp-4.0.0/server/Makefile.am
--- dhcp-4.0.0/server/Makefile.am.ldap 2007-05-29 06:32:11.000000000 -1000
+++ dhcp-4.0.0/server/Makefile.am 2008-01-13 12:55:37.000000000 -1000
+++ dhcp-4.0.0/server/Makefile.am 2008-01-14 10:42:59.000000000 -1000
@@ -4,12 +4,10 @@ dist_sysconf_DATA = dhcpd.conf
sbin_PROGRAMS = dhcpd
dhcpd_SOURCES = dhcpd.c dhcp.c bootp.c confpars.c db.c class.c failover.c \
@ -19,7 +19,7 @@ diff -up dhcp-4.0.0/server/Makefile.am.ldap dhcp-4.0.0/server/Makefile.am
EXTRA_DIST = $(man_MANS)
diff -up dhcp-4.0.0/server/mdb.c.ldap dhcp-4.0.0/server/mdb.c
--- dhcp-4.0.0/server/mdb.c.ldap 2007-11-30 11:51:43.000000000 -1000
+++ dhcp-4.0.0/server/mdb.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/server/mdb.c 2008-01-14 10:42:59.000000000 -1000
@@ -600,6 +600,12 @@ int find_hosts_by_haddr (struct host_dec
const char *file, int line)
{
@ -35,7 +35,7 @@ diff -up dhcp-4.0.0/server/mdb.c.ldap dhcp-4.0.0/server/mdb.c
h.hbuf [0] = htype;
diff -up /dev/null dhcp-4.0.0/server/ldap_casa.c
--- /dev/null 2008-01-11 10:40:59.147013395 -1000
+++ dhcp-4.0.0/server/ldap_casa.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/server/ldap_casa.c 2008-01-14 10:42:59.000000000 -1000
@@ -0,0 +1,138 @@
+/* ldap_casa.c
+
@ -177,7 +177,7 @@ diff -up /dev/null dhcp-4.0.0/server/ldap_casa.c
+
diff -up dhcp-4.0.0/server/dhcpd.c.ldap dhcp-4.0.0/server/dhcpd.c
--- dhcp-4.0.0/server/dhcpd.c.ldap 2007-11-30 11:51:43.000000000 -1000
+++ dhcp-4.0.0/server/dhcpd.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/server/dhcpd.c 2008-01-14 10:42:59.000000000 -1000
@@ -505,6 +505,14 @@ main(int argc, char **argv) {
/* Add the ddns update style enumeration prior to parsing. */
add_enumeration (&ddns_styles);
@ -195,7 +195,7 @@ diff -up dhcp-4.0.0/server/dhcpd.c.ldap dhcp-4.0.0/server/dhcpd.c
log_fatal ("Can't allocate root group!");
diff -up /dev/null dhcp-4.0.0/server/ldap.c
--- /dev/null 2008-01-11 10:40:59.147013395 -1000
+++ dhcp-4.0.0/server/ldap.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/server/ldap.c 2008-01-14 10:42:59.000000000 -1000
@@ -0,0 +1,2004 @@
+/* ldap.c
+
@ -2203,7 +2203,7 @@ diff -up /dev/null dhcp-4.0.0/server/ldap.c
+#endif
diff -up dhcp-4.0.0/server/confpars.c.ldap dhcp-4.0.0/server/confpars.c
--- dhcp-4.0.0/server/confpars.c.ldap 2007-11-30 11:51:43.000000000 -1000
+++ dhcp-4.0.0/server/confpars.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/server/confpars.c 2008-01-14 10:42:59.000000000 -1000
@@ -60,7 +60,17 @@ void parse_trace_setup ()
isc_result_t readconf ()
@ -2225,7 +2225,7 @@ diff -up dhcp-4.0.0/server/confpars.c.ldap dhcp-4.0.0/server/confpars.c
isc_result_t read_conf_file (const char *filename, struct group *group,
diff -up dhcp-4.0.0/server/class.c.ldap dhcp-4.0.0/server/class.c
--- dhcp-4.0.0/server/class.c.ldap 2007-09-05 07:32:10.000000000 -1000
+++ dhcp-4.0.0/server/class.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/server/class.c 2008-01-14 10:42:59.000000000 -1000
@@ -84,6 +84,7 @@ int check_collection (packet, lease, col
int matched = 0;
int status;
@ -2255,7 +2255,7 @@ diff -up dhcp-4.0.0/server/class.c.ldap dhcp-4.0.0/server/class.c
print_hex_1 (data.len,
diff -up dhcp-4.0.0/server/stables.c.ldap dhcp-4.0.0/server/stables.c
--- dhcp-4.0.0/server/stables.c.ldap 2007-11-20 08:34:37.000000000 -1000
+++ dhcp-4.0.0/server/stables.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/server/stables.c 2008-01-14 10:45:48.000000000 -1000
@@ -238,9 +238,107 @@ static struct option server_options[] =
{ "dhcpv6-lease-file-name", "t", &server_universe, 54, 1 },
{ "dhcpv6-pid-file-name", "t", &server_universe, 55, 1 },
@ -2314,7 +2314,7 @@ diff -up dhcp-4.0.0/server/stables.c.ldap dhcp-4.0.0/server/stables.c
+
+struct enumeration ldap_methods = {
+ (struct enumeration *)0,
+ "ldap-methods",
+ "ldap-methods", 1,
+ ldap_values
+};
+
@ -2329,7 +2329,7 @@ diff -up dhcp-4.0.0/server/stables.c.ldap dhcp-4.0.0/server/stables.c
+
+struct enumeration ldap_ssl_usage_enum = {
+ (struct enumeration *)0,
+ "ldap-ssl-usage",
+ "ldap-ssl-usage", 1,
+ ldap_ssl_usage_values
+};
+
@ -2343,7 +2343,7 @@ diff -up dhcp-4.0.0/server/stables.c.ldap dhcp-4.0.0/server/stables.c
+};
+struct enumeration ldap_tls_reqcert_enum = {
+ (struct enumeration *)0,
+ "ldap-tls-reqcert",
+ "ldap-tls-reqcert", 1,
+ ldap_tls_reqcert_values
+};
+
@ -2355,7 +2355,7 @@ diff -up dhcp-4.0.0/server/stables.c.ldap dhcp-4.0.0/server/stables.c
+};
+struct enumeration ldap_tls_crlcheck_enum = {
+ (struct enumeration *)0,
+ "ldap-tls-crlcheck",
+ "ldap-tls-crlcheck", 1,
+ ldap_tls_crlcheck_values
+};
+#endif
@ -2366,7 +2366,7 @@ diff -up dhcp-4.0.0/server/stables.c.ldap dhcp-4.0.0/server/stables.c
{ "ad-hoc", 1 },
diff -up dhcp-4.0.0/dst/Makefile.am.ldap dhcp-4.0.0/dst/Makefile.am
--- dhcp-4.0.0/dst/Makefile.am.ldap 2007-05-29 06:32:10.000000000 -1000
+++ dhcp-4.0.0/dst/Makefile.am 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/dst/Makefile.am 2008-01-14 10:42:59.000000000 -1000
@@ -2,7 +2,12 @@ AM_CPPFLAGS = -DMINIRES_LIB -DHMAC_MD5
lib_LIBRARIES = libdst.a
@ -2382,7 +2382,7 @@ diff -up dhcp-4.0.0/dst/Makefile.am.ldap dhcp-4.0.0/dst/Makefile.am
EXTRA_DIST = dst_internal.h md5.h md5_locl.h
diff -up dhcp-4.0.0/common/print.c.ldap dhcp-4.0.0/common/print.c
--- dhcp-4.0.0/common/print.c.ldap 2007-10-01 04:47:35.000000000 -1000
+++ dhcp-4.0.0/common/print.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/common/print.c 2008-01-14 10:42:59.000000000 -1000
@@ -163,9 +163,9 @@ char *print_base64 (const unsigned char
}
@ -2398,7 +2398,7 @@ diff -up dhcp-4.0.0/common/print.c.ldap dhcp-4.0.0/common/print.c
char *s;
diff -up dhcp-4.0.0/common/conflex.c.ldap dhcp-4.0.0/common/conflex.c
--- dhcp-4.0.0/common/conflex.c.ldap 2007-10-31 09:13:33.000000000 -1000
+++ dhcp-4.0.0/common/conflex.c 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/common/conflex.c 2008-01-14 10:42:59.000000000 -1000
@@ -43,6 +43,7 @@ static enum dhcp_token read_string PROTO
static enum dhcp_token read_number PROTO ((int, struct parse *));
static enum dhcp_token read_num_or_name PROTO ((int, struct parse *));
@ -2461,7 +2461,7 @@ diff -up dhcp-4.0.0/common/conflex.c.ldap dhcp-4.0.0/common/conflex.c
+}
diff -up dhcp-4.0.0/includes/dhcpd.h.ldap dhcp-4.0.0/includes/dhcpd.h
--- dhcp-4.0.0/includes/dhcpd.h.ldap 2007-12-08 09:36:00.000000000 -1000
+++ dhcp-4.0.0/includes/dhcpd.h 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/includes/dhcpd.h 2008-01-14 10:42:59.000000000 -1000
@@ -101,6 +101,11 @@ typedef time_t TIME;
#include <isc-dhcp/result.h>
#include <omapip/omapip_p.h>
@ -2578,7 +2578,7 @@ diff -up dhcp-4.0.0/includes/dhcpd.h.ldap dhcp-4.0.0/includes/dhcpd.h
HASH_FUNCTIONS_DECL(ia_na, unsigned char *, struct ia_na, ia_na_hash_t);
diff -up dhcp-4.0.0/includes/site.h.ldap dhcp-4.0.0/includes/site.h
--- dhcp-4.0.0/includes/site.h.ldap 2006-07-31 12:19:51.000000000 -1000
+++ dhcp-4.0.0/includes/site.h 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/includes/site.h 2008-01-14 10:42:59.000000000 -1000
@@ -183,3 +183,13 @@
traces. */
@ -2595,7 +2595,7 @@ diff -up dhcp-4.0.0/includes/site.h.ldap dhcp-4.0.0/includes/site.h
+#define USE_SSL
diff -up /dev/null dhcp-4.0.0/includes/ldap_casa.h
--- /dev/null 2008-01-11 10:40:59.147013395 -1000
+++ dhcp-4.0.0/includes/ldap_casa.h 2008-01-13 12:54:54.000000000 -1000
+++ dhcp-4.0.0/includes/ldap_casa.h 2008-01-14 10:42:59.000000000 -1000
@@ -0,0 +1,83 @@
+/* ldap_casa.h
+

View File

@ -49,7 +49,6 @@ BuildRequires: automake
BuildRequires: groff
BuildRequires: libtool
BuildRequires: openldap-devel
BuildRequires: openssl-devel
# For /etc/openldap/schema (and slapd, if you're using that with dhcpd)
Requires: openldap-servers
@ -401,7 +400,7 @@ fi
%{_libdir}/libdhcp4client.so
%changelog
* Sun Jan 13 2008 David Cantrell <dcantrell@redhat.com> - 12:4.0.0-1
* Mon Jan 14 2008 David Cantrell <dcantrell@redhat.com> - 12:4.0.0-1
- Upgrade to ISC dhcp-4.0.0 (#426634)
- first ISC release to incorporate DHCPv6 protocol support
- source tree now uses GNU autoconf/automake