c7ea1a3b8d
commit id: d678c139719d5631194b50e49f16ca97162ecd0f) moved multipath bindings file from /var/lib/multipath to /etc/multipath Fixed 354961, 432520
174 lines
6.2 KiB
Diff
174 lines
6.2 KiB
Diff
Index: multipath-tools-090724/libmultipath/hwtable.c
|
|
===================================================================
|
|
--- multipath-tools-090724.orig/libmultipath/hwtable.c
|
|
+++ multipath-tools-090724/libmultipath/hwtable.c
|
|
@@ -589,7 +589,7 @@ static struct hwentry default_hw[] = {
|
|
.vendor = "IBM",
|
|
.product = "S/390 DASD ECKD",
|
|
.bl_product = "S/390.*",
|
|
- .getuid = "/sbin/dasdinfo -u -b %n",
|
|
+ .getuid = "/sbin/dasd_id /dev/%n",
|
|
.features = "1 queue_if_no_path",
|
|
.hwhandler = DEFAULT_HWHANDLER,
|
|
.selector = DEFAULT_SELECTOR,
|
|
Index: multipath-tools-090724/Makefile.inc
|
|
===================================================================
|
|
--- multipath-tools-090724.orig/Makefile.inc
|
|
+++ multipath-tools-090724/Makefile.inc
|
|
@@ -26,7 +26,7 @@ libudevdir = ${prefix}/lib/udev
|
|
multipathdir = $(TOPDIR)/libmultipath
|
|
mandir = $(prefix)/usr/share/man/man8
|
|
man5dir = $(prefix)/usr/share/man/man5
|
|
-rcdir = $(prefix)/etc/init.d
|
|
+rcdir = $(prefix)/etc/rc.d/init.d
|
|
syslibdir = $(prefix)/$(LIB)
|
|
libdir = $(prefix)/$(LIB)/multipath
|
|
|
|
Index: multipath-tools-090724/multipathd/Makefile
|
|
===================================================================
|
|
--- multipath-tools-090724.orig/multipathd/Makefile
|
|
+++ multipath-tools-090724/multipathd/Makefile
|
|
@@ -35,6 +35,7 @@ install:
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(rcdir)
|
|
+ $(INSTALL_PROGRAM) -m 755 multipathd.init.redhat $(DESTDIR)$(rcdir)/$(EXEC)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
|
|
|
|
Index: multipath-tools-090724/multipath/Makefile
|
|
===================================================================
|
|
--- multipath-tools-090724.orig/multipath/Makefile
|
|
+++ multipath-tools-090724/multipath/Makefile
|
|
@@ -27,6 +27,9 @@ install:
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(man5dir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).conf.5.gz $(DESTDIR)$(man5dir)
|
|
+ if [ ! -e $(DESTDIR)//etc/multipath.conf ]; then \
|
|
+ $(INSTALL_PROGRAM) -m 644 multipath.conf.redhat $(DESTDIR)/etc/multipath.conf; \
|
|
+ fi
|
|
|
|
uninstall:
|
|
rm $(DESTDIR)/etc/udev/rules.d/multipath.rules
|
|
Index: multipath-tools-090724/multipath/multipath.conf.redhat
|
|
===================================================================
|
|
--- /dev/null
|
|
+++ multipath-tools-090724/multipath/multipath.conf.redhat
|
|
@@ -0,0 +1,97 @@
|
|
+# This is a basic configuration file with some examples, for device mapper
|
|
+# multipath.
|
|
+# For a complete list of the default configuration values, see
|
|
+# /usr/share/doc/device-mapper-multipath-0.4.9/multipath.conf.defaults
|
|
+# For a list of configuration options with descriptions, see
|
|
+# /usr/share/doc/device-mapper-multipath-0.4.9/multipath.conf.annotated
|
|
+
|
|
+
|
|
+# Blacklist all devices by default. Remove this to enable multipathing
|
|
+# on the default devices.
|
|
+blacklist {
|
|
+ devnode "*"
|
|
+}
|
|
+
|
|
+## By default, devices with vendor = "IBM" and product = "S/390.*" are
|
|
+## blacklisted. To enable mulitpathing on these devies, uncomment the
|
|
+## following lines.
|
|
+#blacklist_exceptions {
|
|
+# device {
|
|
+# vendor "IBM"
|
|
+# product "S/390.*"
|
|
+# }
|
|
+#}
|
|
+
|
|
+## Use user friendly names, instead of using WWIDs as names.
|
|
+defaults {
|
|
+ user_friendly_names yes
|
|
+}
|
|
+##
|
|
+## Here is an example of how to configure some standard options.
|
|
+##
|
|
+#
|
|
+#defaults {
|
|
+# udev_dir /dev
|
|
+# polling_interval 10
|
|
+# selector "round-robin 0"
|
|
+# path_grouping_policy multibus
|
|
+# getuid_callout "/lib/udev/scsi_id --whitelisted --device=/dev/%n"
|
|
+# prio alua
|
|
+# path_checker readsector0
|
|
+# rr_min_io 100
|
|
+# max_fds 8192
|
|
+# rr_weight priorities
|
|
+# failback immediate
|
|
+# no_path_retry fail
|
|
+# user_friendly_names yes
|
|
+#}
|
|
+##
|
|
+## The wwid line in the following blacklist section is shown as an example
|
|
+## of how to blacklist devices by wwid. The 2 devnode lines are the
|
|
+## compiled in default blacklist. If you want to blacklist entire types
|
|
+## of devices, such as all scsi devices, you should use a devnode line.
|
|
+## However, if you want to blacklist specific devices, you should use
|
|
+## a wwid line. Since there is no guarantee that a specific device will
|
|
+## not change names on reboot (from /dev/sda to /dev/sdb for example)
|
|
+## devnode lines are not recommended for blacklisting specific devices.
|
|
+##
|
|
+#blacklist {
|
|
+# wwid 26353900f02796769
|
|
+# devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
|
|
+# devnode "^hd[a-z]"
|
|
+#}
|
|
+#multipaths {
|
|
+# multipath {
|
|
+# wwid 3600508b4000156d700012000000b0000
|
|
+# alias yellow
|
|
+# path_grouping_policy multibus
|
|
+# path_checker readsector0
|
|
+# path_selector "round-robin 0"
|
|
+# failback manual
|
|
+# rr_weight priorities
|
|
+# no_path_retry 5
|
|
+# }
|
|
+# multipath {
|
|
+# wwid 1DEC_____321816758474
|
|
+# alias red
|
|
+# }
|
|
+#}
|
|
+#devices {
|
|
+# device {
|
|
+# vendor "COMPAQ "
|
|
+# product "HSV110 (C)COMPAQ"
|
|
+# path_grouping_policy multibus
|
|
+# getuid_callout "/lib/udev/scsi_id --whitelisted --device=/dev/%n"
|
|
+# path_checker readsector0
|
|
+# path_selector "round-robin 0"
|
|
+# hardware_handler "0"
|
|
+# failback 15
|
|
+# rr_weight priorities
|
|
+# no_path_retry queue
|
|
+# }
|
|
+# device {
|
|
+# vendor "COMPAQ "
|
|
+# product "MSA1000 "
|
|
+# path_grouping_policy multibus
|
|
+# }
|
|
+#}
|
|
Index: multipath-tools-090724/kpartx/Makefile
|
|
===================================================================
|
|
--- multipath-tools-090724.orig/kpartx/Makefile
|
|
+++ multipath-tools-090724/kpartx/Makefile
|
|
@@ -20,10 +20,10 @@ $(EXEC): $(OBJS)
|
|
install: $(EXEC) $(EXEC).8
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(bindir)
|
|
$(INSTALL_PROGRAM) -m 755 $(EXEC) $(DESTDIR)$(bindir)
|
|
- $(INSTALL_PROGRAM) -d $(DESTDIR)$(libudevdir)
|
|
- $(INSTALL_PROGRAM) -m 755 kpartx_id $(DESTDIR)$(libudevdir)
|
|
- $(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
|
|
- $(INSTALL_PROGRAM) -m 644 kpartx.rules $(DESTDIR)/etc/udev/rules.d/
|
|
+# $(INSTALL_PROGRAM) -d $(DESTDIR)$(libudevdir)
|
|
+# $(INSTALL_PROGRAM) -m 755 kpartx_id $(DESTDIR)$(libudevdir)
|
|
+# $(INSTALL_PROGRAM) -d $(DESTDIR)/etc/udev/rules.d
|
|
+# $(INSTALL_PROGRAM) -m 644 kpartx.rules $(DESTDIR)/etc/udev/rules.d/
|
|
$(INSTALL_PROGRAM) -d $(DESTDIR)$(mandir)
|
|
$(INSTALL_PROGRAM) -m 644 $(EXEC).8.gz $(DESTDIR)$(mandir)
|
|
|