Make batched writes work
This commit is contained in:
parent
183915f906
commit
0cb72a1c70
24
dconf-multi-write.patch
Normal file
24
dconf-multi-write.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up dconf-0.3/gsettings/dconfdatabase.c.multi-write dconf-0.3/gsettings/dconfdatabase.c
|
||||||
|
--- dconf-0.3/gsettings/dconfdatabase.c.multi-write 2010-05-21 18:06:25.447432741 -0400
|
||||||
|
+++ dconf-0.3/gsettings/dconfdatabase.c 2010-05-21 18:06:39.905682921 -0400
|
||||||
|
@@ -364,7 +364,7 @@ dconf_database_write_tree (DConfDatabase
|
||||||
|
|
||||||
|
message =
|
||||||
|
g_dbus_message_new_method_call ("ca.desrt.dconf", "/",
|
||||||
|
- "ca.desrt.dconf.Writer", "Write");
|
||||||
|
+ "ca.desrt.dconf.Writer", "Merge");
|
||||||
|
|
||||||
|
g_variant_builder_init (&args, G_VARIANT_TYPE ("(sa(sav))"));
|
||||||
|
g_variant_builder_add (&args, "s", path);
|
||||||
|
diff -up dconf-0.3/service/service.c.multi-write dconf-0.3/service/service.c
|
||||||
|
--- dconf-0.3/service/service.c.multi-write 2010-05-19 10:42:03.000000000 -0400
|
||||||
|
+++ dconf-0.3/service/service.c 2010-05-21 17:52:04.416434906 -0400
|
||||||
|
@@ -204,7 +204,7 @@ method_call (GDBusConnection *conn
|
||||||
|
serial, key, none),
|
||||||
|
NULL);
|
||||||
|
}
|
||||||
|
- else if (strcmp (method_name, "Merge"))
|
||||||
|
+ else if (strcmp (method_name, "Merge") == 0)
|
||||||
|
{
|
||||||
|
GError *error = NULL;
|
||||||
|
const gchar *prefix;
|
10
dconf.spec
10
dconf.spec
@ -1,6 +1,6 @@
|
|||||||
Name: dconf
|
Name: dconf
|
||||||
Version: 0.3
|
Version: 0.3
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: A configuration system
|
Summary: A configuration system
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -11,8 +11,10 @@ Source0: http://download.gnome.org/sources/dconf/0.3/dconf-%{version}.tar
|
|||||||
BuildRequires: glib2-devel >= 2.25.6
|
BuildRequires: glib2-devel >= 2.25.6
|
||||||
Requires: dbus
|
Requires: dbus
|
||||||
|
|
||||||
# fix a case of needle/haystack confusion
|
# upstream fix for a case of needle/haystack confusion
|
||||||
Patch0: dconf-query.patch
|
Patch0: dconf-query.patch
|
||||||
|
# upstream fix for batched writes
|
||||||
|
Patch1: dconf-multi-write.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
dconf is a low-level configuration system. Its main purpose is to provide a
|
dconf is a low-level configuration system. Its main purpose is to provide a
|
||||||
@ -21,6 +23,7 @@ backend to the GSettings API in GLib.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .query
|
%patch0 -p1 -b .query
|
||||||
|
%patch1 -p1 -b .multi-write
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -51,6 +54,9 @@ gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 21 2010 Matthias Clasen <mclasen@redhat.com> 0.3-3
|
||||||
|
- Make batched writes (e.g. with delayed settings) work
|
||||||
|
|
||||||
* Thu May 20 2010 Matthias Clasen <mclasen@redhat.com> 0.3-2
|
* Thu May 20 2010 Matthias Clasen <mclasen@redhat.com> 0.3-2
|
||||||
- Make the registration of the backend work
|
- Make the registration of the backend work
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user