initial import
This commit is contained in:
parent
764e3a1a5b
commit
183915f906
@ -0,0 +1 @@
|
||||
dconf-0.3.tar.bz2
|
10
dconf-query.patch
Normal file
10
dconf-query.patch
Normal file
@ -0,0 +1,10 @@
|
||||
diff -up dconf-0.3/gsettings/dconfsettingsbackend.c.query dconf-0.3/gsettings/dconfsettingsbackend.c
|
||||
--- dconf-0.3/gsettings/dconfsettingsbackend.c.query 2010-05-20 08:50:59.598535660 -0400
|
||||
+++ dconf-0.3/gsettings/dconfsettingsbackend.c 2010-05-20 08:51:56.331309861 -0400
|
||||
@@ -164,5 +164,5 @@ g_io_module_unload (GIOModule *module)
|
||||
gchar **
|
||||
g_io_module_query (void)
|
||||
{
|
||||
- return g_strsplit (",", G_SETTINGS_BACKEND_EXTENSION_POINT_NAME, 0);
|
||||
+ return g_strsplit (G_SETTINGS_BACKEND_EXTENSION_POINT_NAME, ",", 0);
|
||||
}
|
58
dconf.spec
Normal file
58
dconf.spec
Normal file
@ -0,0 +1,58 @@
|
||||
Name: dconf
|
||||
Version: 0.3
|
||||
Release: 2%{?dist}
|
||||
Summary: A configuration system
|
||||
|
||||
Group: System Environment/Base
|
||||
License: LGPLv2+
|
||||
URL: http://live.gnome.org/dconf
|
||||
Source0: http://download.gnome.org/sources/dconf/0.3/dconf-%{version}.tar.bz2
|
||||
|
||||
BuildRequires: glib2-devel >= 2.25.6
|
||||
Requires: dbus
|
||||
|
||||
# fix a case of needle/haystack confusion
|
||||
Patch0: dconf-query.patch
|
||||
|
||||
%description
|
||||
dconf is a low-level configuration system. Its main purpose is to provide a
|
||||
backend to the GSettings API in GLib.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .query
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
rm $RPM_BUILD_ROOT%{_libdir}/gio/modules/libdconfsettings.la
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
|
||||
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_libdir}/gio/modules/libdconfsettings.so
|
||||
%{_libexecdir}/dconf-service
|
||||
%{_datadir}/dbus-1/services/ca.desrt.dconf.service
|
||||
%{_datadir}/dbus-1/system-services/ca.desrt.dconf.service
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 20 2010 Matthias Clasen <mclasen@redhat.com> 0.3-2
|
||||
- Make the registration of the backend work
|
||||
|
||||
* Wed May 19 2010 Matthias Clasen <mclasen@redhat.com> 0.3-1
|
||||
- Initial packaging
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
||||
dconf-0_3-2_fc14:HEAD:dconf-0.3-2.fc14.src.rpm:1274388763
|
Loading…
Reference in New Issue
Block a user