parent
57b2bbb8b3
commit
c222874d03
@ -1,2 +1 @@
|
|||||||
cyrus-sasl-2.1.22-nodlcompatorsrp.tar.gz
|
cyrus-sasl-2.1.22-nodlcompatorsrp.tar.gz
|
||||||
db-4.7.25.tar.gz
|
|
||||||
|
@ -1,65 +0,0 @@
|
|||||||
Use TRY_LINK instead of CHECK_LIB and try linking with plain old -ldb to
|
|
||||||
properly pick up uniq'ified single-use DB.
|
|
||||||
|
|
||||||
diff -up cyrus-sasl-2.1.22/cmulocal/berkdb.m4.db_bundle cyrus-sasl-2.1.22/cmulocal/berkdb.m4
|
|
||||||
--- cyrus-sasl-2.1.22/cmulocal/berkdb.m4.db_bundle 2005-04-26 21:14:07.000000000 +0200
|
|
||||||
+++ cyrus-sasl-2.1.22/cmulocal/berkdb.m4 2008-08-29 11:58:37.000000000 +0200
|
|
||||||
@@ -31,41 +31,22 @@ AC_DEFUN([CMU_DB_INC_WHERE], [
|
|
||||||
# Test for lib files
|
|
||||||
#
|
|
||||||
|
|
||||||
-AC_DEFUN([CMU_DB3_LIB_WHERE1], [
|
|
||||||
+AC_DEFUN([CMU_DB_LIB_WHERE1], [
|
|
||||||
AC_REQUIRE([CMU_AFS])
|
|
||||||
AC_REQUIRE([CMU_KRB4])
|
|
||||||
saved_LIBS=$LIBS
|
|
||||||
- LIBS="$saved_LIBS -L$1 -ldb-3"
|
|
||||||
+LIBS="$saved_LIBS -L$1 -ldb"
|
|
||||||
AC_TRY_LINK([#include <db.h>],
|
|
||||||
[db_env_create(NULL, 0);],
|
|
||||||
-[ac_cv_found_db_3_lib=yes],
|
|
||||||
-ac_cv_found_db_3_lib=no)
|
|
||||||
-LIBS=$saved_LIBS
|
|
||||||
-])
|
|
||||||
-AC_DEFUN([CMU_DB4_LIB_WHERE1], [
|
|
||||||
-AC_REQUIRE([CMU_AFS])
|
|
||||||
-AC_REQUIRE([CMU_KRB4])
|
|
||||||
-saved_LIBS=$LIBS
|
|
||||||
-LIBS="$saved_LIBS -L$1 -ldb-4"
|
|
||||||
-AC_TRY_LINK([#include <db.h>],
|
|
||||||
-[db_env_create(NULL, 0);],
|
|
||||||
-[ac_cv_found_db_4_lib=yes],
|
|
||||||
-ac_cv_found_db_4_lib=no)
|
|
||||||
+[ac_cv_found_db_lib=yes],
|
|
||||||
+ac_cv_found_db_lib=no)
|
|
||||||
LIBS=$saved_LIBS
|
|
||||||
])
|
|
||||||
|
|
||||||
AC_DEFUN([CMU_DB_LIB_WHERE], [
|
|
||||||
for i in $1; do
|
|
||||||
AC_MSG_CHECKING(for db libraries in $i)
|
|
||||||
-if test "$enable_db4" = "yes"; then
|
|
||||||
- CMU_DB4_LIB_WHERE1($i)
|
|
||||||
- CMU_TEST_LIBPATH($i, [db-4])
|
|
||||||
- ac_cv_found_db_lib=$ac_cv_found_db_4_lib
|
|
||||||
-else
|
|
||||||
- CMU_DB3_LIB_WHERE1($i)
|
|
||||||
- CMU_TEST_LIBPATH($i, [db-3])
|
|
||||||
- ac_cv_found_db_lib=$ac_cv_found_db_3_lib
|
|
||||||
-fi
|
|
||||||
+ CMU_DB_LIB_WHERE1($i)
|
|
||||||
if test "$ac_cv_found_db_lib" = "yes" ; then
|
|
||||||
ac_cv_db_where_lib=$i
|
|
||||||
AC_MSG_RESULT(found)
|
|
||||||
diff -up cyrus-sasl-2.1.22/utils/Makefile.am.db_bundle cyrus-sasl-2.1.22/utils/Makefile.am
|
|
||||||
--- cyrus-sasl-2.1.22/utils/Makefile.am.db_bundle 2006-05-18 20:34:26.000000000 +0200
|
|
||||||
+++ cyrus-sasl-2.1.22/utils/Makefile.am 2008-08-29 11:58:37.000000000 +0200
|
|
||||||
@@ -58,7 +58,7 @@ endif
|
|
||||||
|
|
||||||
saslpasswd2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
|
||||||
saslpasswd2_SOURCES = saslpasswd.c
|
|
||||||
-sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
|
||||||
+sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs) @SASL_DB_LIB@
|
|
||||||
sasldblistusers2_SOURCES = sasldblistusers.c
|
|
||||||
dbconverter_2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
|
||||||
pluginviewer_LDADD = $(all_sasl_libs)
|
|
84
cyrus-sasl-2.1.22-warnings.patch
Normal file
84
cyrus-sasl-2.1.22-warnings.patch
Normal file
@ -0,0 +1,84 @@
|
|||||||
|
diff -up cyrus-sasl-2.1.22/lib/auxprop.c.warnings cyrus-sasl-2.1.22/lib/auxprop.c
|
||||||
|
--- cyrus-sasl-2.1.22/lib/auxprop.c.warnings 2006-03-14 15:23:55.000000000 +0100
|
||||||
|
+++ cyrus-sasl-2.1.22/lib/auxprop.c 2008-09-10 14:31:01.000000000 +0200
|
||||||
|
@@ -46,6 +46,7 @@
|
||||||
|
#include <sasl.h>
|
||||||
|
#include <prop.h>
|
||||||
|
#include <ctype.h>
|
||||||
|
+#include <stdio.h>
|
||||||
|
#include "saslint.h"
|
||||||
|
|
||||||
|
struct proppool
|
||||||
|
diff -up cyrus-sasl-2.1.22/lib/server.c.warnings cyrus-sasl-2.1.22/lib/server.c
|
||||||
|
--- cyrus-sasl-2.1.22/lib/server.c.warnings 2006-05-17 18:46:13.000000000 +0200
|
||||||
|
+++ cyrus-sasl-2.1.22/lib/server.c 2008-09-10 14:39:02.000000000 +0200
|
||||||
|
@@ -517,7 +517,7 @@ static int load_config(const sasl_callba
|
||||||
|
goto done;
|
||||||
|
}
|
||||||
|
|
||||||
|
- snprintf(config_filename, len, "%.*s%c%s.conf", path_len, path_to_config,
|
||||||
|
+ snprintf(config_filename, len, "%.*s%c%s.conf", (int)path_len, path_to_config,
|
||||||
|
HIER_DELIMITER, global_callbacks.appname);
|
||||||
|
|
||||||
|
/* Ask the application if it's safe to use this file */
|
||||||
|
diff -up cyrus-sasl-2.1.22/plugins/gssapi.c.warnings cyrus-sasl-2.1.22/plugins/gssapi.c
|
||||||
|
--- cyrus-sasl-2.1.22/plugins/gssapi.c.warnings 2004-07-21 16:39:06.000000000 +0200
|
||||||
|
+++ cyrus-sasl-2.1.22/plugins/gssapi.c 2008-09-10 14:20:59.000000000 +0200
|
||||||
|
@@ -190,7 +190,8 @@ sasl_gss_seterror_(const sasl_utils_t *u
|
||||||
|
OM_uint32 msg_ctx;
|
||||||
|
int ret;
|
||||||
|
char *out = NULL;
|
||||||
|
- size_t len, curlen = 0;
|
||||||
|
+ size_t len;
|
||||||
|
+ unsigned curlen = 0;
|
||||||
|
const char prefix[] = "GSSAPI Error: ";
|
||||||
|
|
||||||
|
len = sizeof(prefix);
|
||||||
|
diff -up cyrus-sasl-2.1.22/plugins/ldapdb.c.warnings cyrus-sasl-2.1.22/plugins/ldapdb.c
|
||||||
|
--- cyrus-sasl-2.1.22/plugins/ldapdb.c.warnings 2005-02-19 03:26:31.000000000 +0100
|
||||||
|
+++ cyrus-sasl-2.1.22/plugins/ldapdb.c 2008-09-10 14:52:33.000000000 +0200
|
||||||
|
@@ -21,6 +21,7 @@
|
||||||
|
|
||||||
|
#include "plugin_common.h"
|
||||||
|
|
||||||
|
+#define LDAP_DEPRECATED 1
|
||||||
|
#include <ldap.h>
|
||||||
|
|
||||||
|
static char ldapdb[] = "ldapdb";
|
||||||
|
diff -up cyrus-sasl-2.1.22/saslauthd/lak.c.warnings cyrus-sasl-2.1.22/saslauthd/lak.c
|
||||||
|
--- cyrus-sasl-2.1.22/saslauthd/lak.c.warnings 2005-05-15 07:49:51.000000000 +0200
|
||||||
|
+++ cyrus-sasl-2.1.22/saslauthd/lak.c 2008-09-10 14:52:51.000000000 +0200
|
||||||
|
@@ -55,6 +55,7 @@
|
||||||
|
#include <openssl/des.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#define LDAP_DEPRECATED 1
|
||||||
|
#include <ldap.h>
|
||||||
|
#include <lber.h>
|
||||||
|
#include <sasl.h>
|
||||||
|
diff -up cyrus-sasl-2.1.22/saslauthd/auth_httpform.c.warnings cyrus-sasl-2.1.22/saslauthd/auth_httpform.c
|
||||||
|
--- cyrus-sasl-2.1.22/saslauthd/auth_httpform.c.warnings 2006-04-19 21:51:13.000000000 +0200
|
||||||
|
+++ cyrus-sasl-2.1.22/saslauthd/auth_httpform.c 2008-09-10 14:45:57.000000000 +0200
|
||||||
|
@@ -552,7 +552,7 @@ auth_httpform (
|
||||||
|
"Content-Type: application/x-www-form-urlencoded" CRLF
|
||||||
|
"Content-Length: %d" TWO_CRLF
|
||||||
|
"%s",
|
||||||
|
- r_uri, r_host, r_port, strlen(escreq), escreq);
|
||||||
|
+ r_uri, r_host, r_port, (int)strlen(escreq), escreq);
|
||||||
|
|
||||||
|
if (flags & VERBOSE) {
|
||||||
|
syslog(LOG_DEBUG, "auth_httpform: sending %s %s %s",
|
||||||
|
diff -up cyrus-sasl-2.1.22/saslauthd/auth_shadow.c.warnings cyrus-sasl-2.1.22/saslauthd/auth_shadow.c
|
||||||
|
--- cyrus-sasl-2.1.22/saslauthd/auth_shadow.c.warnings 2006-04-19 21:36:36.000000000 +0200
|
||||||
|
+++ cyrus-sasl-2.1.22/saslauthd/auth_shadow.c 2008-09-10 14:47:47.000000000 +0200
|
||||||
|
@@ -63,6 +63,10 @@
|
||||||
|
# include <shadow.h>
|
||||||
|
# endif /* ! HAVE_GETUSERPW */
|
||||||
|
|
||||||
|
+# ifdef HAVE_CRYPT_H
|
||||||
|
+# include <crypt.h>
|
||||||
|
+# endif
|
||||||
|
+
|
||||||
|
# include "auth_shadow.h"
|
||||||
|
# include "globals.h"
|
||||||
|
/* END PUBLIC DEPENDENCIES */
|
@ -18,7 +18,6 @@ Source9: saslauthd.sysconfig
|
|||||||
Source10: make-no-dlcompatorsrp-tarball.sh
|
Source10: make-no-dlcompatorsrp-tarball.sh
|
||||||
URL: http://asg.web.cmu.edu/sasl/sasl-library.html
|
URL: http://asg.web.cmu.edu/sasl/sasl-library.html
|
||||||
Requires: %{name}-lib = %{version}-%{release}
|
Requires: %{name}-lib = %{version}-%{release}
|
||||||
Patch10: cyrus-sasl-2.1.22-db_bundle.patch
|
|
||||||
Patch11: cyrus-sasl-2.1.18-no_rpath.patch
|
Patch11: cyrus-sasl-2.1.18-no_rpath.patch
|
||||||
Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
|
Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
|
||||||
Patch24: cyrus-sasl-2.1.21-sizes.patch
|
Patch24: cyrus-sasl-2.1.21-sizes.patch
|
||||||
|
@ -2,6 +2,7 @@
|
|||||||
#include <stdio.h>
|
#include <stdio.h>
|
||||||
#include <stdlib.h>
|
#include <stdlib.h>
|
||||||
#include <string.h>
|
#include <string.h>
|
||||||
|
#include <unistd.h>
|
||||||
|
|
||||||
static int
|
static int
|
||||||
my_getopt(void *context, const char *plugin_name,
|
my_getopt(void *context, const char *plugin_name,
|
||||||
|
Loading…
Reference in New Issue
Block a user