cyrus-sasl/cyrus-sasl-2.1.22-db_bundle...

66 lines
2.2 KiB
Diff

Use TRY_LINK instead of CHECK_LIB and try linking with plain old -ldb to
properly pick up uniq'ified single-use DB.
diff -up cyrus-sasl-2.1.22/cmulocal/berkdb.m4.db_bundle cyrus-sasl-2.1.22/cmulocal/berkdb.m4
--- cyrus-sasl-2.1.22/cmulocal/berkdb.m4.db_bundle 2005-04-26 21:14:07.000000000 +0200
+++ cyrus-sasl-2.1.22/cmulocal/berkdb.m4 2008-08-29 11:58:37.000000000 +0200
@@ -31,41 +31,22 @@ AC_DEFUN([CMU_DB_INC_WHERE], [
# Test for lib files
#
-AC_DEFUN([CMU_DB3_LIB_WHERE1], [
+AC_DEFUN([CMU_DB_LIB_WHERE1], [
AC_REQUIRE([CMU_AFS])
AC_REQUIRE([CMU_KRB4])
saved_LIBS=$LIBS
- LIBS="$saved_LIBS -L$1 -ldb-3"
+LIBS="$saved_LIBS -L$1 -ldb"
AC_TRY_LINK([#include <db.h>],
[db_env_create(NULL, 0);],
-[ac_cv_found_db_3_lib=yes],
-ac_cv_found_db_3_lib=no)
-LIBS=$saved_LIBS
-])
-AC_DEFUN([CMU_DB4_LIB_WHERE1], [
-AC_REQUIRE([CMU_AFS])
-AC_REQUIRE([CMU_KRB4])
-saved_LIBS=$LIBS
-LIBS="$saved_LIBS -L$1 -ldb-4"
-AC_TRY_LINK([#include <db.h>],
-[db_env_create(NULL, 0);],
-[ac_cv_found_db_4_lib=yes],
-ac_cv_found_db_4_lib=no)
+[ac_cv_found_db_lib=yes],
+ac_cv_found_db_lib=no)
LIBS=$saved_LIBS
])
AC_DEFUN([CMU_DB_LIB_WHERE], [
for i in $1; do
AC_MSG_CHECKING(for db libraries in $i)
-if test "$enable_db4" = "yes"; then
- CMU_DB4_LIB_WHERE1($i)
- CMU_TEST_LIBPATH($i, [db-4])
- ac_cv_found_db_lib=$ac_cv_found_db_4_lib
-else
- CMU_DB3_LIB_WHERE1($i)
- CMU_TEST_LIBPATH($i, [db-3])
- ac_cv_found_db_lib=$ac_cv_found_db_3_lib
-fi
+ CMU_DB_LIB_WHERE1($i)
if test "$ac_cv_found_db_lib" = "yes" ; then
ac_cv_db_where_lib=$i
AC_MSG_RESULT(found)
diff -up cyrus-sasl-2.1.22/utils/Makefile.am.db_bundle cyrus-sasl-2.1.22/utils/Makefile.am
--- cyrus-sasl-2.1.22/utils/Makefile.am.db_bundle 2006-05-18 20:34:26.000000000 +0200
+++ cyrus-sasl-2.1.22/utils/Makefile.am 2008-08-29 11:58:37.000000000 +0200
@@ -58,7 +58,7 @@ endif
saslpasswd2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
saslpasswd2_SOURCES = saslpasswd.c
-sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
+sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs) @SASL_DB_LIB@
sasldblistusers2_SOURCES = sasldblistusers.c
dbconverter_2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
pluginviewer_LDADD = $(all_sasl_libs)