- dropped curl-7.16.0-privlibs.patch no longer useful
- a new patch forcing -lrt when linking the curl tool and test-cases
This commit is contained in:
parent
6d0277e653
commit
149dc257a1
@ -1,12 +0,0 @@
|
|||||||
diff --git a/libcurl.pc.in b/libcurl.pc.in
|
|
||||||
index b765994..d843688 100644
|
|
||||||
--- a/libcurl.pc.in
|
|
||||||
+++ b/libcurl.pc.in
|
|
||||||
@@ -35,6 +35,6 @@ Name: libcurl
|
|
||||||
URL: http://curl.haxx.se/
|
|
||||||
Description: Library to transfer files with ftp, http, etc.
|
|
||||||
Version: @VERSION@
|
|
||||||
-Libs: -L${libdir} -lcurl @LIBS@
|
|
||||||
+Libs: -L${libdir} -lcurl
|
|
||||||
Libs.private: @LIBCURL_LIBS@ @LIBS@
|
|
||||||
Cflags: -I${includedir}
|
|
26
curl-7.20.0-lrt.patch
Normal file
26
curl-7.20.0-lrt.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
|
index e993bc3..af9b315 100644
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -47,7 +47,7 @@ bin_PROGRAMS = curl
|
||||||
|
|
||||||
|
include Makefile.inc
|
||||||
|
|
||||||
|
-curl_LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@
|
||||||
|
+curl_LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@ -lrt
|
||||||
|
curl_DEPENDENCIES = $(top_builddir)/lib/libcurl.la
|
||||||
|
BUILT_SOURCES = hugehelp.c
|
||||||
|
CLEANFILES = hugehelp.c
|
||||||
|
diff --git a/tests/libtest/Makefile.am b/tests/libtest/Makefile.am
|
||||||
|
index 1941cd8..8491b94 100644
|
||||||
|
--- a/tests/libtest/Makefile.am
|
||||||
|
+++ b/tests/libtest/Makefile.am
|
||||||
|
@@ -55,7 +55,7 @@ EXTRA_DIST = test75.pl test307.pl test610.pl test613.pl test1013.pl \
|
||||||
|
test1022.pl Makefile.inc
|
||||||
|
|
||||||
|
# Dependencies (may need to be overriden)
|
||||||
|
-LDADD = $(top_builddir)/lib/libcurl.la
|
||||||
|
+LDADD = $(top_builddir)/lib/libcurl.la -lrt
|
||||||
|
DEPENDENCIES = $(top_builddir)/lib/libcurl.la
|
||||||
|
|
||||||
|
# Makefile.inc provides the source defines (TESTUTIL, SUPPORTFILES, noinst_PROGRAMS, lib*_SOURCES, and lib*_CFLAGS)
|
14
curl.spec
14
curl.spec
@ -10,14 +10,15 @@ Source2: curlbuild.h
|
|||||||
# patching making libcurl multilib ready (by not installing static libraries)
|
# patching making libcurl multilib ready (by not installing static libraries)
|
||||||
Patch101: curl-7.15.3-multilib.patch
|
Patch101: curl-7.15.3-multilib.patch
|
||||||
|
|
||||||
# tweak of libcurl.pc
|
# force -lrt when linking the curl tool and test-cases
|
||||||
Patch102: curl-7.16.0-privlibs.patch
|
Patch102: curl-7.20.0-lrt.patch
|
||||||
|
|
||||||
# prevent configure script from discarding -g in CFLAGS (#496778)
|
# prevent configure script from discarding -g in CFLAGS (#496778)
|
||||||
Patch103: curl-7.19.4-debug.patch
|
Patch103: curl-7.19.4-debug.patch
|
||||||
|
|
||||||
# suppress occasional failure of curl test-suite on s390; caused more likely
|
# suppress occasional failure of curl test-suite on s390; caused more likely
|
||||||
# by the test-suite infrastructure than (lib)curl itself
|
# by the test-suite infrastructure than (lib)curl itself
|
||||||
|
# http://curl.haxx.se/mail/lib-2009-12/0031.html
|
||||||
Patch104: curl-7.19.7-s390-sleep.patch
|
Patch104: curl-7.19.7-s390-sleep.patch
|
||||||
|
|
||||||
# use localhost6 instead of ip6-localhost in the curl test-suite
|
# use localhost6 instead of ip6-localhost in the curl test-suite
|
||||||
@ -31,7 +32,7 @@ Patch106: curl-7.19.7-ares-ipv6.patch
|
|||||||
Provides: webclient
|
Provides: webclient
|
||||||
URL: http://curl.haxx.se/
|
URL: http://curl.haxx.se/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: autoconf
|
BuildRequires: automake
|
||||||
BuildRequires: c-ares-devel
|
BuildRequires: c-ares-devel
|
||||||
BuildRequires: groff
|
BuildRequires: groff
|
||||||
BuildRequires: krb5-devel
|
BuildRequires: krb5-devel
|
||||||
@ -96,8 +97,6 @@ use cURL's capabilities internally.
|
|||||||
%patch101 -p1
|
%patch101 -p1
|
||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
%patch103 -p1
|
%patch103 -p1
|
||||||
|
|
||||||
# http://curl.haxx.se/mail/lib-2009-12/0031.html
|
|
||||||
%patch104 -p1
|
%patch104 -p1
|
||||||
|
|
||||||
# temporarily disabled (clash with patch #106)
|
# temporarily disabled (clash with patch #106)
|
||||||
@ -105,7 +104,7 @@ use cURL's capabilities internally.
|
|||||||
|
|
||||||
%patch106 -p1
|
%patch106 -p1
|
||||||
|
|
||||||
autoconf
|
autoreconf
|
||||||
|
|
||||||
# replace hard wired port numbers in the test suite
|
# replace hard wired port numbers in the test suite
|
||||||
sed -i s/899\\\([0-9]\\\)/%{?__isa_bits}9\\1/ tests/data/test*
|
sed -i s/899\\\([0-9]\\\)/%{?__isa_bits}9\\1/ tests/data/test*
|
||||||
@ -198,6 +197,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%changelog
|
%changelog
|
||||||
* Thu Feb 11 2010 Kamil Dudka <kdudka@redhat.com> 7.20.0-1
|
* Thu Feb 11 2010 Kamil Dudka <kdudka@redhat.com> 7.20.0-1
|
||||||
- new upstream release - added support for IMAP(S), POP3(S), SMTP(S) and RTSP
|
- new upstream release - added support for IMAP(S), POP3(S), SMTP(S) and RTSP
|
||||||
|
- dropped patches applied upstream
|
||||||
|
- dropped curl-7.16.0-privlibs.patch no longer useful
|
||||||
|
- a new patch forcing -lrt when linking the curl tool and test-cases
|
||||||
|
|
||||||
* Fri Jan 29 2010 Kamil Dudka <kdudka@redhat.com> 7.19.7-11
|
* Fri Jan 29 2010 Kamil Dudka <kdudka@redhat.com> 7.19.7-11
|
||||||
- upstream patch adding a new option -J/--remote-header-name
|
- upstream patch adding a new option -J/--remote-header-name
|
||||||
|
Loading…
Reference in New Issue
Block a user