149dc257a1
- a new patch forcing -lrt when linking the curl tool and test-cases
27 lines
980 B
Diff
27 lines
980 B
Diff
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index e993bc3..af9b315 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -47,7 +47,7 @@ bin_PROGRAMS = curl
|
|
|
|
include Makefile.inc
|
|
|
|
-curl_LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@
|
|
+curl_LDADD = $(top_builddir)/lib/libcurl.la @CURL_LIBS@ -lrt
|
|
curl_DEPENDENCIES = $(top_builddir)/lib/libcurl.la
|
|
BUILT_SOURCES = hugehelp.c
|
|
CLEANFILES = hugehelp.c
|
|
diff --git a/tests/libtest/Makefile.am b/tests/libtest/Makefile.am
|
|
index 1941cd8..8491b94 100644
|
|
--- a/tests/libtest/Makefile.am
|
|
+++ b/tests/libtest/Makefile.am
|
|
@@ -55,7 +55,7 @@ EXTRA_DIST = test75.pl test307.pl test610.pl test613.pl test1013.pl \
|
|
test1022.pl Makefile.inc
|
|
|
|
# Dependencies (may need to be overriden)
|
|
-LDADD = $(top_builddir)/lib/libcurl.la
|
|
+LDADD = $(top_builddir)/lib/libcurl.la -lrt
|
|
DEPENDENCIES = $(top_builddir)/lib/libcurl.la
|
|
|
|
# Makefile.inc provides the source defines (TESTUTIL, SUPPORTFILES, noinst_PROGRAMS, lib*_SOURCES, and lib*_CFLAGS)
|