Merge branch 'f19' into f20
This commit is contained in:
commit
1e8ec83658
17
cups-final-content-type.patch
Normal file
17
cups-final-content-type.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -up cups-1.6.4/scheduler/job.c.final-content-type cups-1.6.4/scheduler/job.c
|
||||
--- cups-1.6.4/scheduler/job.c.final-content-type 2013-09-27 16:58:13.934775402 +0100
|
||||
+++ cups-1.6.4/scheduler/job.c 2013-09-27 17:00:57.716549576 +0100
|
||||
@@ -692,12 +692,7 @@ cupsdContinueJob(cupsd_job_t *job) /* I
|
||||
|
||||
if (!job->printer->remote)
|
||||
{
|
||||
- for (filter = (mime_filter_t *)cupsArrayLast(filters);
|
||||
- filter && filter->dst;
|
||||
- filter = (mime_filter_t *)cupsArrayPrev(filters))
|
||||
- if (strcmp(filter->dst->super, "printer") ||
|
||||
- strcmp(filter->dst->type, job->printer->name))
|
||||
- break;
|
||||
+ filter = (mime_filter_t *)cupsArrayLast(filters);
|
||||
|
||||
if (filter && filter->dst)
|
||||
{
|
16
cups.spec
16
cups.spec
@ -14,7 +14,7 @@ Summary: CUPS printing system
|
||||
Name: cups
|
||||
Epoch: 1
|
||||
Version: 1.7
|
||||
Release: 0.25.%{prever}%{?dist}
|
||||
Release: 0.26.%{prever}%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Daemons
|
||||
Url: http://www.cups.org/
|
||||
@ -71,6 +71,8 @@ Patch38: cups-build.patch
|
||||
Patch39: cups-ipp-multifile.patch
|
||||
Patch40: cups-full-relro.patch
|
||||
Patch41: cups-web-devices-timeout.patch
|
||||
Patch42: cups-synconclose.patch
|
||||
Patch43: cups-final-content-type.patch
|
||||
|
||||
Patch100: cups-lspp.patch
|
||||
|
||||
@ -265,6 +267,11 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
||||
%patch40 -p1 -b .full-relro
|
||||
# Increase web interface get-devices timeout to 10s (bug #996664).
|
||||
%patch41 -p1 -b .web-devices-timeout
|
||||
# Add SyncOnClose option (bug #984883).
|
||||
%patch42 -p0 -b .synconclose
|
||||
# Reverted upstream change to FINAL_CONTENT_TYPE in order to fix
|
||||
# printing to remote CUPS servers (bug #1010580).
|
||||
%patch43 -p1 -b .final-content-type
|
||||
|
||||
%if %lspp
|
||||
# LSPP support.
|
||||
@ -639,6 +646,13 @@ rm -f %{cups_serverbin}/backend/smb
|
||||
%{_mandir}/man5/ipptoolfile.5.gz
|
||||
|
||||
%changelog
|
||||
* Fri Sep 27 2013 Tim Waugh <twaugh@redhat.com> - 1:1.7-0.26.rc1
|
||||
- Reverted upstream change to FINAL_CONTENT_TYPE in order to fix
|
||||
printing to remote CUPS servers (bug #1010580).
|
||||
|
||||
* Wed Aug 21 2013 Jaromír Končický <jkoncick@redhat.com>
|
||||
- Add SyncOnClose option (bug #984883).
|
||||
|
||||
* Fri Aug 16 2013 Tim Waugh <twaugh@redhat.com> - 1:1.7-0.25.rc1
|
||||
- Increase web interface get-devices timeout to 10s (bug #996664).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user