Reverted upstream change to FINAL_CONTENT_TYPE in order to fix printing to remote CUPS servers (bug #1010580).
Resolves: rhbz#1010580
This commit is contained in:
parent
7a2317d5d7
commit
77e3fed684
17
cups-final-content-type.patch
Normal file
17
cups-final-content-type.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -up cups-1.6.4/scheduler/job.c.final-content-type cups-1.6.4/scheduler/job.c
|
||||
--- cups-1.6.4/scheduler/job.c.final-content-type 2013-09-27 16:58:13.934775402 +0100
|
||||
+++ cups-1.6.4/scheduler/job.c 2013-09-27 17:00:57.716549576 +0100
|
||||
@@ -692,12 +692,7 @@ cupsdContinueJob(cupsd_job_t *job) /* I
|
||||
|
||||
if (!job->printer->remote)
|
||||
{
|
||||
- for (filter = (mime_filter_t *)cupsArrayLast(filters);
|
||||
- filter && filter->dst;
|
||||
- filter = (mime_filter_t *)cupsArrayPrev(filters))
|
||||
- if (strcmp(filter->dst->super, "printer") ||
|
||||
- strcmp(filter->dst->type, job->printer->name))
|
||||
- break;
|
||||
+ filter = (mime_filter_t *)cupsArrayLast(filters);
|
||||
|
||||
if (filter && filter->dst)
|
||||
{
|
10
cups.spec
10
cups.spec
@ -11,7 +11,7 @@ Summary: CUPS printing system
|
||||
Name: cups
|
||||
Epoch: 1
|
||||
Version: 1.6.4
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Daemons
|
||||
Url: http://www.cups.org/
|
||||
@ -66,6 +66,7 @@ Patch35: cups-gz-crc.patch
|
||||
Patch36: cups-ipp-multifile.patch
|
||||
Patch37: cups-full-relro.patch
|
||||
Patch38: cups-web-devices-timeout.patch
|
||||
Patch39: cups-final-content-type.patch
|
||||
|
||||
Patch100: cups-lspp.patch
|
||||
|
||||
@ -257,6 +258,9 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
||||
%patch37 -p1 -b .full-relro
|
||||
# Increase web interface get-devices timeout to 10s (bug #996664).
|
||||
%patch38 -p1 -b .web-devices-timeout
|
||||
# Reverted upstream change to FINAL_CONTENT_TYPE in order to fix
|
||||
# printing to remote CUPS servers (bug #1010580).
|
||||
%patch39 -p1 -b .final-content-type
|
||||
|
||||
%if %lspp
|
||||
# LSPP support.
|
||||
@ -645,6 +649,10 @@ rm -f %{cups_serverbin}/backend/smb
|
||||
%{_mandir}/man5/ipptoolfile.5.gz
|
||||
|
||||
%changelog
|
||||
* Fri Sep 27 2013 Tim Waugh <twaugh@redhat.com> - 1:1.6.4-2
|
||||
- Reverted upstream change to FINAL_CONTENT_TYPE in order to fix
|
||||
printing to remote CUPS servers (bug #1010580).
|
||||
|
||||
* Wed Sep 25 2013 Tim Waugh <twaugh@redhat.com> - 1:1.6.4-1
|
||||
- 1.6.4.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user