import crash-7.2.6-2.el8
This commit is contained in:
commit
f0b6f71b28
1
.crash.metadata
Normal file
1
.crash.metadata
Normal file
@ -0,0 +1 @@
|
||||
c972d50634ae15fac036bd1f8f9f84d87a54acba SOURCES/crash-7.2.6.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/crash-7.2.6.tar.gz
|
28
SOURCES/github_b1a6e13a_p_regression.patch
Normal file
28
SOURCES/github_b1a6e13a_p_regression.patch
Normal file
@ -0,0 +1,28 @@
|
||||
commit b1a6e13a93661dfae7df15fe32862bddf4026c80
|
||||
Author: Dave Anderson <anderson@redhat.com>
|
||||
Date: Tue May 21 14:09:13 2019 -0400
|
||||
|
||||
Fix for a crash-7.2.6 regression to the "p" command. Without the
|
||||
patch, a gdb pass-through command construct such as:
|
||||
p ((struct zone *)0xffff901e3ffda000)->min_slab_pages
|
||||
gets parsed incorrectly, and the "-" is mistaken for an argument
|
||||
option, and each of the subsequent characters are marked as an
|
||||
"invalid option".
|
||||
(dwysocha@redhat.com)
|
||||
|
||||
diff --git a/tools.c b/tools.c
|
||||
index eceea90..2d95c3a 100644
|
||||
--- a/tools.c
|
||||
+++ b/tools.c
|
||||
@@ -246,8 +246,10 @@ next:
|
||||
break;
|
||||
}
|
||||
}
|
||||
- if (expression == 0)
|
||||
+ if (expression == 0) {
|
||||
i++;
|
||||
+ continue;
|
||||
+ }
|
||||
}
|
||||
|
||||
if (str[i] != NULLCHAR && str[i] != '\n') {
|
26
SOURCES/github_bf48dd4e_arm64_devmem_read_error.patch
Normal file
26
SOURCES/github_bf48dd4e_arm64_devmem_read_error.patch
Normal file
@ -0,0 +1,26 @@
|
||||
commit bf48dd4e9926515345cad06c1bfce49d7a057a26
|
||||
Author: Dave Anderson <anderson@redhat.com>
|
||||
Date: Mon Jun 10 14:12:52 2019 -0400
|
||||
|
||||
Fix for Linux 4.16 and later ARM64 kernels that contain kernel commit
|
||||
fa2a8445b1d3810c52f2a6b3a006456bd1aacb7e, titled "arm64: allow ID map
|
||||
to be extended to 52 bits", and which have been configured with both
|
||||
CONFIG_DEVMEM=y and CONFIG_STRICT_DEVMEM=y. Without the patch, an
|
||||
inconsequential error message indicating "crash: read error: kernel
|
||||
virtual address: <address> type: idmap_ptrs_per_pgd" is displayed
|
||||
during initialization.
|
||||
(anderson@redhat.com)
|
||||
|
||||
diff --git a/arm64.c b/arm64.c
|
||||
index 5b82263..6b34b5f 100644
|
||||
--- a/arm64.c
|
||||
+++ b/arm64.c
|
||||
@@ -283,7 +283,7 @@ arm64_init(int when)
|
||||
case 65536:
|
||||
if (kernel_symbol_exists("idmap_ptrs_per_pgd") &&
|
||||
readmem(symbol_value("idmap_ptrs_per_pgd"), KVADDR,
|
||||
- &value, sizeof(ulong), "idmap_ptrs_per_pgd", RETURN_ON_ERROR))
|
||||
+ &value, sizeof(ulong), "idmap_ptrs_per_pgd", QUIET|RETURN_ON_ERROR))
|
||||
machdep->ptrs_per_pgd = value;
|
||||
|
||||
if (machdep->machspec->VA_BITS > PGDIR_SHIFT_L3_64K) {
|
22
SOURCES/lzo_snappy.patch
Normal file
22
SOURCES/lzo_snappy.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- crash-7.1.5/diskdump.c.orig
|
||||
+++ crash-7.1.5/diskdump.c
|
||||
@@ -23,6 +23,8 @@
|
||||
* GNU General Public License for more details.
|
||||
*/
|
||||
|
||||
+#define LZO
|
||||
+#define SNAPPY
|
||||
#include "defs.h"
|
||||
#include "diskdump.h"
|
||||
#include "xen_dom0.h"
|
||||
--- crash-7.1.5/Makefile.orig
|
||||
+++ crash-7.1.5/Makefile
|
||||
@@ -228,7 +228,7 @@ all: make_configure
|
||||
gdb_merge: force
|
||||
@if [ ! -f ${GDB}/README ]; then \
|
||||
make --no-print-directory gdb_unzip; fi
|
||||
- @echo "${LDFLAGS} -lz -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
||||
+ @echo "${LDFLAGS} -lz -llzo2 -lsnappy -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
||||
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
||||
@rm -f ${PROGRAM}
|
||||
@if [ ! -f ${GDB}/config.status ]; then \
|
32
SOURCES/rhel8_build.patch
Normal file
32
SOURCES/rhel8_build.patch
Normal file
@ -0,0 +1,32 @@
|
||||
--- crash-7.2.3/Makefile.orig
|
||||
+++ crash-7.2.3/Makefile
|
||||
@@ -198,7 +198,7 @@ GDB_FLAGS=
|
||||
# TARGET_CFLAGS will be configured automatically by configure
|
||||
TARGET_CFLAGS=
|
||||
|
||||
-CRASH_CFLAGS=-g -D${TARGET} ${TARGET_CFLAGS} ${GDB_FLAGS} ${CFLAGS}
|
||||
+CRASH_CFLAGS=-g -D${TARGET} ${TARGET_CFLAGS} ${GDB_FLAGS} ${CFLAGS} ${CPPFLAGS} -fPIE
|
||||
|
||||
GPL_FILES=COPYING3
|
||||
TAR_FILES=${SOURCE_FILES} Makefile ${GPL_FILES} README .rh_rpm_package crash.8 \
|
||||
@@ -228,7 +228,7 @@ all: make_configure
|
||||
gdb_merge: force
|
||||
@if [ ! -f ${GDB}/README ]; then \
|
||||
make --no-print-directory gdb_unzip; fi
|
||||
- @echo "${LDFLAGS} -lz -llzo2 -lsnappy -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
||||
+ @echo "${LDFLAGS} -lz -llzo2 -lsnappy -ldl -rdynamic -Wl,-z,now -fpie" > ${GDB}/gdb/mergelibs
|
||||
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
||||
@rm -f ${PROGRAM}
|
||||
@if [ ! -f ${GDB}/config.status ]; then \
|
||||
--- crash-7.2.3/configure.c.orig
|
||||
+++ crash-7.2.3/configure.c
|
||||
@@ -780,7 +780,8 @@ build_configure(struct supported_gdb_ver
|
||||
fprintf(fp2, "%s\n", sp->GDB);
|
||||
sprintf(target_data.gdb_version, "%s", &sp->GDB[4]);
|
||||
} else if (strncmp(buf, "LDFLAGS=", strlen("LDFLAGS=")) == 0) {
|
||||
- fprintf(fp2, "LDFLAGS=%s\n", ldflags ? ldflags : "");
|
||||
+ if (ldflags)
|
||||
+ fprintf(fp2, "LDFLAGS=%s\n", ldflags ? ldflags : "");
|
||||
} else
|
||||
fprintf(fp2, "%s", buf);
|
||||
|
591
SPECS/crash.spec
Normal file
591
SPECS/crash.spec
Normal file
@ -0,0 +1,591 @@
|
||||
#
|
||||
# crash core analysis suite
|
||||
#
|
||||
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
||||
Name: crash
|
||||
Version: 7.2.6
|
||||
Release: 2%{?dist}
|
||||
License: GPLv3
|
||||
Group: Development/Debuggers
|
||||
Source: http://people.redhat.com/anderson/crash-%{version}.tar.gz
|
||||
URL: http://people.redhat.com/anderson
|
||||
ExclusiveOS: Linux
|
||||
ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x %{arm} aarch64 ppc64le
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot-%(%{__id_u} -n)
|
||||
BuildRequires: ncurses-devel zlib-devel lzo-devel bison snappy-devel
|
||||
Requires: binutils
|
||||
Patch0: lzo_snappy.patch
|
||||
Patch1: rhel8_build.patch
|
||||
Patch2: github_bf48dd4e_arm64_devmem_read_error.patch
|
||||
Patch3: github_b1a6e13a_p_regression.patch
|
||||
|
||||
%description
|
||||
The core analysis suite is a self-contained tool that can be used to
|
||||
investigate either live systems, kernel core dumps created from the
|
||||
netdump, diskdump and kdump packages from Red Hat Linux, the mcore kernel patch
|
||||
offered by Mission Critical Linux, or the LKCD kernel patch.
|
||||
|
||||
%package devel
|
||||
Requires: %{name} = %{version}, zlib-devel lzo-devel snappy-devel
|
||||
Summary: kernel crash analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
||||
Group: Development/Debuggers
|
||||
|
||||
%description devel
|
||||
The core analysis suite is a self-contained tool that can be used to
|
||||
investigate either live systems, kernel core dumps created from the
|
||||
netdump, diskdump and kdump packages from Red Hat Linux, the mcore kernel patch
|
||||
offered by Mission Critical Linux, or the LKCD kernel patch.
|
||||
|
||||
%prep
|
||||
%setup -n %{name}-%{version} -q
|
||||
%patch0 -p1 -b lzo_snappy.patch
|
||||
%patch1 -p1 -b rhel8_build.patch
|
||||
%patch2 -p1 -b github_bf48dd4e_arm64_devmem_read_error.patch
|
||||
%patch3 -p1 -b github_b1a6e13a_p_regression.patch
|
||||
|
||||
%build
|
||||
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}"
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
make DESTDIR=%{buildroot} install
|
||||
mkdir -p %{buildroot}%{_mandir}/man8
|
||||
cp -p crash.8 %{buildroot}%{_mandir}/man8/crash.8
|
||||
mkdir -p %{buildroot}%{_includedir}/crash
|
||||
chmod 0644 defs.h
|
||||
cp -p defs.h %{buildroot}%{_includedir}/crash
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/crash
|
||||
%{_mandir}/man8/crash.8*
|
||||
%doc README COPYING3
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 10 2019 Dave Anderson <anderson@redhat.com> - 7.2.6-2
|
||||
- Fix "p" command regression
|
||||
Resolves: rhbz#1718417
|
||||
- Fix arm64 debug kernel read error message during initialization
|
||||
Resolves: rhbz#1718736
|
||||
|
||||
* Mon May 6 2019 Dave Anderson <anderson@redhat.com> - 7.2.6-1
|
||||
- Rebase to latest upstream sources
|
||||
Resolves: rhbz#1686560
|
||||
- Utilize the VMCOREINFO PT_NOTE in /proc/kcore header
|
||||
Resolves: rhbz#1627528
|
||||
- Support extraction of CONFIG_PROC_VMCORE_DEVICE_DUMP data from dumpfile header
|
||||
Resolves: rhbz#1702535
|
||||
|
||||
* Thu Feb 14 2019 Dave Anderson <anderson@redhat.com> - 7.2.3-18
|
||||
- Fix "files -c" and "files -p" options
|
||||
Resolves: rhbz#1673285
|
||||
|
||||
* Mon Feb 11 2019 Dave Anderson <anderson@redhat.com> - 7.2.3-17
|
||||
- Support for CONFIG_ARM64_USER_VA_BITS_52 and CONFIG_ARM64_PA_BITS=52
|
||||
Resolves: rhbz#1670099
|
||||
|
||||
* Tue Jan 8 2019 Dave Anderson <anderson@redhat.com> - 7.2.3-16
|
||||
- Resurrect "dev -p" option.
|
||||
- Fix "dev -[dD]" options to account for request_queue.in_flight[] removal.
|
||||
Resolves: rhbz#1662039
|
||||
- Command line input fixes
|
||||
Resolves: rhbz#1664061
|
||||
|
||||
* Thu Dec 13 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-15
|
||||
- Increase ppc64 MAX_PHYSMEM_BITS to match 4.18.0-35.el8 kernel backport
|
||||
Resolves: rhbz#1658628
|
||||
|
||||
* Thu Nov 29 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-14
|
||||
- Fix for ARM64 "ps -s" memory allocation failure
|
||||
Resolves: rhbz#1654582
|
||||
|
||||
* Thu Oct 25 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-13
|
||||
- Change "bt" warnings when exception RIP is legitimate mapped address
|
||||
Resolves: rhbz#1642221
|
||||
|
||||
* Mon Oct 15 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-12
|
||||
- Address covscan issues
|
||||
Resolves: rhbz#1602466
|
||||
- Fix for x86_64 5-level pagetable vmalloc range expansion
|
||||
Resolves: rhbz#1637125
|
||||
|
||||
* Wed Oct 4 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-11
|
||||
- Fix ppc64 backtrace issues
|
||||
Resolves: rhbz#1633525
|
||||
|
||||
* Wed Sep 19 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-10
|
||||
- Address annocheck build issues
|
||||
Resolves: rhbz#1624101
|
||||
|
||||
* Thu Aug 9 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-9
|
||||
- Fix for live system (/proc/kcore) access when KALSR is in effect
|
||||
Resolves: rhbz#1611916
|
||||
|
||||
* Mon Jul 16 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-8
|
||||
- Rebase to github commits 9b494b70_to_eb823b79
|
||||
Resolves: rhbz#1563495
|
||||
|
||||
* Fri Jun 22 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-7
|
||||
- Rebase to github commits 28fa7bd0 to 02efd083
|
||||
Resolves: rhbz#1590751
|
||||
Resolves: rhbz#1592746
|
||||
|
||||
* Tue Jun 12 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-6
|
||||
- github commit 1926150e: fix ppc64/ppc6le stacksize calculation
|
||||
|
||||
* Fri Jun 8 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-5
|
||||
- Remove /dev/mem readmem error message and /proc/kcore switch messages
|
||||
Resolves: rhbz#1585944
|
||||
|
||||
* Fri Jun 1 2018 Dave Anderson <anderson@redhat.com> - 7.2.3-4
|
||||
- Rebase to latest upstream sources
|
||||
|
||||
* Tue Nov 21 2017 Dave Anderson <anderson@redhat.com> - 7.2.0-2
|
||||
- Rebase to github commits da9bd35a to e2efacdd
|
||||
Resolves: rhbz#1497316
|
||||
|
||||
* Wed Nov 1 2017 Dave Anderson <anderson@redhat.com> - 7.2.0-1
|
||||
- Rebase to upstream version 7.2.0
|
||||
- Rebase to github commits da9bd35a_to_e2efacdd.patch
|
||||
Resolves: rhbz#1497316
|
||||
- ppc64le: fix for "WARNING: cannot access vmalloc'd module memory"
|
||||
Resolves: rhbz#1485391
|
||||
- Support for analyzing an SADUMP crash dump if KASLR is enabled
|
||||
Resolves: rhbz#1504467
|
||||
|
||||
* Wed May 3 2017 Dave Anderson <anderson@redhat.com> - 7.1.9-2
|
||||
- Rebase to github commits 87179026 to ad3b8476
|
||||
Resolves: rhbz#1393534
|
||||
- Prohibit native gdb disassemble command when KASLR
|
||||
Resolves: rhbz#1445649
|
||||
|
||||
* Mon Apr 24 2017 Dave Anderson <anderson@redhat.com> - 7.1.9-1
|
||||
- Rebase to upstream version 7.1.9
|
||||
Resolves: rhbz#1393534
|
||||
- Fix gdb "set scope" option for KASLR kernels.
|
||||
Resolves: rhbz#1440725
|
||||
- Fix for the determination of the x86_64 "phys_base" value when it is
|
||||
not passed in the VMCOREINFO data of ELF vmcores
|
||||
Resolves: rhbz#1439170
|
||||
|
||||
* Wed Mar 8 2017 Dave Anderson <anderson@redhat.com> - 7.1.8-2
|
||||
- mod [-sS] command may erroneously reassign module symbol addresses
|
||||
Resolves: rhbz#1430091
|
||||
|
||||
* Fri Feb 24 2017 Dave Anderson <anderson@redhat.com> - 7.1.8-1
|
||||
- Rebase to upstream version 7.1.8
|
||||
Resolves: rhbz#1393534
|
||||
- POWER9 - Power ISA 3.0 related support for crash utility
|
||||
Resolves: rhbz#1368711
|
||||
- crash package update - ppc64/ppc64le
|
||||
Resolves: rhbz#1384944
|
||||
- exception RIP: unknown or invalid address
|
||||
Resolves: rhbz#1350457
|
||||
- Crash does not always parse correctly the modules symbol tables
|
||||
Resolves: rhbz#1360415
|
||||
- ARM64: crash live system from: WARNING: cannot read linux_banner string
|
||||
Resolves: rhbz#1392007
|
||||
- kmem: invalid structure member offset: page_count
|
||||
Resolves: rhbz#1392011
|
||||
- Kernel address space randomization [KASLR] support
|
||||
Resolves: rhbz#1392658
|
||||
- invalid structure size: tnt
|
||||
Resolves: rhbz#1420653
|
||||
|
||||
* Wed Sep 14 2016 Dave Anderson <anderson@redhat.com> - 7.1.5-2
|
||||
- Fix for kernel module symbol gathering when the ordering of module
|
||||
symbol name strings does not match the order of the kernel_symbol
|
||||
structures.
|
||||
- Resolves: rhbz#1375130
|
||||
|
||||
* Thu Apr 28 2016 Dave Anderson <anderson@redhat.com> - 7.1.5-1
|
||||
- Rebase to upstream version 7.1.5
|
||||
Resolves: rhbz#1292566
|
||||
- Decode clflushopt instruction
|
||||
Resolves: rhbz#1262479
|
||||
- Support AArch64 QEMU generated dumps
|
||||
Resolves: rhbz#1299873
|
||||
- crash: zero-size memory allocation (aarch64)
|
||||
Resolves: rhbz#1312738
|
||||
|
||||
* Tue Apr 5 2016 Dave Anderson <anderson@redhat.com> - 7.1.2-4
|
||||
- crash: fails to read excluded pages by default on sadump-related format
|
||||
Resolves: rhbz#1304260
|
||||
|
||||
* Mon Nov 23 2015 Dave Anderson <anderson@redhat.com> - 7.1.2-3
|
||||
- crash fails to read or wrongly reads some parts of memory in sadump vmcore format
|
||||
Resolves: rhbz#1282997
|
||||
|
||||
* Tue Aug 4 2015 Dave Anderson <anderson@redhat.com> - 7.1.2-2
|
||||
- Fix "kmem -s <address>", "bt -F[F]", and "rd -S[S]" options in kernels
|
||||
configured with CONFIG_SLUB having multiple-page slabs.
|
||||
Resolves: rhbz#1244003
|
||||
- Fix for SIGSEGV generated by "bt -[f|F]" in ARM64 kernels.
|
||||
Resolves: rhbz#1248859
|
||||
|
||||
* Mon Jul 13 2015 Dave Anderson <anderson@redhat.com> - 7.1.2-1
|
||||
- Rebase to upstream version 7.1.2
|
||||
Resolves: rhbz#1207696
|
||||
- Fix several ppc64 backtrace issues
|
||||
Resolves: rhbz#1235447
|
||||
|
||||
* Fri Jun 05 2015 Dave Anderson <anderson@redhat.com> - 7.1.1-2
|
||||
- ARM64 backtrace enhancements
|
||||
Resolves: rhbz#1227508
|
||||
|
||||
* Thu May 28 2015 Dave Anderson <anderson@redhat.com> - 7.1.1-1
|
||||
- Rebase to upstream version 7.1.1
|
||||
Resolves: rhbz#1207696
|
||||
- Display s390x vector registers from a kernel dump.
|
||||
Resolves: rhbz#1182161
|
||||
- Fix date displayed on initial system banner and by the "sys" command on ARM64.
|
||||
Resolves: rhbz#1223044
|
||||
- Fix ARM64 page size calculation on 4.1 and later kernels.
|
||||
Resolves: rhbz#1222645
|
||||
|
||||
* Tue Apr 21 2015 Dave Anderson <anderson@redhat.com> - 7.0.9-6
|
||||
- Calculate ARM64 virtual memory layout based upon struct page size
|
||||
Resolves: rhbz#1204941
|
||||
|
||||
* Tue Apr 7 2015 Dave Anderson <anderson@redhat.com> - 7.0.9-5
|
||||
- Support new sadump format that can represent more than 16 TB physical memory space
|
||||
Resolves: rhbz#1182383
|
||||
|
||||
* Mon Jan 26 2015 Dave Anderson <anderson@redhat.com> - 7.0.9-4
|
||||
Fix ppc64 "bt" command for active tasks in compressed kdumps.
|
||||
Resolves: rhbz#1184401
|
||||
|
||||
* Mon Jan 12 2015 Dave Anderson <anderson@redhat.com> - 7.0.9-3
|
||||
Fix "bt" command mislabeling errors.
|
||||
Resolves: rhbz#1179476
|
||||
|
||||
* Mon Dec 08 2014 Dave Anderson <anderson@redhat.com> - 7.0.9-2
|
||||
- Use registers from QEMU-generated ELF and compressed kdump headers
|
||||
for active task backtraces.
|
||||
- Resolves: rhbz#1169555
|
||||
|
||||
* Fri Nov 14 2014 Dave Anderson <anderson@redhat.com> - 7.0.9-1
|
||||
- Rebase to upstream version 7.0.9.
|
||||
- Resolves: rhbz#1110513
|
||||
|
||||
* Tue Sep 23 2014 Dave Anderson <anderson@redhat.com> - 7.0.8-2
|
||||
- Fix ps performance patch regression on live systems.
|
||||
- Resolves: rhbz#1134177
|
||||
- Minor build-related fixes for ppc64le.
|
||||
- Resolves: rhbz#1123991
|
||||
|
||||
* Fri Sep 12 2014 Dave Anderson <anderson@redhat.com> - 7.0.8-1
|
||||
- Rebase to upstream version 7.0.8.
|
||||
- Resolves: rhbz#1110513
|
||||
- Fix to calculate the physical base address of dumpfiles created
|
||||
by a "virsh dump" of an OVMF guest.
|
||||
- Resolves: rhbz#1080698
|
||||
- Support for aarch64 architecture.
|
||||
- Resolves: rhbz#1110551
|
||||
- Fix to prevent crash from spinning endlessly on a corrupted/truncated
|
||||
dumpfile whose bitmap data is not wholly contained within the file.
|
||||
- Resolves: rhbz#1114088
|
||||
- Support for ppc64le architecture.
|
||||
- Resolves: rhbz#1123991
|
||||
|
||||
* Tue Jan 28 2014 Daniel Mach <dmach@redhat.com> - 7.0.2-6
|
||||
- Mass rebuild 2014-01-24
|
||||
|
||||
* Fri Jan 24 2014 Dave Anderson <anderson@redhat.com> - 7.0.2-5
|
||||
- Fix for a missing kernel-mode exception frame dump by the x86_64
|
||||
"bt" command if a page fault was generated by a bogus RIP.
|
||||
- Resolves: rhbz#1057353
|
||||
- Fix for the x86_64 "bt" command to prevent an unwarranted message
|
||||
indicating "WARNING: possibly bogus exception frame" generated
|
||||
from a blocked kernel thread that was in the process of exec'ing
|
||||
a user process via the call_usermodehelper() facility.
|
||||
- Resolves: rhbz#1057357
|
||||
|
||||
* Fri Jan 10 2014 Dave Anderson <anderson@redhat.com> - 7.0.2-4
|
||||
- Fixes for "kmem -S" command for CONFIG_SLUB.
|
||||
- Resolves: rhbz#1045591
|
||||
- Increase S390X NR_CPUS
|
||||
- Resolves: rhbz#1051156
|
||||
|
||||
* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 7.0.2-3
|
||||
- Mass rebuild 2013-12-27
|
||||
|
||||
* Tue Oct 29 2013 Dave Anderson <anderson@redhat.com> - 7.0.2-2
|
||||
- Compressed kdump 46-bit physical memory support
|
||||
Resolves: rhbz#1015250
|
||||
- Fix incorrect backtrace for dumps taken with "virsh dump --memory-only"
|
||||
Resolves: rhbz#1020469
|
||||
- Fix cpu number display on systems with more than 254 cpus
|
||||
Resolves: rhbz#1020536
|
||||
|
||||
* Wed Sep 04 2013 Dave Anderson <anderson@redhat.com> - 7.0.2-1
|
||||
- Update to latest upstream release
|
||||
- Fix for ppc64 embedded gdb NULL pointer translation sigsegv
|
||||
- Fix for bt -F failure
|
||||
|
||||
* Fri Jul 26 2013 Dave Anderson <anderson@redhat.com> - 7.0.1-4
|
||||
- Add lzo-devel and snappy-devel to crash-devel Requires line
|
||||
|
||||
* Tue Jul 23 2013 Dave Anderson <anderson@redhat.com> - 7.0.1-3
|
||||
- Build with snappy compression support
|
||||
|
||||
* Tue Jul 9 2013 Dave Anderson <anderson@redhat.com> - 7.0.1-2
|
||||
- Fix for ppc64 Linux 3.10 vmalloc/user-space virtual address translation
|
||||
|
||||
* Tue Jun 18 2013 Dave Anderson <anderson@redhat.com> - 7.0.1-1
|
||||
- Update to latest upstream release
|
||||
- Build with LZO support
|
||||
|
||||
* Tue Apr 9 2013 Dave Anderson <anderson@redhat.com> - 6.1.6-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Tue Feb 19 2013 Dave Anderson <anderson@redhat.com> - 6.1.4-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.1.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Jan 9 2013 Dave Anderson <anderson@redhat.com> - 6.1.2-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Tue Nov 27 2012 Dave Anderson <anderson@redhat.com> - 6.1.1-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Mon Sep 1 2012 Dave Anderson <anderson@redhat.com> - 6.1.0-1
|
||||
- Add ppc to ExclusiveArch list
|
||||
- Update to latest upstream release
|
||||
|
||||
* Tue Aug 21 2012 Dave Anderson <anderson@redhat.com> - 6.0.9-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Jul 1 2012 Dave Anderson <anderson@redhat.com> - 6.0.8-1
|
||||
- Update to latest upstream release.
|
||||
- Replace usage of "struct siginfo" with "siginfo_t".
|
||||
|
||||
* Mon Apr 30 2012 Dave Anderson <anderson@redhat.com> - 6.0.6-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Mon Mar 26 2012 Dave Anderson <anderson@redhat.com> - 6.0.5-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Wed Jan 4 2012 Dave Anderson <anderson@redhat.com> - 6.0.2-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Wed Oct 26 2011 Dave Anderson <anderson@redhat.com> - 6.0.0-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Tue Sep 20 2011 Dave Anderson <anderson@redhat.com> - 5.1.8-1
|
||||
- Update to latest upstream release
|
||||
- Additional fixes for gcc-4.6 -Werror compile failures for ARM architecture.
|
||||
|
||||
* Thu Sep 1 2011 Dave Anderson <anderson@redhat.com> - 5.1.7-2
|
||||
- Fixes for gcc-4.6 -Werror compile failures for ARM architecture.
|
||||
|
||||
* Wed Aug 17 2011 Dave Anderson <anderson@redhat.com> - 5.1.7-1
|
||||
- Update to latest upstream release
|
||||
- Fixes for gcc-4.6 -Werror compile failures for ppc64/ppc.
|
||||
|
||||
* Tue May 31 2011 Peter Robinson <pbrobinson@gmail.com> - 5.1.5-1
|
||||
- Update to latest upstream release
|
||||
- Add ARM to the Exclusive arch
|
||||
|
||||
* Wed Feb 25 2011 Dave Anderson <anderson@redhat.com> - 5.1.2-2
|
||||
- Fixes for gcc-4.6 -Werror compile failures in gdb module.
|
||||
|
||||
* Wed Feb 23 2011 Dave Anderson <anderson@redhat.com> - 5.1.2-1
|
||||
- Upstream version.
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Jul 20 2010 Dave Anderson <anderson@redhat.com> - 5.0.6-2
|
||||
- Bump version.
|
||||
|
||||
* Tue Jul 20 2010 Dave Anderson <anderson@redhat.com> - 5.0.6-1
|
||||
- Update to upstream version.
|
||||
|
||||
* Fri Sep 11 2009 Dave Anderson <anderson@redhat.com> - 4.0.9-2
|
||||
Bump version.
|
||||
|
||||
* Fri Sep 11 2009 Dave Anderson <anderson@redhat.com> - 4.0.9-1
|
||||
- Update to upstream release, which allows the removal of the
|
||||
Revision tag workaround, the crash-4.0-8.11-dwarf3.patch and
|
||||
the crash-4.0-8.11-optflags.patch
|
||||
|
||||
* Sun Aug 05 2009 Lubomir Rintel <lkundrak@v3.sk> - 4.0.8.11-2
|
||||
- Fix reading of dwarf 3 DW_AT_data_member_location
|
||||
- Use proper compiler flags
|
||||
|
||||
* Wed Aug 05 2009 Lubomir Rintel <lkundrak@v3.sk> - 4.0.8.11-1
|
||||
- Update to later upstream release
|
||||
- Fix abuse of Revision tag
|
||||
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-9.7.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-8.7.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Thu Feb 19 2009 Dave Anderson <anderson@redhat.com> - 4.0-7.7.2
|
||||
- Replace exclusive arch i386 with ix86.
|
||||
|
||||
* Thu Feb 19 2009 Dave Anderson <anderson@redhat.com> - 4.0-7.7.1
|
||||
- Updates to this file per crash merge review
|
||||
- Update to upstream version 4.0-7.7. Full changelog viewable in:
|
||||
http://people.redhat.com/anderson/crash.changelog.html
|
||||
|
||||
* Tue Jul 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> 4.0-7
|
||||
- fix license tag
|
||||
|
||||
* Tue Apr 29 2008 Dave Anderson <anderson@redhat.com> - 4.0-6.3
|
||||
- Added crash-devel subpackage
|
||||
- Updated crash.patch to match upstream version 4.0-6.3
|
||||
|
||||
* Wed Feb 20 2008 Dave Anderson <anderson@redhat.com> - 4.0-6.0.5
|
||||
- Second attempt at addressing the GCC 4.3 build, which failed due
|
||||
to additional ptrace.h includes in the lkcd vmdump header files.
|
||||
|
||||
* Wed Feb 20 2008 Dave Anderson <anderson@redhat.com> - 4.0-6.0.4
|
||||
- First attempt at addressing the GCC 4.3 build, which failed on x86_64
|
||||
because ptrace-abi.h (included by ptrace.h) uses the "u32" typedef,
|
||||
which relies on <asm/types.h>, and include/asm-x86_64/types.h
|
||||
does not not typedef u32 as done in include/asm-x86/types.h.
|
||||
|
||||
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.0-6.0.3
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Wed Jan 23 2008 Dave Anderson <anderson@redhat.com> - 4.0-5.0.3
|
||||
- Updated crash.patch to match upstream version 4.0-5.0.
|
||||
|
||||
* Wed Aug 29 2007 Dave Anderson <anderson@redhat.com> - 4.0-4.6.2
|
||||
- Updated crash.patch to match upstream version 4.0-4.6.
|
||||
|
||||
* Wed Sep 13 2006 Dave Anderson <anderson@redhat.com> - 4.0-3.3
|
||||
- Updated crash.patch to match upstream version 4.0-3.3.
|
||||
- Support for x86_64 relocatable kernels. BZ #204557
|
||||
|
||||
* Mon Aug 7 2006 Dave Anderson <anderson@redhat.com> - 4.0-3.1
|
||||
- Updated crash.patch to match upstream version 4.0-3.1.
|
||||
- Added kdump reference to description.
|
||||
- Added s390 and s390x to ExclusiveArch list. BZ #199125
|
||||
- Removed LKCD v1 pt_regs references for s390/s390x build.
|
||||
- Removed LKCD v2_v3 pt_regs references for for s390/s390x build.
|
||||
|
||||
* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 4.0-3
|
||||
- rebuild
|
||||
|
||||
* Mon May 15 2006 Dave Anderson <anderson@redhat.com> - 4.0-2.26.4
|
||||
- Updated crash.patch such that <asm/page.h> is not #include'd
|
||||
by s390_dump.c; IBM did not make the file s390[s] only; BZ #192719
|
||||
|
||||
* Mon May 15 2006 Dave Anderson <anderson@redhat.com> - 4.0-2.26.3
|
||||
- Updated crash.patch such that <asm/page.h> is not #include'd
|
||||
by vas_crash.h; only ia64 build complained; BZ #191719
|
||||
|
||||
* Mon May 15 2006 Dave Anderson <anderson@redhat.com> - 4.0-2.26.2
|
||||
- Updated crash.patch such that <asm/segment.h> is not #include'd
|
||||
by lkcd_x86_trace.c; also for BZ #191719
|
||||
|
||||
* Mon May 15 2006 Dave Anderson <anderson@redhat.com> - 4.0-2.26.1
|
||||
- Updated crash.patch to bring it up to 4.0-2.26, which should
|
||||
address BZ #191719 - "crash fails to build in mock"
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.0-2.18.1
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Wed Jan 04 2006 Dave Anderson <anderson@redhat.com> 4.0-2.18
|
||||
- Updated source package to crash-4.0.tar.gz, and crash.patch
|
||||
to bring it up to 4.0-2.18.
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Thu Mar 03 2005 Dave Anderson <anderson@redhat.com> 3.10-13
|
||||
- Compiler error- and warning-related fixes for gcc 4 build.
|
||||
- Update to enhance x86 and x86_64 gdb disassembly output so as to
|
||||
symbolically display call targets from kernel module text without
|
||||
requiring module debuginfo data.
|
||||
- Fix hole where an ia64 vmcore could be mistakenly accepted as a
|
||||
usable dumpfile on an x86_64 machine, leading eventually to a
|
||||
non-related error message.
|
||||
* Wed Mar 02 2005 Dave Anderson <anderson@redhat.com> 3.10-12
|
||||
- rebuild (gcc 4)
|
||||
* Thu Feb 10 2005 Dave Anderson <anderson@redhat.com> 3.10-9
|
||||
- Updated source package to crash-3.10.tar.gz, containing
|
||||
IBM's final ppc64 processor support for RHEL4
|
||||
- Fixes potential "bt -a" hang on dumpfile where netdump IPI interrupted
|
||||
an x86 process while executing the instructions just after it had entered
|
||||
the kernel for a syscall, but before calling the handler. BZ #139437
|
||||
- Update to handle backtraces in dumpfiles generated on IA64 with the
|
||||
INIT switch (functionality intro'd in RHEL3-U5 kernel). BZ #139429
|
||||
- Fix for handling ia64 and x86_64 machines booted with maxcpus=1 on
|
||||
an SMP kernel. BZ #139435
|
||||
- Update to handle backtraces in dumpfiles generated on x86_64 from the
|
||||
NMI exception stack (functionality intro'd in RHEL3-U5 kernel).
|
||||
- "kmem -[sS]" beefed up to more accurately verify slab cache chains
|
||||
and report errors found.
|
||||
- Fix for ia64 INIT switch-generated backtrace handling when
|
||||
init_handler_platform() is inlined into ia64_init_handler();
|
||||
properly handles both RHEL3 and RHEL4 kernel patches.
|
||||
BZ #138350
|
||||
- Update to enhance ia64 gdb disassembly output so as to
|
||||
symbolically display call targets from kernel module
|
||||
text without requiring module debuginfo data.
|
||||
|
||||
* Wed Jul 14 2004 Dave Anderson <anderson@redhat.com> 3.8-5
|
||||
- bump release for fc3
|
||||
|
||||
* Tue Jul 13 2004 Dave Anderson <anderson@redhat.com> 3.8-4
|
||||
- Fix for gcc 3.4.x/gdb issue where vmlinux was mistakenly presumed non-debug
|
||||
|
||||
* Fri Jun 25 2004 Dave Anderson <anderson@redhat.com> 3.8-3
|
||||
- remove (harmless) error message during ia64 diskdump invocation when
|
||||
an SMP system gets booted with maxcpus=1
|
||||
- several 2.6 kernel specific updates
|
||||
|
||||
* Thu Jun 17 2004 Dave Anderson <anderson@redhat.com> 3.8-2
|
||||
- updated source package to crash-3.8.tar.gz
|
||||
- diskdump support
|
||||
- x86_64 processor support
|
||||
|
||||
* Mon Sep 22 2003 Dave Anderson <anderson@redhat.com> 3.7-5
|
||||
- make bt recovery code start fix-up only upon reaching first faulting frame
|
||||
|
||||
* Fri Sep 19 2003 Dave Anderson <anderson@redhat.com> 3.7-4
|
||||
- fix "bt -e" and bt recovery code to recognize new __KERNEL_CS and DS
|
||||
|
||||
* Wed Sep 10 2003 Dave Anderson <anderson@redhat.com> 3.7-3
|
||||
- patch to recognize per-cpu GDT changes that redefine __KERNEL_CS and DS
|
||||
|
||||
* Wed Sep 10 2003 Dave Anderson <anderson@redhat.com> 3.7-2
|
||||
- patches for netdump active_set determination and slab info gathering
|
||||
|
||||
* Wed Aug 20 2003 Dave Anderson <anderson@redhat.com> 3.7-1
|
||||
- updated source package to crash-3.7.tar.gz
|
||||
|
||||
* Wed Jul 23 2003 Dave Anderson <anderson@redhat.com> 3.6-1
|
||||
- removed Packager, Distribution, and Vendor tags
|
||||
- updated source package to crash-3.6.tar.gz
|
||||
|
||||
* Fri Jul 18 2003 Jay Fenlason <fenlason@redhat.com> 3.5-2
|
||||
- remove ppc from arch list, since it doesn't work with ppc64 kernels
|
||||
- remove alpha from the arch list since we don't build it any more
|
||||
|
||||
* Fri Jul 18 2003 Matt Wilson <msw@redhat.com> 3.5-1
|
||||
- use %%defattr(-,root,root)
|
||||
|
||||
* Tue Jul 15 2003 Jay Fenlason <fenlason@redhat.com>
|
||||
- Updated spec file as first step in turning this into a real RPM for taroon.
|
||||
- Wrote man page.
|
Loading…
Reference in New Issue
Block a user