Debrand for AlmaLinux
This commit is contained in:
commit
d6bf2df374
@ -1,2 +1,2 @@
|
|||||||
2ac6f08b5425943407f2819df11ae4156e6706db SOURCES/crash-8.0.5.tar.gz
|
118c55409a4e026c8052c7cb0020dbc24b5144a1 SOURCES/crash-8.0.6.tar.gz
|
||||||
6bf5ee7877a4740835745ed97ce525a00bb2232c SOURCES/gdb-10.2.tar.gz
|
6bf5ee7877a4740835745ed97ce525a00bb2232c SOURCES/gdb-10.2.tar.gz
|
||||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/crash-8.0.5.tar.gz
|
SOURCES/crash-8.0.6.tar.gz
|
||||||
SOURCES/gdb-10.2.tar.gz
|
SOURCES/gdb-10.2.tar.gz
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- crash-8.0.5/Makefile.orig
|
--- crash-8.0.6/Makefile.orig
|
||||||
+++ crash-8.0.5/Makefile
|
+++ crash-8.0.6/Makefile
|
||||||
@@ -204,7 +204,7 @@ GDB_FLAGS=
|
@@ -204,7 +204,7 @@ GDB_FLAGS=
|
||||||
# TARGET_CFLAGS will be configured automatically by configure
|
# TARGET_CFLAGS will be configured automatically by configure
|
||||||
TARGET_CFLAGS=
|
TARGET_CFLAGS=
|
||||||
@ -18,8 +18,8 @@
|
|||||||
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
||||||
@rm -f ${PROGRAM}
|
@rm -f ${PROGRAM}
|
||||||
@if [ ! -f ${GDB}/config.status ]; then \
|
@if [ ! -f ${GDB}/config.status ]; then \
|
||||||
--- crash-8.0.5/configure.c.orig
|
--- crash-8.0.6/configure.c.orig
|
||||||
+++ crash-8.0.5/configure.c
|
+++ crash-8.0.6/configure.c
|
||||||
@@ -810,7 +810,8 @@ build_configure(struct supported_gdb_version *sp)
|
@@ -810,7 +810,8 @@ build_configure(struct supported_gdb_version *sp)
|
||||||
fprintf(fp2, "%s\n", sp->GDB);
|
fprintf(fp2, "%s\n", sp->GDB);
|
||||||
sprintf(target_data.gdb_version, "%s", &sp->GDB[4]);
|
sprintf(target_data.gdb_version, "%s", &sp->GDB[4]);
|
@ -1,5 +1,5 @@
|
|||||||
--- crash-8.0.5/Makefile.orig
|
--- crash-8.0.6/Makefile.orig
|
||||||
+++ crash-8.0.5/Makefile
|
+++ crash-8.0.6/Makefile
|
||||||
@@ -256,7 +256,7 @@ all: make_configure
|
@@ -256,7 +256,7 @@ all: make_configure
|
||||||
gdb_merge: force
|
gdb_merge: force
|
||||||
@if [ ! -f ${GDB}/README ]; then \
|
@if [ ! -f ${GDB}/README ]; then \
|
||||||
@ -9,8 +9,8 @@
|
|||||||
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
||||||
@rm -f ${PROGRAM}
|
@rm -f ${PROGRAM}
|
||||||
@if [ ! -f ${GDB}/config.status ]; then \
|
@if [ ! -f ${GDB}/config.status ]; then \
|
||||||
--- crash-8.0.5/diskdump.c.orig
|
--- crash-8.0.6/diskdump.c.orig
|
||||||
+++ crash-8.0.5/diskdump.c
|
+++ crash-8.0.6/diskdump.c
|
||||||
@@ -23,6 +23,9 @@
|
@@ -23,6 +23,9 @@
|
||||||
* GNU General Public License for more details.
|
* GNU General Public License for more details.
|
||||||
*/
|
*/
|
||||||
|
@ -3,7 +3,7 @@
|
|||||||
#
|
#
|
||||||
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
||||||
Name: crash
|
Name: crash
|
||||||
Version: 8.0.5
|
Version: 8.0.6
|
||||||
Release: 1%{?dist}.alma.1
|
Release: 1%{?dist}.alma.1
|
||||||
License: GPLv3
|
License: GPLv3
|
||||||
Source0: https://github.com/crash-utility/crash/archive/crash-%{version}.tar.gz
|
Source0: https://github.com/crash-utility/crash/archive/crash-%{version}.tar.gz
|
||||||
@ -18,7 +18,7 @@ Requires: binutils
|
|||||||
Provides: bundled(libiberty)
|
Provides: bundled(libiberty)
|
||||||
Provides: bundled(gdb) = 10.2
|
Provides: bundled(gdb) = 10.2
|
||||||
Patch0: lzo_snappy_zstd.patch
|
Patch0: lzo_snappy_zstd.patch
|
||||||
Patch1: crash-8.0.5_build.patch
|
Patch1: crash-8.0.6_build.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The core analysis suite is a self-contained tool that can be used to
|
The core analysis suite is a self-contained tool that can be used to
|
||||||
@ -39,7 +39,7 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
|
|||||||
%prep
|
%prep
|
||||||
%setup -n %{name}-%{version} -q
|
%setup -n %{name}-%{version} -q
|
||||||
%patch -P 0 -p1 -b lzo_snappy_zstd.patch
|
%patch -P 0 -p1 -b lzo_snappy_zstd.patch
|
||||||
%patch -P 1 -p1 -b crash-8.0.4_build.patch
|
%patch -P 1 -p1 -b crash-8.0.6_build.patch
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -65,13 +65,18 @@ cp -p defs.h %{buildroot}%{_includedir}/crash
|
|||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Sep 30 2024 Eduard Abdullin <eabdullin@almalinux.org> - 8.0.5-1.alma.1
|
* Tue Mar 11 2025 Eduard Abdullin <eabdullin@almalinux.org> - 8.0.6-1.alma.1
|
||||||
- Debrand for AlmaLinux
|
- Debrand for AlmaLinux
|
||||||
|
|
||||||
|
* Thu Nov 14 2024 Lianbo Jiang <lijiang@redhat.com> - 8.0.6-1
|
||||||
|
- Rebase to upstream crash 8.0.6
|
||||||
|
|
||||||
* Sat May 11 2024 Lianbo Jiang <lijiang@redhat.com> - 8.0.5-1
|
* Sat May 11 2024 Lianbo Jiang <lijiang@redhat.com> - 8.0.5-1
|
||||||
- Rebase to upstream crash 8.0.5
|
- Rebase to upstream crash 8.0.5
|
||||||
|
|
||||||
* Mon Feb 05 2024 Tao Liu <ltao@redhat.com> - 8.0.4-3
|
* Mon Feb 05 2024 Tao Liu <ltao@redhat.com> - 8.0.4-3
|
||||||
- Fix bt takes many minutes on some pids in some vmcore
|
- Fix bt takes many minutes on some pids in some vmcore
|
||||||
|
|
||||||
* Tue Jan 02 2024 Lianbo Jiang <lijiang@redhat.com> - 8.0.4-2
|
* Tue Jan 02 2024 Lianbo Jiang <lijiang@redhat.com> - 8.0.4-2
|
||||||
- Fix the "dis -lr" not displaying the source file names
|
- Fix the "dis -lr" not displaying the source file names
|
||||||
and line numbers
|
and line numbers
|
||||||
@ -82,9 +87,11 @@ cp -p defs.h %{buildroot}%{_includedir}/crash
|
|||||||
|
|
||||||
* Thu May 04 2023 Lianbo Jiang <lijiang@redhat.com> - 8.0.3-1
|
* Thu May 04 2023 Lianbo Jiang <lijiang@redhat.com> - 8.0.3-1
|
||||||
- Rebase to upstream crash 8.0.3
|
- Rebase to upstream crash 8.0.3
|
||||||
|
|
||||||
* Mon Feb 20 2023 Lianbo Jiang <lijiang@redhat.com> - 8.0.2-2
|
* Mon Feb 20 2023 Lianbo Jiang <lijiang@redhat.com> - 8.0.2-2
|
||||||
- Fix an assertion failure in the gdb's copy_type()
|
- Fix an assertion failure in the gdb's copy_type()
|
||||||
- Fix for "bt" command printing "bogus exception frame" warning
|
- Fix for "bt" command printing "bogus exception frame" warning
|
||||||
|
|
||||||
* Thu Nov 17 2022 Lianbo Jiang <lijiang@redhat.com> - 8.0.2-1
|
* Thu Nov 17 2022 Lianbo Jiang <lijiang@redhat.com> - 8.0.2-1
|
||||||
- Rebase to upstream crash 8.0.2
|
- Rebase to upstream crash 8.0.2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user