Update to latest upstream release(crash-7.2.9)
Signed-off-by: Lianbo Jiang <lijiang@redhat.com>
This commit is contained in:
parent
235709a5cf
commit
cd525b14e6
2
.gitignore
vendored
2
.gitignore
vendored
@ -42,3 +42,5 @@ crash-5.0.6.tar.gz
|
|||||||
/crash-7.2.6.tar.gz
|
/crash-7.2.6.tar.gz
|
||||||
/crash-7.2.7.tar.gz
|
/crash-7.2.7.tar.gz
|
||||||
/crash-7.2.8.tar.gz
|
/crash-7.2.8.tar.gz
|
||||||
|
/crash-7.2.9.tar.gz
|
||||||
|
/gdb-7.6.tar.gz
|
||||||
|
15
crash.spec
15
crash.spec
@ -3,11 +3,12 @@
|
|||||||
#
|
#
|
||||||
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
||||||
Name: crash
|
Name: crash
|
||||||
Version: 7.2.8
|
Version: 7.2.9
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3
|
License: GPLv3
|
||||||
Source: http://people.redhat.com/anderson/crash-%{version}.tar.gz
|
Source0: https://github.com/crash-utility/crash/archive/crash-%{version}.tar.gz
|
||||||
URL: http://people.redhat.com/anderson
|
Source1: http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz
|
||||||
|
URL: https://crash-utility.github.io
|
||||||
ExclusiveOS: Linux
|
ExclusiveOS: Linux
|
||||||
ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x %{arm} aarch64 ppc64le
|
ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x %{arm} aarch64 ppc64le
|
||||||
BuildRequires: ncurses-devel zlib-devel lzo-devel snappy-devel bison readline-devel
|
BuildRequires: ncurses-devel zlib-devel lzo-devel snappy-devel bison readline-devel
|
||||||
@ -17,7 +18,6 @@ Provides: bundled(libiberty)
|
|||||||
Provides: bundled(gdb) = 7.6
|
Provides: bundled(gdb) = 7.6
|
||||||
Patch0: lzo_snappy.patch
|
Patch0: lzo_snappy.patch
|
||||||
Patch1: use_system_readline_v3.patch
|
Patch1: use_system_readline_v3.patch
|
||||||
Patch2: aarch64_gcc10_fno-common.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The core analysis suite is a self-contained tool that can be used to
|
The core analysis suite is a self-contained tool that can be used to
|
||||||
@ -39,7 +39,6 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
|
|||||||
%setup -n %{name}-%{version} -q
|
%setup -n %{name}-%{version} -q
|
||||||
%patch0 -p1 -b lzo_snappy.patch
|
%patch0 -p1 -b lzo_snappy.patch
|
||||||
%patch1 -p1 -b use_system_readline_v3.patch
|
%patch1 -p1 -b use_system_readline_v3.patch
|
||||||
%patch2 -p1 -b aarch64_gcc10_fno-common.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# This package has an internal copy of GDB which has broken configure code for
|
# This package has an internal copy of GDB which has broken configure code for
|
||||||
@ -49,6 +48,7 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
|
|||||||
# Disable LTO
|
# Disable LTO
|
||||||
%define _lto_cflags %{nil}
|
%define _lto_cflags %{nil}
|
||||||
|
|
||||||
|
cp %{SOURCE1} .
|
||||||
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}" LDFLAGS="%{build_ldflags}"
|
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}" LDFLAGS="%{build_ldflags}"
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -70,6 +70,9 @@ cp -p defs.h %{buildroot}%{_includedir}/crash
|
|||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 25 2020 Lianbo Jiang <lijiang@redhat.com> - 7.2.9-1
|
||||||
|
- Update to latest upstream release
|
||||||
|
|
||||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.2.8-5
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.2.8-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- crash-7.1.4/diskdump.c.orig
|
--- crash-7.2.9/diskdump.c.orig
|
||||||
+++ crash-7.1.4/diskdump.c
|
+++ crash-7.2.9/diskdump.c
|
||||||
@@ -23,6 +23,8 @@
|
@@ -23,6 +23,8 @@
|
||||||
* GNU General Public License for more details.
|
* GNU General Public License for more details.
|
||||||
*/
|
*/
|
||||||
@ -9,8 +9,8 @@
|
|||||||
#include "defs.h"
|
#include "defs.h"
|
||||||
#include "diskdump.h"
|
#include "diskdump.h"
|
||||||
#include "xen_dom0.h"
|
#include "xen_dom0.h"
|
||||||
--- crash-7.1.4/Makefile.orig
|
--- crash-7.2.9/Makefile.orig
|
||||||
+++ crash-7.1.4/Makefile
|
+++ crash-7.2.9/Makefile
|
||||||
@@ -228,7 +228,7 @@ all: make_configure
|
@@ -228,7 +228,7 @@ all: make_configure
|
||||||
gdb_merge: force
|
gdb_merge: force
|
||||||
@if [ ! -f ${GDB}/README ]; then \
|
@if [ ! -f ${GDB}/README ]; then \
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (crash-7.2.7.tar.gz) = 14e0c5842b752faa7f2c5667517c9cb214a172cea5b779df5cd38feec6472eb6fd6508346c1c4eec02d4565fd6dade270e851ebf571e778023f32ac7f82836b7
|
SHA512 (crash-7.2.9.tar.gz) = 57b7b7780ad71bad09d962bfb2d5ad729dd167d9aaffd86f7b5467c98f52e8cb2c6ebb317bf1ad285dcb78ffa300b5dd733c63efd7aaa4ef03ddfe076c269984
|
||||||
SHA512 (crash-7.2.8.tar.gz) = 3269760a50b49f25af0e1c43d60432e603036793aa542f8ccfb0b8019376da45afa7c053d3860ae2130b6471f3ac72cff78f1096e9ffa8c6f1d34afb52208e70
|
SHA512 (gdb-7.6.tar.gz) = 02d9c62fa73bcb79138d14c7fc182443f0ca82d4545b4d260b67d3f0074ed75f899a657814a56727e601032a668b0ddd7b48aabd49215fc012eeea6077bca368
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- crash-7.0.7/cmdline.c.orig
|
--- crash-7.2.9/cmdline.c.orig
|
||||||
+++ crash-7.0.7/cmdline.c
|
+++ crash-7.2.9/cmdline.c
|
||||||
@@ -46,7 +46,8 @@ static int verify_args_input_file(char *
|
@@ -46,7 +46,8 @@ static int verify_args_input_file(char *
|
||||||
#define READLINE_LIBRARY
|
#define READLINE_LIBRARY
|
||||||
|
|
||||||
@ -10,8 +10,8 @@
|
|||||||
#include <history.h>
|
#include <history.h>
|
||||||
|
|
||||||
static void readline_init(void);
|
static void readline_init(void);
|
||||||
--- crash-7.0.7/Makefile.orig
|
--- crash-7.2.9/Makefile.orig
|
||||||
+++ crash-7.0.7/Makefile
|
+++ crash-7.2.9/Makefile
|
||||||
@@ -205,7 +205,7 @@ TAR_FILES=${SOURCE_FILES} Makefile ${GPL
|
@@ -205,7 +205,7 @@ TAR_FILES=${SOURCE_FILES} Makefile ${GPL
|
||||||
${EXTENSION_SOURCE_FILES} ${MEMORY_DRIVER_FILES}
|
${EXTENSION_SOURCE_FILES} ${MEMORY_DRIVER_FILES}
|
||||||
CSCOPE_FILES=${SOURCE_FILES}
|
CSCOPE_FILES=${SOURCE_FILES}
|
||||||
|
Loading…
Reference in New Issue
Block a user