Update to latest upstream release
This commit is contained in:
parent
e251f44090
commit
c49e35772b
1
.gitignore
vendored
1
.gitignore
vendored
@ -32,3 +32,4 @@ crash-5.0.6.tar.gz
|
||||
/crash-7.1.5.tar.gz
|
||||
/crash-7.1.6.tar.gz
|
||||
/crash-7.1.7.tar.gz
|
||||
/crash-7.1.8.tar.gz
|
||||
|
11
crash.spec
11
crash.spec
@ -3,8 +3,8 @@
|
||||
#
|
||||
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
||||
Name: crash
|
||||
Version: 7.1.7
|
||||
Release: 3%{?dist}
|
||||
Version: 7.1.8
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3
|
||||
Group: Development/Debuggers
|
||||
Source: http://people.redhat.com/anderson/crash-%{version}.tar.gz
|
||||
@ -18,7 +18,7 @@ Provides: bundled(libiberty)
|
||||
Provides: bundled(gdb) = 7.6
|
||||
Patch0: lzo_snappy.patch
|
||||
Patch1: use_system_readline_v3.patch
|
||||
Patch2: glibc_ps_get_thread_area_workaround.patch
|
||||
Patch2: glibc_ps_get_thread_area_workaround.patch_7_1_8
|
||||
|
||||
%description
|
||||
The core analysis suite is a self-contained tool that can be used to
|
||||
@ -41,7 +41,7 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
|
||||
%setup -n %{name}-%{version} -q
|
||||
%patch0 -p1 -b lzo_snappy.patch
|
||||
%patch1 -p1 -b use_system_readline_v3.patch
|
||||
%patch2 -p1 -b glibc_ps_get_thread_area_workaround.patch
|
||||
%patch2 -p1 -b glibc_ps_get_thread_area_workaround.patch_7_1_8
|
||||
|
||||
%build
|
||||
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}"
|
||||
@ -70,6 +70,9 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/*
|
||||
|
||||
%changelog
|
||||
* Thu Feb 23 2017 Dave Anderson <anderson@redhat.com> - 7.1.8-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 7.1.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
61
glibc_ps_get_thread_area_workaround.patch_7_1_8
Normal file
61
glibc_ps_get_thread_area_workaround.patch_7_1_8
Normal file
@ -0,0 +1,61 @@
|
||||
--- crash-7.1.8/gdb-7.6.patch.orig
|
||||
+++ crash-7.1.8/gdb-7.6.patch
|
||||
@@ -2323,3 +2323,58 @@ diff -up gdb-7.6/opcodes/configure.orig
|
||||
NO_WERROR="-Wno-error"
|
||||
fi
|
||||
|
||||
+--- gdb-7.6/gdb/gdb_proc_service.h.orig
|
||||
++++ gdb-7.6/gdb/gdb_proc_service.h
|
||||
+@@ -115,7 +115,7 @@ extern pid_t ps_getpid (struct ps_procha
|
||||
+ /* Fetch the special per-thread address associated with the given LWP.
|
||||
+ This call is only used on a few platforms (most use a normal register).
|
||||
+ The meaning of the `int' parameter is machine-dependent. */
|
||||
+-extern ps_err_e ps_get_thread_area (const struct ps_prochandle *,
|
||||
++extern ps_err_e ps_get_thread_area (struct ps_prochandle *,
|
||||
+ lwpid_t, int, psaddr_t *);
|
||||
+
|
||||
+
|
||||
+--- gdb-7.6/gdb/amd64-linux-nat.c.orig
|
||||
++++ gdb-7.6/gdb/amd64-linux-nat.c
|
||||
+@@ -493,7 +493,7 @@ amd64_linux_new_fork (struct lwp_info *p
|
||||
+ a request for a thread's local storage address. */
|
||||
+
|
||||
+ ps_err_e
|
||||
+-ps_get_thread_area (const struct ps_prochandle *ph,
|
||||
++ps_get_thread_area (struct ps_prochandle *ph,
|
||||
+ lwpid_t lwpid, int idx, void **base)
|
||||
+ {
|
||||
+ if (gdbarch_bfd_arch_info (target_gdbarch ())->bits_per_word == 32)
|
||||
+--- gdb-7.6/gdb/aarch64-linux-nat.c.orig
|
||||
++++ gdb-7.6/gdb/aarch64-linux-nat.c
|
||||
+@@ -750,7 +750,7 @@ aarch64_linux_new_fork (struct lwp_info
|
||||
+ storage (or its descriptor). */
|
||||
+
|
||||
+ ps_err_e
|
||||
+-ps_get_thread_area (const struct ps_prochandle *ph,
|
||||
++ps_get_thread_area (struct ps_prochandle *ph,
|
||||
+ lwpid_t lwpid, int idx, void **base)
|
||||
+ {
|
||||
+ struct iovec iovec;
|
||||
+--- gdb-7.6/gdb/arm-linux-nat.c.orig
|
||||
++++ gdb-7.6/gdb/arm-linux-nat.c
|
||||
+@@ -613,7 +613,7 @@ supply_fpregset (struct regcache *regcac
|
||||
+ /* Fetch the thread-local storage pointer for libthread_db. */
|
||||
+
|
||||
+ ps_err_e
|
||||
+-ps_get_thread_area (const struct ps_prochandle *ph,
|
||||
++ps_get_thread_area (struct ps_prochandle *ph,
|
||||
+ lwpid_t lwpid, int idx, void **base)
|
||||
+ {
|
||||
+ if (ptrace (PTRACE_GET_THREAD_AREA, lwpid, NULL, base) != 0)
|
||||
+--- gdb-7.6/gdb/i386-linux-nat.c.orig
|
||||
++++ gdb-7.6/gdb/i386-linux-nat.c
|
||||
+@@ -849,7 +849,7 @@ i386_linux_new_fork (struct lwp_info *pa
|
||||
+ storage (or its descriptor). */
|
||||
+
|
||||
+ ps_err_e
|
||||
+-ps_get_thread_area (const struct ps_prochandle *ph,
|
||||
++ps_get_thread_area (struct ps_prochandle *ph,
|
||||
+ lwpid_t lwpid, int idx, void **base)
|
||||
+ {
|
||||
+ /* NOTE: cagney/2003-08-26: The definition of this buffer is found
|
Loading…
Reference in New Issue
Block a user