import crash-7.2.8-3.el8

This commit is contained in:
CentOS Sources 2020-07-28 02:35:34 -04:00 committed by Stepan Oksanichenko
parent 87f77a2c12
commit c37ad908d8
7 changed files with 106 additions and 1153 deletions

View File

@ -1 +1,2 @@
194a82c2cd9d45478559947fe767fd42be5a668f SOURCES/crash-7.2.7.tar.gz
334bce71a69ccf8abefaf8c4bc5eec67c9b43c9e SOURCES/crash-7.2.8.tar.gz
026f4c9e1c8152a2773354551c523acd32d7f00e SOURCES/gdb-7.6.tar.gz

3
.gitignore vendored
View File

@ -1 +1,2 @@
SOURCES/crash-7.2.7.tar.gz
SOURCES/crash-7.2.8.tar.gz
SOURCES/gdb-7.6.tar.gz

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,43 @@
commit b80b16549e24769c7d5fe3a10c4b1a1c4b5161f3
Author: Dave Anderson <anderson@redhat.com>
Date: Mon Mar 23 15:52:11 2020 -0400
Fix for reading compressed kdump dumpfiles from systems with physical
memory located at extraordinarily high addresses. In a system with
a physical address range from 0x602770ecf000 to 0x6027ffffffff, the
crash utility fails during session initialization due to an integer
overflow, ending with the error message "crash: vmlinux and vmcore
do not match!".
(chenjialong@huawei.com)
diff --git crash-7.2.8/diskdump.c crash-7.2.8/diskdump.c
index e88243e616cc..328c932dad5a 100644
--- crash-7.2.8/diskdump.c
+++ crash-7.2.8/diskdump.c
@@ -233,7 +233,7 @@ clean_diskdump_data(void)
}
static inline int
-get_bit(char *map, int byte, int bit)
+get_bit(char *map, unsigned long byte, int bit)
{
return map[byte] & (1<<bit);
}
@@ -694,7 +694,7 @@ restart:
dd->max_mapnr = header->max_mapnr;
/* read memory bitmap */
- bitmap_len = block_size * header->bitmap_blocks;
+ bitmap_len = (off_t)block_size * header->bitmap_blocks;
dd->bitmap_len = bitmap_len;
offset = (off_t)block_size * (1 + header->sub_hdr_size);
@@ -744,7 +744,7 @@ restart:
memcpy(dd->dumpable_bitmap, dd->bitmap, bitmap_len);
dd->data_offset
- = (1 + header->sub_hdr_size + header->bitmap_blocks)
+ = (1UL + header->sub_hdr_size + header->bitmap_blocks)
* header->block_size;
dd->header = header;

View File

@ -1,16 +1,7 @@
--- crash-7.1.5/diskdump.c.orig
+++ crash-7.1.5/diskdump.c
@@ -23,6 +23,8 @@
* GNU General Public License for more details.
*/
+#define LZO
+#define SNAPPY
#include "defs.h"
#include "diskdump.h"
#include "xen_dom0.h"
--- crash-7.1.5/Makefile.orig
+++ crash-7.1.5/Makefile
diff --git crash-7.2.8/Makefile crash-7.2.8/Makefile
index 745541012f43..d0574d8f07d3 100644
--- crash-7.2.8/Makefile
+++ crash-7.2.8/Makefile
@@ -228,7 +228,7 @@ all: make_configure
gdb_merge: force
@if [ ! -f ${GDB}/README ]; then \
@ -20,3 +11,16 @@
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
@rm -f ${PROGRAM}
@if [ ! -f ${GDB}/config.status ]; then \
diff --git crash-7.2.8/diskdump.c crash-7.2.8/diskdump.c
index e88243e616cc..9ccf7039231b 100644
--- crash-7.2.8/diskdump.c
+++ crash-7.2.8/diskdump.c
@@ -23,6 +23,8 @@
* GNU General Public License for more details.
*/
+#define LZO
+#define SNAPPY
#include "defs.h"
#include "diskdump.h"
#include "xen_dom0.h"

View File

@ -1,5 +1,7 @@
--- crash-7.2.3/Makefile.orig
+++ crash-7.2.3/Makefile
diff --git crash-7.2.8/Makefile crash-7.2.8/Makefile
index d0574d8f07d3..9dbb61d0dbc8 100644
--- crash-7.2.8/Makefile
+++ crash-7.2.8/Makefile
@@ -198,7 +198,7 @@ GDB_FLAGS=
# TARGET_CFLAGS will be configured automatically by configure
TARGET_CFLAGS=
@ -7,7 +9,7 @@
-CRASH_CFLAGS=-g -D${TARGET} ${TARGET_CFLAGS} ${GDB_FLAGS} ${CFLAGS}
+CRASH_CFLAGS=-g -D${TARGET} ${TARGET_CFLAGS} ${GDB_FLAGS} ${CFLAGS} ${CPPFLAGS} -fPIE
GPL_FILES=COPYING3
GPL_FILES=
TAR_FILES=${SOURCE_FILES} Makefile ${GPL_FILES} README .rh_rpm_package crash.8 \
@@ -228,7 +228,7 @@ all: make_configure
gdb_merge: force
@ -18,15 +20,16 @@
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
@rm -f ${PROGRAM}
@if [ ! -f ${GDB}/config.status ]; then \
--- crash-7.2.3/configure.c.orig
+++ crash-7.2.3/configure.c
@@ -780,7 +780,8 @@ build_configure(struct supported_gdb_ver
diff --git crash-7.2.8/configure.c crash-7.2.8/configure.c
index 75006e881f5a..06c94d58c56c 100644
--- crash-7.2.8/configure.c
+++ crash-7.2.8/configure.c
@@ -780,7 +780,8 @@ build_configure(struct supported_gdb_version *sp)
fprintf(fp2, "%s\n", sp->GDB);
sprintf(target_data.gdb_version, "%s", &sp->GDB[4]);
} else if (strncmp(buf, "LDFLAGS=", strlen("LDFLAGS=")) == 0) {
- fprintf(fp2, "LDFLAGS=%s\n", ldflags ? ldflags : "");
+ if (ldflags)
+ fprintf(fp2, "LDFLAGS=%s\n", ldflags ? ldflags : "");
+ fprintf(fp2, "LDFLAGS=%s\n", ldflags ? ldflags : "");
} else
fprintf(fp2, "%s", buf);

View File

@ -3,20 +3,22 @@
#
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
Name: crash
Version: 7.2.7
Release: 2%{?dist}
Version: 7.2.8
Release: 3%{?dist}
License: GPLv3
Group: Development/Debuggers
Source: http://people.redhat.com/anderson/crash-%{version}.tar.gz
URL: http://people.redhat.com/anderson
Source0: https://github.com/crash-utility/crash/archive/crash-%{version}.tar.gz
Source1: http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz
URL: https://crash-utility.github.io
ExclusiveOS: Linux
ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x %{arm} aarch64 ppc64le
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot-%(%{__id_u} -n)
BuildRequires: ncurses-devel zlib-devel lzo-devel bison snappy-devel
Requires: binutils
Provides: bundled(gdb) = 7.6
Patch0: lzo_snappy.patch
Patch1: rhel8_build.patch
Patch2: github_105a3e13_to_b5c2359f.patch
Patch2: github_b80b16549e24.patch
%description
The core analysis suite is a self-contained tool that can be used to
@ -39,10 +41,12 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
%setup -n %{name}-%{version} -q
%patch0 -p1 -b lzo_snappy.patch
%patch1 -p1 -b rhel8_build.patch
%patch2 -p1 -b github_105a3e13_to_b5c2359f.patch
%patch2 -p1 -b github_b80b16549e24.patch
%build
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}"
cp %{SOURCE1} .
#make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}"
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}" LDFLAGS="%{build_ldflags}"
%install
rm -rf %{buildroot}
@ -68,6 +72,26 @@ rm -rf %{buildroot}
%{_includedir}/*
%changelog
* Mon Jun 22 2020 Bhupesh Sharma <bhsharma@redhat.com> - 7.2.8-3
- Fix for reading compressed kdump dumpfiles from systems with physical memory
Resolves: rhbz#1819606
* Mon Jun 8 2020 Bhupesh Sharma <bhsharma@redhat.com> - 7.2.8-2
- Remove wget from BuildRequires section
Resolves: rhbz#1838322
* Fri Jun 5 2020 Bhupesh Sharma <bhsharma@redhat.com> - 7.2.8-1
- Rebase to latest upstream release 7.2.8
Resolves: rhbz#1838322
* Mon Feb 3 2020 Dave Anderson <anderson@redhat.com> - 7.2.7-3
- Rebase to github commit 6c1c8ac6
Resolves: rhbz#1738619
- Fix "log -a" option
Resolves: rhbz#1785537
- Fix for ELF kdump vmcores form s390x KASLR kernels
Resolves: rhbz#1786996
* Mon Nov 11 2019 Dave Anderson <anderson@redhat.com> - 7.2.7-2
- Rebase to latest upstream sources
Resolves: rhbz#1738619