Update to latest upstream release
Additional fixes for gcc-4.6 -Werror compile failures for ARM architecture.
This commit is contained in:
parent
4a78f29404
commit
c1b92511d9
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ crash-5.0.6.tar.gz
|
||||
/crash-5.1.2.tar.gz
|
||||
/crash-5.1.5.tar.gz
|
||||
/crash-5.1.7.tar.gz
|
||||
/crash-5.1.8.tar.gz
|
||||
|
35
arm-unused-but-set-variable_v2.patch
Normal file
35
arm-unused-but-set-variable_v2.patch
Normal file
@ -0,0 +1,35 @@
|
||||
--- crash-5.1.8/gdb-7.0.patch.orig
|
||||
+++ crash-5.1.8/gdb-7.0.patch
|
||||
@@ -1986,3 +1986,32 @@
|
||||
stub_sec = stub_entry->stub_sec;
|
||||
|
||||
/* Ensure this stub is attached to the current section being
|
||||
+--- gdb-7.0/bfd/elf32-arm.c.orig
|
||||
++++ gdb-7.0/bfd/elf32-arm.c
|
||||
+@@ -12962,7 +12962,6 @@ arm_map_one_stub (struct bfd_hash_entry
|
||||
+ void * in_arg)
|
||||
+ {
|
||||
+ struct elf32_arm_stub_hash_entry *stub_entry;
|
||||
+- struct bfd_link_info *info;
|
||||
+ asection *stub_sec;
|
||||
+ bfd_vma addr;
|
||||
+ char *stub_name;
|
||||
+@@ -12977,8 +12976,6 @@ arm_map_one_stub (struct bfd_hash_entry
|
||||
+ stub_entry = (struct elf32_arm_stub_hash_entry *) gen_entry;
|
||||
+ osi = (output_arch_syminfo *) in_arg;
|
||||
+
|
||||
+- info = osi->info;
|
||||
+-
|
||||
+ stub_sec = stub_entry->stub_sec;
|
||||
+
|
||||
+ /* Ensure this stub is attached to the current section being
|
||||
+--- gdb-7.0/bfd/cpu-arm.c.orig
|
||||
++++ gdb-7.0/bfd/cpu-arm.c
|
||||
+@@ -262,6 +262,7 @@ arm_check_note (bfd *abfd,
|
||||
+ }
|
||||
+
|
||||
+ /* FIXME: We should probably check the type as well. */
|
||||
++ (void) type;
|
||||
+
|
||||
+ if (description_return != NULL)
|
||||
+ * description_return = descr;
|
14
crash.spec
14
crash.spec
@ -3,8 +3,8 @@
|
||||
#
|
||||
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
||||
Name: crash
|
||||
Version: 5.1.7
|
||||
Release: 2%{?dist}
|
||||
Version: 5.1.8
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: Development/Debuggers
|
||||
Source: http://people.redhat.com/anderson/crash-%{version}.tar.gz
|
||||
@ -14,8 +14,7 @@ ExclusiveArch: %{ix86} ia64 x86_64 ppc64 s390 s390x %{arm}
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot-%(%{__id_u} -n)
|
||||
BuildRequires: ncurses-devel zlib-devel
|
||||
Requires: binutils
|
||||
Patch0: ppc64-unused-but-set-variable.patch
|
||||
Patch1: arm-unused-but-set-variable.patch
|
||||
Patch0: arm-unused-but-set-variable_v2.patch
|
||||
|
||||
%description
|
||||
The core analysis suite is a self-contained tool that can be used to
|
||||
@ -36,8 +35,7 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
|
||||
|
||||
%prep
|
||||
%setup -n %{name}-%{version} -q
|
||||
%patch0 -p1 -b ppc64-unused-but-set-variable.patch
|
||||
%patch1 -p1 -b arm-unused-but-set-variable.patch
|
||||
%patch0 -p1 -b arm-unused-but-set-variable_v2.patch
|
||||
|
||||
%build
|
||||
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}"
|
||||
@ -66,6 +64,10 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/*
|
||||
|
||||
%changelog
|
||||
* Tue Sep 20 2011 Dave Anderson <anderson@redhat.com> - 5.1.8-1
|
||||
- Update to latest upstream release
|
||||
- Additional fixes for gcc-4.6 -Werror compile failures for ARM architecture.
|
||||
|
||||
* Thu Sep 1 2011 Dave Anderson <anderson@redhat.com> - 5.1.7-2
|
||||
- Fixes for gcc-4.6 -Werror compile failures for ARM architecture.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user