Enable ZSTD feature
Release: crash-8.0.0-3 Signed-off-by: Lianbo Jiang <lijiang@redhat.com>
This commit is contained in:
parent
120df7f566
commit
7f59063f3e
@ -1,8 +1,6 @@
|
|||||||
diff --git crash-8.0.0/Makefile crash-8.0.0/Makefile
|
--- crash-8.0.0/Makefile.orig
|
||||||
index d0574d8f07d3..9dbb61d0dbc8 100644
|
|
||||||
--- crash-8.0.0/Makefile
|
|
||||||
+++ crash-8.0.0/Makefile
|
+++ crash-8.0.0/Makefile
|
||||||
@@ -198,7 +198,7 @@ GDB_FLAGS=
|
@@ -203,7 +203,7 @@ GDB_FLAGS=
|
||||||
# TARGET_CFLAGS will be configured automatically by configure
|
# TARGET_CFLAGS will be configured automatically by configure
|
||||||
TARGET_CFLAGS=
|
TARGET_CFLAGS=
|
||||||
|
|
||||||
@ -11,20 +9,18 @@ index d0574d8f07d3..9dbb61d0dbc8 100644
|
|||||||
|
|
||||||
GPL_FILES=
|
GPL_FILES=
|
||||||
TAR_FILES=${SOURCE_FILES} Makefile ${GPL_FILES} README .rh_rpm_package crash.8 \
|
TAR_FILES=${SOURCE_FILES} Makefile ${GPL_FILES} README .rh_rpm_package crash.8 \
|
||||||
@@ -228,7 +228,7 @@ all: make_configure
|
@@ -233,7 +233,7 @@ all: make_configure
|
||||||
gdb_merge: force
|
gdb_merge: force
|
||||||
@if [ ! -f ${GDB}/README ]; then \
|
@if [ ! -f ${GDB}/README ]; then \
|
||||||
make --no-print-directory gdb_unzip; fi
|
make --no-print-directory gdb_unzip; fi
|
||||||
- @echo "${LDFLAGS} -lz -llzo2 -lsnappy -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
- @echo "${LDFLAGS} -lz -llzo2 -lsnappy -lzstd -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
||||||
+ @echo "${LDFLAGS} -lz -llzo2 -lsnappy -ldl -rdynamic -Wl,-z,now -fPIE" > ${GDB}/gdb/mergelibs
|
+ @echo "${LDFLAGS} -lz -llzo2 -lsnappy -lzstd -ldl -rdynamic -Wl,-z,now -fPIE" > ${GDB}/gdb/mergelibs
|
||||||
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
||||||
@rm -f ${PROGRAM}
|
@rm -f ${PROGRAM}
|
||||||
@if [ ! -f ${GDB}/config.status ]; then \
|
@if [ ! -f ${GDB}/config.status ]; then \
|
||||||
diff --git crash-8.0.0/configure.c crash-8.0.0/configure.c
|
--- crash-8.0.0/configure.c.orig
|
||||||
index 75006e881f5a..06c94d58c56c 100644
|
|
||||||
--- crash-8.0.0/configure.c
|
|
||||||
+++ crash-8.0.0/configure.c
|
+++ crash-8.0.0/configure.c
|
||||||
@@ -780,7 +780,8 @@ build_configure(struct supported_gdb_version *sp)
|
@@ -810,7 +810,8 @@ build_configure(struct supported_gdb_version *sp)
|
||||||
fprintf(fp2, "%s\n", sp->GDB);
|
fprintf(fp2, "%s\n", sp->GDB);
|
||||||
sprintf(target_data.gdb_version, "%s", &sp->GDB[4]);
|
sprintf(target_data.gdb_version, "%s", &sp->GDB[4]);
|
||||||
} else if (strncmp(buf, "LDFLAGS=", strlen("LDFLAGS=")) == 0) {
|
} else if (strncmp(buf, "LDFLAGS=", strlen("LDFLAGS=")) == 0) {
|
||||||
@ -33,3 +29,5 @@ index 75006e881f5a..06c94d58c56c 100644
|
|||||||
+ fprintf(fp2, "LDFLAGS=%s\n", ldflags ? ldflags : "");
|
+ fprintf(fp2, "LDFLAGS=%s\n", ldflags ? ldflags : "");
|
||||||
} else
|
} else
|
||||||
fprintf(fp2, "%s", buf);
|
fprintf(fp2, "%s", buf);
|
||||||
|
|
||||||
|
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
||||||
Name: crash
|
Name: crash
|
||||||
Version: 8.0.0
|
Version: 8.0.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv3
|
License: GPLv3
|
||||||
Source0: https://github.com/crash-utility/crash/archive/crash-%{version}.tar.gz
|
Source0: https://github.com/crash-utility/crash/archive/crash-%{version}.tar.gz
|
||||||
Source1: http://ftp.gnu.org/gnu/gdb/gdb-10.2.tar.gz
|
Source1: http://ftp.gnu.org/gnu/gdb/gdb-10.2.tar.gz
|
||||||
@ -17,7 +17,7 @@ BuildRequires: make
|
|||||||
Requires: binutils
|
Requires: binutils
|
||||||
Provides: bundled(libiberty)
|
Provides: bundled(libiberty)
|
||||||
Provides: bundled(gdb) = 10.2
|
Provides: bundled(gdb) = 10.2
|
||||||
Patch0: lzo_snappy.patch
|
Patch0: lzo_snappy_zstd.patch
|
||||||
Patch1: crash-8.0.0_build.patch
|
Patch1: crash-8.0.0_build.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -38,7 +38,7 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -n %{name}-%{version} -q
|
%setup -n %{name}-%{version} -q
|
||||||
%patch0 -p1 -b lzo_snappy.patch
|
%patch0 -p1 -b lzo_snappy_zstd.patch
|
||||||
%patch1 -p1 -b crash-8.0.0_build.patch
|
%patch1 -p1 -b crash-8.0.0_build.patch
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -65,6 +65,9 @@ cp -p defs.h %{buildroot}%{_includedir}/crash
|
|||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 06 2021 Lianbo Jiang <lijiang@redhat.com> - 8.0.0-3
|
||||||
|
- Enable ZSTD feature
|
||||||
|
|
||||||
* Fri Nov 26 2021 Lianbo Jiang <lijiang@redhat.com> - 8.0.0-2
|
* Fri Nov 26 2021 Lianbo Jiang <lijiang@redhat.com> - 8.0.0-2
|
||||||
- Enable LTO and Hardened package
|
- Enable LTO and Hardened package
|
||||||
|
|
||||||
|
@ -1,22 +1,23 @@
|
|||||||
|
--- crash-8.0.0/Makefile.orig
|
||||||
|
+++ crash-8.0.0/Makefile
|
||||||
|
@@ -233,7 +233,7 @@ all: make_configure
|
||||||
|
gdb_merge: force
|
||||||
|
@if [ ! -f ${GDB}/README ]; then \
|
||||||
|
make --no-print-directory gdb_unzip; fi
|
||||||
|
- @echo "${LDFLAGS} -lz -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
||||||
|
+ @echo "${LDFLAGS} -lz -llzo2 -lsnappy -lzstd -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
||||||
|
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
||||||
|
@rm -f ${PROGRAM}
|
||||||
|
@if [ ! -f ${GDB}/config.status ]; then \
|
||||||
--- crash-8.0.0/diskdump.c.orig
|
--- crash-8.0.0/diskdump.c.orig
|
||||||
+++ crash-8.0.0/diskdump.c
|
+++ crash-8.0.0/diskdump.c
|
||||||
@@ -23,6 +23,8 @@
|
@@ -23,6 +23,9 @@
|
||||||
* GNU General Public License for more details.
|
* GNU General Public License for more details.
|
||||||
*/
|
*/
|
||||||
|
|
||||||
+#define LZO
|
+#define LZO
|
||||||
+#define SNAPPY
|
+#define SNAPPY
|
||||||
|
+#define ZSTD
|
||||||
#include "defs.h"
|
#include "defs.h"
|
||||||
#include "diskdump.h"
|
#include "diskdump.h"
|
||||||
#include "xen_dom0.h"
|
#include "xen_dom0.h"
|
||||||
--- crash-8.0.0/Makefile.orig
|
|
||||||
+++ crash-8.0.0/Makefile
|
|
||||||
@@ -228,7 +228,7 @@ all: make_configure
|
|
||||||
gdb_merge: force
|
|
||||||
@if [ ! -f ${GDB}/README ]; then \
|
|
||||||
make --no-print-directory gdb_unzip; fi
|
|
||||||
- @echo "${LDFLAGS} -lz -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
|
||||||
+ @echo "${LDFLAGS} -lz -llzo2 -lsnappy -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
|
||||||
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
|
||||||
@rm -f ${PROGRAM}
|
|
||||||
@if [ ! -f ${GDB}/config.status ]; then \
|
|
Loading…
Reference in New Issue
Block a user