Update to latest upstream release

This commit is contained in:
Dave Anderson 2016-04-28 10:50:49 -04:00
parent fe43ac8b40
commit 724c5fe93a
4 changed files with 41 additions and 5 deletions

1
.gitignore vendored
View File

@ -29,3 +29,4 @@ crash-5.0.6.tar.gz
/crash-7.1.2.tar.gz
/crash-7.1.3.tar.gz
/crash-7.1.4.tar.gz
/crash-7.1.5.tar.gz

View File

@ -3,8 +3,8 @@
#
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
Name: crash
Version: 7.1.4
Release: 2%{?dist}
Version: 7.1.5
Release: 1%{?dist}
License: GPLv3
Group: Development/Debuggers
Source: http://people.redhat.com/anderson/crash-%{version}.tar.gz
@ -16,7 +16,7 @@ BuildRequires: ncurses-devel zlib-devel lzo-devel snappy-devel bison readline-de
Requires: binutils
Provides: bundled(libiberty)
Patch0: lzo_snappy.patch
Patch1: use_system_readline_v2.patch
Patch1: use_system_readline_v3.patch
%description
The core analysis suite is a self-contained tool that can be used to
@ -38,7 +38,7 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
%prep
%setup -n %{name}-%{version} -q
%patch0 -p1 -b lzo_snappy.patch
%patch1 -p1 -b use_system_readline_v2.patch
%patch1 -p1 -b use_system_readline_v3.patch
%build
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}"
@ -67,6 +67,9 @@ rm -rf %{buildroot}
%{_includedir}/*
%changelog
* Thu Apr 28 2016 Dave Anderson <anderson@redhat.com> - 7.1.5-1
- Update to latest upstream release
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 7.1.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

View File

@ -1 +1 @@
4f7a00fd09c1316da8903e8f99188d98 crash-7.1.4.tar.gz
3e73ee9d2de04c2fd25ea1bb7f712a66 crash-7.1.5.tar.gz

View File

@ -0,0 +1,32 @@
--- crash-7.0.7/cmdline.c.orig
+++ crash-7.0.7/cmdline.c
@@ -44,7 +44,8 @@ static int verify_args_input_file(char *
#define READLINE_LIBRARY
#include <readline.h>
-#include <rldefs.h>
+#define vi_mode 0
+#define emacs_mode 1
#include <history.h>
static void readline_init(void);
--- crash-7.0.7/Makefile.orig
+++ crash-7.0.7/Makefile
@@ -205,7 +205,7 @@ TAR_FILES=${SOURCE_FILES} Makefile ${GPL
${EXTENSION_SOURCE_FILES} ${MEMORY_DRIVER_FILES}
CSCOPE_FILES=${SOURCE_FILES}
-READLINE_DIRECTORY=./${GDB}/readline
+READLINE_DIRECTORY=/usr/include/readline
BFD_DIRECTORY=./${GDB}/bfd
GDB_INCLUDE_DIRECTORY=./${GDB}/include
@@ -233,7 +233,7 @@ gdb_merge: force
@rm -f ${PROGRAM}
@if [ ! -f ${GDB}/config.status ]; then \
(cd ${GDB}; ./configure ${GDB_CONF_FLAGS} --with-separate-debug-dir=/usr/lib/debug \
- --with-bugurl="" --with-expat=no --with-python=no --disable-sim; \
+ --with-bugurl="" --with-expat=no --with-python=no --disable-sim --with-system-readline; \
make --no-print-directory CRASH_TARGET=${TARGET}; echo ${TARGET} > crash.target) \
else make --no-print-directory rebuild; fi
@if [ ! -f ${PROGRAM} ]; then \