- Update to latest upstream release
- Build with lzo and snappy compression capability
This commit is contained in:
parent
2c305846d7
commit
597ceadcbc
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@ crash-5.0.6.tar.gz
|
||||
/crash-6.1.4.tar.gz
|
||||
/crash-6.1.6.tar.gz
|
||||
/crash-7.0.1.tar.gz
|
||||
/crash-7.0.2.tar.gz
|
||||
|
12
crash.spec
12
crash.spec
@ -3,8 +3,8 @@
|
||||
#
|
||||
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
|
||||
Name: crash
|
||||
Version: 7.0.1
|
||||
Release: 2%{?dist}
|
||||
Version: 7.0.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3
|
||||
Group: Development/Debuggers
|
||||
Source: http://people.redhat.com/anderson/crash-%{version}.tar.gz
|
||||
@ -12,8 +12,9 @@ URL: http://people.redhat.com/anderson
|
||||
ExclusiveOS: Linux
|
||||
ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x %{arm} aarch64
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot-%(%{__id_u} -n)
|
||||
BuildRequires: ncurses-devel zlib-devel bison
|
||||
BuildRequires: ncurses-devel zlib-devel lzo-devel snappy-devel bison
|
||||
Requires: binutils
|
||||
Patch0: lzo_snappy.patch
|
||||
|
||||
%description
|
||||
The core analysis suite is a self-contained tool that can be used to
|
||||
@ -34,6 +35,7 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
|
||||
|
||||
%prep
|
||||
%setup -n %{name}-%{version} -q
|
||||
%patch0 -p1 -b lzo_snappy.patch
|
||||
|
||||
%build
|
||||
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}"
|
||||
@ -62,6 +64,10 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/*
|
||||
|
||||
%changelog
|
||||
* Wed Sep 04 2013 Dave Anderson <anderson@redhat.com> - 7.0.2-1
|
||||
- Update to latest upstream release
|
||||
- Build with lzo and snappy compression capability
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
22
lzo_snappy.patch
Normal file
22
lzo_snappy.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- crash-7.0.2/diskdump.c.orig
|
||||
+++ crash-7.0.2/diskdump.c
|
||||
@@ -23,6 +23,8 @@
|
||||
* GNU General Public License for more details.
|
||||
*/
|
||||
|
||||
+#define LZO
|
||||
+#define SNAPPY
|
||||
#include "defs.h"
|
||||
#include "diskdump.h"
|
||||
|
||||
--- crash-7.0.2/Makefile.orig
|
||||
+++ crash-7.0.2/Makefile
|
||||
@@ -223,7 +223,7 @@ all: make_configure
|
||||
gdb_merge: force
|
||||
@if [ ! -f ${GDB}/README ]; then \
|
||||
make --no-print-directory gdb_unzip; fi
|
||||
- @echo "${LDFLAGS} -lz -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
||||
+ @echo "${LDFLAGS} -lz -llzo2 -lsnappy -ldl -rdynamic" > ${GDB}/gdb/mergelibs
|
||||
@echo "../../${PROGRAM} ../../${PROGRAM}lib.a" > ${GDB}/gdb/mergeobj
|
||||
@rm -f ${PROGRAM}
|
||||
@if [ ! -f ${GDB}/config.status ]; then \
|
Loading…
Reference in New Issue
Block a user