Updated crash.patch such that <asm/segment.h> is not #include'd by
lkcd_x86_trace.c; also for BZ #191719
This commit is contained in:
parent
ef16efa829
commit
437ab56e19
126
crash.patch
126
crash.patch
@ -1,4 +1,4 @@
|
||||
--- crash/extensions/Makefile.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/extensions/Makefile.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/extensions/Makefile 2005-11-08 11:38:21.000000000 -0500
|
||||
@@ -0,0 +1,41 @@
|
||||
+#
|
||||
@ -42,7 +42,7 @@
|
||||
+dminfo.so: ../defs.h dminfo.c
|
||||
+ gcc -nostartfiles -shared -rdynamic -o dminfo.so dminfo.c -fPIC -D$(TARGET)
|
||||
+
|
||||
--- crash/extensions/echo.c.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/extensions/echo.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/extensions/echo.c 2005-11-10 16:12:50.000000000 -0500
|
||||
@@ -0,0 +1,105 @@
|
||||
+/* echo.c - simple example of a crash extension
|
||||
@ -150,7 +150,7 @@
|
||||
+};
|
||||
+
|
||||
+
|
||||
--- crash/extensions/dminfo.c.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/extensions/dminfo.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/extensions/dminfo.c 2005-11-10 16:12:50.000000000 -0500
|
||||
@@ -0,0 +1,1531 @@
|
||||
+/* dminfo.c - crash extension module for device-mapper analysis
|
||||
@ -1684,7 +1684,7 @@
|
||||
+{
|
||||
+ return 0;
|
||||
+}
|
||||
--- crash/gdb-6.1/gdb/ppc-linux-tdep.c.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/gdb-6.1/gdb/ppc-linux-tdep.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/gdb-6.1/gdb/ppc-linux-tdep.c 2005-11-04 17:37:54.000000000 -0500
|
||||
@@ -0,0 +1,1116 @@
|
||||
+/* Target-dependent code for GDB, the GNU debugger.
|
||||
@ -2803,7 +2803,7 @@
|
||||
+ ppc_linux_init_abi);
|
||||
+ add_core_fns (&ppc_linux_regset_core_fns);
|
||||
+}
|
||||
--- crash/main.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/main.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/main.c 2006-04-26 15:41:04.000000000 -0400
|
||||
@@ -35,11 +35,13 @@
|
||||
{"no_data_debug", 0, 0, 0},
|
||||
@ -3025,7 +3025,7 @@
|
||||
else if (pc->writemem == write_memory_device)
|
||||
fprintf(fp, " writemem: write_memory_device()\n");
|
||||
else
|
||||
--- crash/tools.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/tools.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/tools.c 2006-04-26 15:45:34.000000000 -0400
|
||||
@@ -2004,6 +2004,10 @@
|
||||
pc->flags &= ~(DUMPFILE_TYPES);
|
||||
@ -3123,7 +3123,7 @@
|
||||
+ fprintf(fp, "\r \r");
|
||||
+ fflush(fp);
|
||||
+}
|
||||
--- crash/memory.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/memory.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/memory.c 2006-05-01 11:35:50.000000000 -0400
|
||||
@@ -45,6 +45,8 @@
|
||||
ulong *addrlist;
|
||||
@ -5294,7 +5294,7 @@
|
||||
+ }
|
||||
+ }
|
||||
+}
|
||||
--- crash/filesys.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/filesys.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/filesys.c 2006-04-28 11:24:32.000000000 -0400
|
||||
@@ -1,8 +1,8 @@
|
||||
/* filesys.c - core analysis suite
|
||||
@ -5494,7 +5494,7 @@
|
||||
FREEBUF(files_struct_buf);
|
||||
}
|
||||
|
||||
--- crash/help.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/help.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/help.c 2006-03-23 14:25:56.000000000 -0500
|
||||
@@ -1,8 +1,8 @@
|
||||
/* help.c - core analysis suite
|
||||
@ -5760,7 +5760,7 @@
|
||||
"Copyright (C) 1999, 2002 Silicon Graphics, Inc.",
|
||||
"Copyright (C) 1999, 2000, 2001, 2002 Mission Critical Linux, Inc.",
|
||||
"This program is free software, covered by the GNU General Public License,",
|
||||
--- crash/task.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/task.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/task.c 2006-04-28 11:25:53.000000000 -0400
|
||||
@@ -27,6 +27,7 @@
|
||||
static void refresh_pidhash_task_table(void);
|
||||
@ -6596,7 +6596,7 @@
|
||||
sigset = task_signal(tc->task);
|
||||
if (!tt->last_task_read)
|
||||
return;
|
||||
--- crash/kernel.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/kernel.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/kernel.c 2006-04-26 16:42:12.000000000 -0400
|
||||
@@ -20,7 +20,7 @@
|
||||
|
||||
@ -7156,7 +7156,7 @@
|
||||
+ return(XEN_MFN_NOT_FOUND);
|
||||
+}
|
||||
+
|
||||
--- crash/gdb_interface.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/gdb_interface.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/gdb_interface.c 2006-04-11 17:25:48.000000000 -0400
|
||||
@@ -31,9 +31,6 @@
|
||||
{
|
||||
@ -7188,7 +7188,7 @@
|
||||
gdb_interface(req);
|
||||
if (!(req->flags & GNU_COMMAND_FAILED))
|
||||
goto retry;
|
||||
--- crash/configure.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/configure.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/configure.c 2006-03-23 15:44:46.000000000 -0500
|
||||
@@ -1128,7 +1128,7 @@
|
||||
printf("License: GPL\n");
|
||||
@ -7199,7 +7199,7 @@
|
||||
printf("Distribution: Linux 2.2 or greater\n");
|
||||
printf("Vendor: Red Hat, Inc.\n");
|
||||
printf("Packager: Dave Anderson <anderson@redhat.com>\n");
|
||||
--- crash/net.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/net.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/net.c 2006-05-11 11:17:01.000000000 -0400
|
||||
@@ -50,6 +50,7 @@
|
||||
#define STRUCT_NET_DEVICE (0x4)
|
||||
@ -7556,7 +7556,7 @@
|
||||
break;
|
||||
}
|
||||
break;
|
||||
--- crash/dev.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/dev.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/dev.c 2005-11-23 11:09:08.000000000 -0500
|
||||
@@ -91,13 +91,13 @@
|
||||
switch(c)
|
||||
@ -7574,7 +7574,7 @@
|
||||
option_not_supported(c);
|
||||
do_pci();
|
||||
return;
|
||||
--- crash/alpha.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/alpha.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/alpha.c 2005-11-04 17:37:53.000000000 -0500
|
||||
@@ -1858,8 +1858,6 @@
|
||||
fprintf(fp, " flags: %lx (", machdep->flags);
|
||||
@ -7585,7 +7585,7 @@
|
||||
fprintf(fp, ")\n");
|
||||
fprintf(fp, " kvbase: %lx\n", machdep->kvbase);
|
||||
fprintf(fp, " identity_map_base: %lx\n", machdep->identity_map_base);
|
||||
--- crash/x86.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/x86.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/x86.c 2006-04-26 15:53:35.000000000 -0400
|
||||
@@ -685,6 +685,7 @@
|
||||
bt->debug ||
|
||||
@ -8550,7 +8550,7 @@
|
||||
+ return machdep->get_stack_frame(bt, eip, esp);
|
||||
+}
|
||||
#endif /* X86 */
|
||||
--- crash/ppc.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/ppc.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/ppc.c 2006-04-11 15:22:52.000000000 -0400
|
||||
@@ -138,6 +138,8 @@
|
||||
machdep->hz = HZ;
|
||||
@ -8580,7 +8580,7 @@
|
||||
fprintf(fp, " machspec: %lx\n", (ulong)machdep->machspec);
|
||||
}
|
||||
|
||||
--- crash/ia64.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/ia64.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/ia64.c 2006-04-26 15:56:33.000000000 -0400
|
||||
@@ -1,8 +1,8 @@
|
||||
/* ia64.c - core analysis suite
|
||||
@ -8642,7 +8642,7 @@
|
||||
|
||||
if (DUMPFILE() && ia64_in_init_stack(SWITCH_STACK_ADDR(CURRENT_TASK())))
|
||||
machdep->flags |= INIT;
|
||||
--- crash/s390.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/s390.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/s390.c 2005-11-04 17:37:53.000000000 -0500
|
||||
@@ -178,8 +178,6 @@
|
||||
fprintf(fp, " flags: %lx (", machdep->flags);
|
||||
@ -8653,7 +8653,7 @@
|
||||
fprintf(fp, ")\n");
|
||||
|
||||
fprintf(fp, " kvbase: %lx\n", machdep->kvbase);
|
||||
--- crash/s390x.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/s390x.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/s390x.c 2005-11-04 17:37:53.000000000 -0500
|
||||
@@ -193,8 +193,6 @@
|
||||
fprintf(fp, " flags: %lx (", machdep->flags);
|
||||
@ -8664,7 +8664,7 @@
|
||||
fprintf(fp, ")\n");
|
||||
|
||||
fprintf(fp, " kvbase: %lx\n", machdep->kvbase);
|
||||
--- crash/ppc64.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/ppc64.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/ppc64.c 2006-04-26 15:57:36.000000000 -0400
|
||||
@@ -47,6 +47,9 @@
|
||||
static char * ppc64_check_eframe(struct ppc64_pt_regs *);
|
||||
@ -9225,7 +9225,7 @@
|
||||
+ machdep->machspec->last_level4_read = 0;
|
||||
+}
|
||||
#endif /* PPC64 */
|
||||
--- crash/x86_64.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/x86_64.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/x86_64.c 2006-04-26 16:12:41.000000000 -0400
|
||||
@@ -18,7 +18,10 @@
|
||||
#ifdef X86_64
|
||||
@ -10848,7 +10848,7 @@
|
||||
+ }
|
||||
+}
|
||||
#endif /* X86_64 */
|
||||
--- crash/extensions.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/extensions.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/extensions.c 2005-11-10 09:47:46.000000000 -0500
|
||||
@@ -18,9 +18,6 @@
|
||||
#include "defs.h"
|
||||
@ -10878,7 +10878,7 @@
|
||||
unload_extension(char *lib)
|
||||
{
|
||||
struct extension_table *ext;
|
||||
--- crash/va_server.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/va_server.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/va_server.c 2006-03-22 08:55:34.000000000 -0500
|
||||
@@ -57,13 +57,15 @@
|
||||
|
||||
@ -10897,7 +10897,7 @@
|
||||
if(read_map(crash_file)) {
|
||||
if(va_server_init_v1(crash_file, start, end, stride))
|
||||
return -1;
|
||||
--- crash/symbols.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/symbols.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/symbols.c 2006-05-10 14:14:28.000000000 -0400
|
||||
@@ -1,8 +1,8 @@
|
||||
/* symbols.c - core analysis suite
|
||||
@ -11052,7 +11052,7 @@
|
||||
|
||||
fprintf(fp, "\n array_table:\n");
|
||||
/*
|
||||
--- crash/cmdline.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/cmdline.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/cmdline.c 2005-11-18 10:49:59.000000000 -0500
|
||||
@@ -71,14 +71,17 @@
|
||||
* 4. from a terminal.
|
||||
@ -11085,7 +11085,7 @@
|
||||
pc->sigint_cnt = 0;
|
||||
pc->redirect = 0;
|
||||
pc->pipe_command[0] = NULLCHAR;
|
||||
--- crash/lkcd_common.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/lkcd_common.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/lkcd_common.c 2005-11-10 15:24:16.000000000 -0500
|
||||
@@ -53,6 +53,8 @@
|
||||
|
||||
@ -11225,7 +11225,7 @@
|
||||
|
||||
if ((lkcd->flags & LKCD_VALID) && (page > lkcd->total_pages))
|
||||
lkcd->total_pages = page;
|
||||
--- crash/lkcd_v7.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/lkcd_v7.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/lkcd_v7.c 2005-11-10 15:21:50.000000000 -0500
|
||||
@@ -89,7 +89,11 @@
|
||||
ifd = 0;
|
||||
@ -11240,7 +11240,7 @@
|
||||
dump_index_size = (lkcd->memory_pages * sizeof(off_t));
|
||||
lkcd->page_offsets = 0;
|
||||
strcpy(dumpfile_index_name, dumpfile);
|
||||
--- crash/lkcd_v8.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/lkcd_v8.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/lkcd_v8.c 2005-12-15 08:59:52.000000000 -0500
|
||||
@@ -26,6 +26,7 @@
|
||||
// static dump_header_asm_t dump_header_asm_v8 = { 0 };
|
||||
@ -11301,8 +11301,8 @@
|
||||
set_mb_benchmark((granularity * (i+1))/lkcd->page_size);
|
||||
}
|
||||
}
|
||||
--- crash/lkcd_x86_trace.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
+++ crash/lkcd_x86_trace.c 2006-04-11 15:33:35.000000000 -0400
|
||||
--- crash/lkcd_x86_trace.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/lkcd_x86_trace.c 2006-05-15 16:24:51.000000000 -0400
|
||||
@@ -47,11 +47,13 @@
|
||||
static int setup_trace_rec(kaddr_t, kaddr_t, int, trace_t *);
|
||||
static int valid_ra(kaddr_t);
|
||||
@ -11326,7 +11326,17 @@
|
||||
{ NULL, NULL, 0, 0, 0, 0, 0 },
|
||||
};
|
||||
|
||||
@@ -1153,6 +1155,9 @@
|
||||
@@ -1118,7 +1120,9 @@
|
||||
}
|
||||
|
||||
#include <asm/ptrace.h>
|
||||
+#ifndef REDHAT
|
||||
#include <asm/segment.h>
|
||||
+#endif
|
||||
#define KERNEL_EFRAME 0
|
||||
#define USER_EFRAME 1
|
||||
#define KERNEL_EFRAME_SZ 13 /* no ss and esp */
|
||||
@@ -1153,6 +1157,9 @@
|
||||
else if (((regs->xcs & 0xffff) == 0x60) &&
|
||||
((regs->xds & 0xffff) == 0x7b))
|
||||
return KERNEL_EFRAME;
|
||||
@ -11336,7 +11346,7 @@
|
||||
#endif
|
||||
else if (((regs->xcs & 0xffff) == __USER_CS) &&
|
||||
((regs->xds & 0xffff) == __USER_DS))
|
||||
@@ -1206,6 +1211,93 @@
|
||||
@@ -1206,6 +1213,93 @@
|
||||
} \
|
||||
}
|
||||
#endif
|
||||
@ -11430,7 +11440,7 @@
|
||||
/*
|
||||
* find_trace()
|
||||
*
|
||||
@@ -1253,6 +1345,7 @@
|
||||
@@ -1253,6 +1347,7 @@
|
||||
int flag;
|
||||
int interrupted_system_call = FALSE;
|
||||
struct bt_info *bt = trace->bt;
|
||||
@ -11438,7 +11448,7 @@
|
||||
#endif
|
||||
sbp = trace->stack[curstkidx].ptr;
|
||||
sbase = trace->stack[curstkidx].addr;
|
||||
@@ -1503,12 +1596,13 @@
|
||||
@@ -1503,12 +1598,13 @@
|
||||
return(trace->nframes);
|
||||
#ifdef REDHAT
|
||||
} else if (strstr(func_name, "error_code")
|
||||
@ -11453,7 +11463,7 @@
|
||||
|
||||
bp = sp + (KERNEL_EFRAME_SZ-1)*4;
|
||||
asp = (uaddr_t*)((uaddr_t)sbp + (STACK_SIZE -
|
||||
@@ -1572,6 +1666,22 @@
|
||||
@@ -1572,6 +1668,22 @@
|
||||
}
|
||||
}
|
||||
|
||||
@ -11476,7 +11486,7 @@
|
||||
/* Make sure our next frame pointer is valid (in the stack).
|
||||
*/
|
||||
if ((bp < sbase) || (bp >= saddr)) {
|
||||
@@ -1684,8 +1794,15 @@
|
||||
@@ -1684,8 +1796,15 @@
|
||||
(bt->flags & (BT_HARDIRQ|BT_SOFTIRQ)))
|
||||
return;
|
||||
|
||||
@ -11494,7 +11504,7 @@
|
||||
frmp->level + 1 : frmp->level,
|
||||
fp ? (ulong)fp : trace->bt->stkptr,
|
||||
(ulong)frmp->pc, frmp->funcname, frmp, ofp);
|
||||
@@ -1708,6 +1825,10 @@
|
||||
@@ -1708,6 +1827,10 @@
|
||||
#endif
|
||||
if (frmp->flag & EX_FRAME) {
|
||||
pt = (struct pt_regs *)frmp->asp;
|
||||
@ -11505,7 +11515,7 @@
|
||||
print_eframe(ofp, pt);
|
||||
}
|
||||
#ifdef REDHAT
|
||||
@@ -1789,6 +1910,114 @@
|
||||
@@ -1789,6 +1912,114 @@
|
||||
if (kt->flags & RA_SEEK)
|
||||
bt->flags |= BT_SPECULATE;
|
||||
|
||||
@ -11620,7 +11630,7 @@
|
||||
if (!verify_back_trace(bt) && !recoverable(bt, ofp) &&
|
||||
!BT_REFERENCE_CHECK(bt))
|
||||
error(INFO, "cannot resolve stack trace:\n");
|
||||
@@ -2192,11 +2421,12 @@
|
||||
@@ -2192,11 +2423,12 @@
|
||||
else
|
||||
buf[0] = NULLCHAR;
|
||||
|
||||
@ -11635,7 +11645,7 @@
|
||||
strlen(buf) ? buf : "", eip);
|
||||
|
||||
if (bt->flags & BT_LINE_NUMBERS) {
|
||||
@@ -2325,6 +2555,25 @@
|
||||
@@ -2325,6 +2557,25 @@
|
||||
}
|
||||
|
||||
/*
|
||||
@ -11661,7 +11671,7 @@
|
||||
* Cache 2k starting from the passed-in text address. This sits on top
|
||||
* of the instrbuf 256-byte cache, but we don't want to extend its size
|
||||
* because we can run off the end of a module segment -- if this routine
|
||||
--- crash/netdump.c.orig 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/netdump.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/netdump.c 2006-02-14 14:36:21.000000000 -0500
|
||||
@@ -22,12 +22,12 @@
|
||||
physaddr_t phys_end;
|
||||
@ -12660,7 +12670,7 @@
|
||||
+{
|
||||
+ return netdump_memory_dump(fp);
|
||||
+}
|
||||
--- crash/diskdump.c.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/diskdump.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/diskdump.c 2006-03-23 14:29:25.000000000 -0500
|
||||
@@ -1,16 +1,16 @@
|
||||
/*
|
||||
@ -13184,7 +13194,7 @@
|
||||
}
|
||||
|
||||
/*
|
||||
--- crash/xendump.c.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/xendump.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/xendump.c 2006-04-26 16:17:27.000000000 -0400
|
||||
@@ -0,0 +1,1167 @@
|
||||
+/*
|
||||
@ -14354,7 +14364,7 @@
|
||||
+ }
|
||||
+ }
|
||||
+}
|
||||
--- crash/unwind.c.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/unwind.c.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/unwind.c 2005-11-23 09:37:52.000000000 -0500
|
||||
@@ -1397,9 +1397,22 @@
|
||||
req = &request;
|
||||
@ -14382,7 +14392,7 @@
|
||||
machdep->machspec->unw_tables_offset =
|
||||
req->member_offset/BITS_PER_BYTE;
|
||||
|
||||
--- crash/defs.h.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/defs.h.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/defs.h 2006-05-01 11:49:13.000000000 -0400
|
||||
@@ -1,8 +1,8 @@
|
||||
/* defs.h - core analysis suite
|
||||
@ -15097,7 +15107,7 @@
|
||||
|
||||
#define LKCD_DUMP_VERSION_NUMBER_MASK (0xf)
|
||||
#define LKCD_DUMP_RAW (0x1) /* DUMP_[DH_]RAW */
|
||||
--- crash/netdump.h.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/netdump.h.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/netdump.h 2005-11-04 17:37:53.000000000 -0500
|
||||
@@ -24,3 +24,14 @@
|
||||
|
||||
@ -15114,7 +15124,7 @@
|
||||
+#endif
|
||||
+
|
||||
+#endif /* NOTDEF */
|
||||
--- crash/diskdump.h.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/diskdump.h.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/diskdump.h 2005-11-30 15:15:00.000000000 -0500
|
||||
@@ -3,6 +3,8 @@
|
||||
*
|
||||
@ -15187,7 +15197,7 @@
|
||||
+#define PAGE_VALID (0x1) /* flags */
|
||||
+#define DISKDUMP_VALID_PAGE(flags) ((flags) & PAGE_VALID)
|
||||
+
|
||||
--- crash/xendump.h.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/xendump.h.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/xendump.h 2006-04-26 15:58:59.000000000 -0400
|
||||
@@ -0,0 +1,97 @@
|
||||
+/*
|
||||
@ -15287,7 +15297,7 @@
|
||||
+
|
||||
+#define MFN_NOT_FOUND (-1)
|
||||
+#define PFN_NOT_FOUND (-1)
|
||||
--- crash/lkcd_dump_v5.h.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/lkcd_dump_v5.h.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/lkcd_dump_v5.h 2006-03-22 08:45:35.000000000 -0500
|
||||
@@ -35,7 +35,7 @@
|
||||
#ifndef _DUMP_H
|
||||
@ -15298,7 +15308,7 @@
|
||||
|
||||
/* define TRUE and FALSE for use in our dump modules */
|
||||
#ifndef FALSE
|
||||
--- crash/lkcd_dump_v7.h.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/lkcd_dump_v7.h.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/lkcd_dump_v7.h 2006-03-22 08:45:57.000000000 -0500
|
||||
@@ -35,7 +35,7 @@
|
||||
#ifndef _DUMP_H
|
||||
@ -15309,8 +15319,8 @@
|
||||
|
||||
/* define TRUE and FALSE for use in our dump modules */
|
||||
#ifndef FALSE
|
||||
--- crash/Makefile.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
+++ crash/Makefile 2006-05-11 11:25:03.000000000 -0400
|
||||
--- crash/Makefile.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/Makefile 2006-05-15 16:26:27.000000000 -0400
|
||||
@@ -3,8 +3,8 @@
|
||||
# Copyright (C) 1999, 2000, 2001, 2002 Mission Critical Linux, Inc.
|
||||
# www.missioncriticallinux.com, info@missioncriticallinux.com
|
||||
@ -15486,7 +15496,7 @@
|
||||
+
|
||||
+do_extensions:
|
||||
+ @(cd extensions; make -i OBJECTS="$(EXTENSION_OBJECT_FILES)" TARGET=$(TARGET))
|
||||
--- crash/gdb-6.1.patch.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
--- crash/gdb-6.1.patch.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/gdb-6.1.patch 2006-01-03 13:36:25.000000000 -0500
|
||||
@@ -0,0 +1,11 @@
|
||||
+--- gdb-6.1/bfd/coff-alpha.c.orig
|
||||
@ -15500,8 +15510,8 @@
|
||||
+ }
|
||||
+
|
||||
+ if (lita_sec_data->gp != 0)
|
||||
--- crash/README.orig 2006-05-11 11:25:04.000000000 -0400
|
||||
+++ crash/README 2006-05-11 11:25:02.000000000 -0400
|
||||
--- crash/README.orig 2006-05-15 16:26:27.000000000 -0400
|
||||
+++ crash/README 2006-05-15 16:26:25.000000000 -0400
|
||||
@@ -69,7 +69,7 @@
|
||||
After the kernel is re-compiled, the uncompressed "vmlinux" kernel
|
||||
that is created in the top-level kernel build directory must be saved.
|
||||
@ -15533,7 +15543,7 @@
|
||||
DUMPFILE: /dev/mem
|
||||
CPUS: 1
|
||||
- DATE: Wed Jul 13 13:26:00 2005
|
||||
+ DATE: Thu May 11 11:25:02 2006
|
||||
+ DATE: Mon May 15 16:26:25 2006
|
||||
UPTIME: 10 days, 22:55:18
|
||||
LOAD AVERAGE: 0.08, 0.03, 0.01
|
||||
TASKS: 42
|
||||
|
@ -4,7 +4,7 @@
|
||||
Summary: crash utility for live systems; netdump, diskdump, LKCD or mcore dumpfiles
|
||||
Name: crash
|
||||
Version: 4.0
|
||||
Release: 2.26.1
|
||||
Release: 2.26.2
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
Source: %{name}-%{version}.tar.gz
|
||||
@ -45,6 +45,10 @@ rm -rf %{buildroot}
|
||||
%doc README
|
||||
|
||||
%changelog
|
||||
* Mon May 15 2006 Dave Anderson <anderson@redhat.com> - 4.0-2.26.2
|
||||
- Updated crash.patch such that <asm/segment.h> is not #include'd
|
||||
by lkcd_x86_trace.c; also for BZ #191719
|
||||
|
||||
* Mon May 15 2006 Dave Anderson <anderson@redhat.com> - 4.0-2.26.1
|
||||
- Updated crash.patch to bring it up to 4.0-2.26, which should
|
||||
address BZ #191719 - "crash fails to build in mock"
|
||||
|
Loading…
Reference in New Issue
Block a user