- Update to latest upstream release

- Fix Fedora_21_Mass_Rebuild FTBFS (BZ #1106090)
This commit is contained in:
Dave Anderson 2014-06-11 11:10:06 -04:00
parent 79483db943
commit 2388dd965f
4 changed files with 42 additions and 7 deletions

1
.gitignore vendored
View File

@ -21,3 +21,4 @@ crash-5.0.6.tar.gz
/crash-7.0.3.tar.gz
/crash-7.0.4.tar.gz
/crash-7.0.5.tar.gz
/crash-7.0.7.tar.gz

View File

@ -3,8 +3,8 @@
#
Summary: Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles
Name: crash
Version: 7.0.5
Release: 2%{?dist}
Version: 7.0.7
Release: 1%{?dist}
License: GPLv3
Group: Development/Debuggers
Source: http://people.redhat.com/anderson/crash-%{version}.tar.gz
@ -16,8 +16,7 @@ BuildRequires: ncurses-devel zlib-devel lzo-devel snappy-devel bison readline-de
Requires: binutils
Provides: bundled(libiberty)
Patch0: lzo_snappy.patch
Patch1: use_system_readline.patch
Patch2: crash_log.patch
Patch1: use_system_readline_v2.patch
%description
The core analysis suite is a self-contained tool that can be used to
@ -39,8 +38,7 @@ offered by Mission Critical Linux, or the LKCD kernel patch.
%prep
%setup -n %{name}-%{version} -q
%patch0 -p1 -b lzo_snappy.patch
%patch1 -p1 -b use_system_readline.patch
%patch2 -p1 -b crash_log.patch
%patch1 -p1 -b use_system_readline_v2.patch
%build
make RPMPKG="%{version}-%{release}" CFLAGS="%{optflags}"
@ -69,6 +67,10 @@ rm -rf %{buildroot}
%{_includedir}/*
%changelog
* Wed Jun 11 2014 Dave Anderson <anderson@redhat.com> - 7.0.7-1
- Update to latest upstream release
- Fix Fedora_21_Mass_Rebuild FTBFS (BZ #1106090)
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.0.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

View File

@ -1 +1 @@
3fba47055539e61ba3fb4d6e8a0e84b0 crash-7.0.5.tar.gz
a671c6aead4ce89a3123ccf0e04c6693 crash-7.0.7.tar.gz

View File

@ -0,0 +1,32 @@
--- crash-7.0.7/cmdline.c.orig
+++ crash-7.0.7/cmdline.c
@@ -42,7 +42,8 @@ static int verify_args_input_file(char *
#define READLINE_LIBRARY
#include <readline.h>
-#include <rldefs.h>
+#define vi_mode 0
+#define emacs_mode 1
#include <history.h>
static void readline_init(void);
--- crash-7.0.7/Makefile.orig
+++ crash-7.0.7/Makefile
@@ -200,7 +200,7 @@ TAR_FILES=${SOURCE_FILES} Makefile ${GPL
${EXTENSION_SOURCE_FILES} ${MEMORY_DRIVER_FILES}
CSCOPE_FILES=${SOURCE_FILES}
-READLINE_DIRECTORY=./${GDB}/readline
+READLINE_DIRECTORY=/usr/include/readline
BFD_DIRECTORY=./${GDB}/bfd
GDB_INCLUDE_DIRECTORY=./${GDB}/include
@@ -228,7 +228,7 @@ gdb_merge: force
@rm -f ${PROGRAM}
@if [ ! -f ${GDB}/config.status ]; then \
(cd ${GDB}; ./configure ${GDB_CONF_FLAGS} --with-separate-debug-dir=/usr/lib/debug \
- --with-bugurl="" --with-expat=no --with-python=no; \
+ --with-bugurl="" --with-expat=no --with-python=no --with-system-readline; \
make --no-print-directory CRASH_TARGET=${TARGET}; echo ${TARGET} > crash.target) \
else make --no-print-directory rebuild; fi
@if [ ! -f ${PROGRAM} ]; then \