s390/s390x build requires removal of pt_regs reference in lkcd asm struct

This commit is contained in:
anderson 2006-08-07 17:51:51 +00:00
parent 7e82cdd1f0
commit 1173b73efb

View File

@ -1,4 +1,4 @@
--- crash/extensions/Makefile.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/extensions/Makefile.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/extensions/Makefile 2005-11-08 11:38:21.000000000 -0500 +++ crash/extensions/Makefile 2005-11-08 11:38:21.000000000 -0500
@@ -0,0 +1,41 @@ @@ -0,0 +1,41 @@
+# +#
@ -42,7 +42,7 @@
+dminfo.so: ../defs.h dminfo.c +dminfo.so: ../defs.h dminfo.c
+ gcc -nostartfiles -shared -rdynamic -o dminfo.so dminfo.c -fPIC -D$(TARGET) + gcc -nostartfiles -shared -rdynamic -o dminfo.so dminfo.c -fPIC -D$(TARGET)
+ +
--- crash/extensions/echo.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/extensions/echo.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/extensions/echo.c 2006-05-16 15:43:05.000000000 -0400 +++ crash/extensions/echo.c 2006-05-16 15:43:05.000000000 -0400
@@ -0,0 +1,105 @@ @@ -0,0 +1,105 @@
+/* echo.c - simple example of a crash extension +/* echo.c - simple example of a crash extension
@ -150,7 +150,7 @@
+}; +};
+ +
+ +
--- crash/extensions/dminfo.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/extensions/dminfo.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/extensions/dminfo.c 2006-05-16 15:43:05.000000000 -0400 +++ crash/extensions/dminfo.c 2006-05-16 15:43:05.000000000 -0400
@@ -0,0 +1,1531 @@ @@ -0,0 +1,1531 @@
+/* dminfo.c - crash extension module for device-mapper analysis +/* dminfo.c - crash extension module for device-mapper analysis
@ -1684,7 +1684,7 @@
+{ +{
+ return 0; + return 0;
+} +}
--- crash/gdb-6.1/gdb/ppc-linux-tdep.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/gdb-6.1/gdb/ppc-linux-tdep.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/gdb-6.1/gdb/ppc-linux-tdep.c 2005-11-04 17:37:54.000000000 -0500 +++ crash/gdb-6.1/gdb/ppc-linux-tdep.c 2005-11-04 17:37:54.000000000 -0500
@@ -0,0 +1,1116 @@ @@ -0,0 +1,1116 @@
+/* Target-dependent code for GDB, the GNU debugger. +/* Target-dependent code for GDB, the GNU debugger.
@ -2803,7 +2803,7 @@
+ ppc_linux_init_abi); + ppc_linux_init_abi);
+ add_core_fns (&ppc_linux_regset_core_fns); + add_core_fns (&ppc_linux_regset_core_fns);
+} +}
--- crash/main.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/main.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/main.c 2006-08-03 16:58:32.000000000 -0400 +++ crash/main.c 2006-08-03 16:58:32.000000000 -0400
@@ -35,11 +35,15 @@ @@ -35,11 +35,15 @@
{"no_data_debug", 0, 0, 0}, {"no_data_debug", 0, 0, 0},
@ -3065,7 +3065,7 @@
else if (pc->writemem == write_memory_device) else if (pc->writemem == write_memory_device)
fprintf(fp, " writemem: write_memory_device()\n"); fprintf(fp, " writemem: write_memory_device()\n");
else else
--- crash/tools.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/tools.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/tools.c 2006-07-06 16:21:55.000000000 -0400 +++ crash/tools.c 2006-07-06 16:21:55.000000000 -0400
@@ -2004,6 +2004,10 @@ @@ -2004,6 +2004,10 @@
pc->flags &= ~(DUMPFILE_TYPES); pc->flags &= ~(DUMPFILE_TYPES);
@ -3183,7 +3183,7 @@
+ +
+ return ((c2 == '\0') && (c1 == '/') && (*p1 == '\0')) ? 0 : c1 - c2; + return ((c2 == '\0') && (c1 == '/') && (*p1 == '\0')) ? 0 : c1 - c2;
+} +}
--- crash/memory.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/memory.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/memory.c 2006-08-02 10:32:08.000000000 -0400 +++ crash/memory.c 2006-08-02 10:32:08.000000000 -0400
@@ -45,6 +45,8 @@ @@ -45,6 +45,8 @@
ulong *addrlist; ulong *addrlist;
@ -5670,7 +5670,7 @@
+ } + }
+ } + }
+} +}
--- crash/filesys.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/filesys.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/filesys.c 2006-07-06 16:40:52.000000000 -0400 +++ crash/filesys.c 2006-07-06 16:40:52.000000000 -0400
@@ -1,8 +1,8 @@ @@ -1,8 +1,8 @@
/* filesys.c - core analysis suite /* filesys.c - core analysis suite
@ -5920,7 +5920,7 @@
* get_pathname() fills in a pathname string for an ending dentry * get_pathname() fills in a pathname string for an ending dentry
* See __d_path() in the kernel for help fixing problems. * See __d_path() in the kernel for help fixing problems.
*/ */
--- crash/help.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/help.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/help.c 2006-08-03 16:59:00.000000000 -0400 +++ crash/help.c 2006-08-03 16:59:00.000000000 -0400
@@ -1,8 +1,8 @@ @@ -1,8 +1,8 @@
/* help.c - core analysis suite /* help.c - core analysis suite
@ -6253,7 +6253,7 @@
"Copyright (C) 1999, 2002 Silicon Graphics, Inc.", "Copyright (C) 1999, 2002 Silicon Graphics, Inc.",
"Copyright (C) 1999, 2000, 2001, 2002 Mission Critical Linux, Inc.", "Copyright (C) 1999, 2000, 2001, 2002 Mission Critical Linux, Inc.",
"This program is free software, covered by the GNU General Public License,", "This program is free software, covered by the GNU General Public License,",
--- crash/task.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/task.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/task.c 2006-06-26 09:13:03.000000000 -0400 +++ crash/task.c 2006-06-26 09:13:03.000000000 -0400
@@ -27,6 +27,7 @@ @@ -27,6 +27,7 @@
static void refresh_pidhash_task_table(void); static void refresh_pidhash_task_table(void);
@ -7172,7 +7172,7 @@
sigset = task_signal(tc->task); sigset = task_signal(tc->task);
if (!tt->last_task_read) if (!tt->last_task_read)
return; return;
--- crash/kernel.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/kernel.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/kernel.c 2006-08-03 17:25:27.000000000 -0400 +++ crash/kernel.c 2006-08-03 17:25:27.000000000 -0400
@@ -20,7 +20,7 @@ @@ -20,7 +20,7 @@
@ -8157,7 +8157,7 @@
+ break; + break;
+ } + }
} }
--- crash/gdb_interface.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/gdb_interface.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/gdb_interface.c 2006-04-11 17:25:48.000000000 -0400 +++ crash/gdb_interface.c 2006-04-11 17:25:48.000000000 -0400
@@ -31,9 +31,6 @@ @@ -31,9 +31,6 @@
{ {
@ -8189,7 +8189,7 @@
gdb_interface(req); gdb_interface(req);
if (!(req->flags & GNU_COMMAND_FAILED)) if (!(req->flags & GNU_COMMAND_FAILED))
goto retry; goto retry;
--- crash/configure.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/configure.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/configure.c 2006-03-23 15:44:46.000000000 -0500 +++ crash/configure.c 2006-03-23 15:44:46.000000000 -0500
@@ -1128,7 +1128,7 @@ @@ -1128,7 +1128,7 @@
printf("License: GPL\n"); printf("License: GPL\n");
@ -8200,7 +8200,7 @@
printf("Distribution: Linux 2.2 or greater\n"); printf("Distribution: Linux 2.2 or greater\n");
printf("Vendor: Red Hat, Inc.\n"); printf("Vendor: Red Hat, Inc.\n");
printf("Packager: Dave Anderson <anderson@redhat.com>\n"); printf("Packager: Dave Anderson <anderson@redhat.com>\n");
--- crash/net.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/net.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/net.c 2006-05-11 11:17:01.000000000 -0400 +++ crash/net.c 2006-05-11 11:17:01.000000000 -0400
@@ -50,6 +50,7 @@ @@ -50,6 +50,7 @@
#define STRUCT_NET_DEVICE (0x4) #define STRUCT_NET_DEVICE (0x4)
@ -8557,7 +8557,7 @@
break; break;
} }
break; break;
--- crash/dev.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/dev.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/dev.c 2005-11-23 11:09:08.000000000 -0500 +++ crash/dev.c 2005-11-23 11:09:08.000000000 -0500
@@ -91,13 +91,13 @@ @@ -91,13 +91,13 @@
switch(c) switch(c)
@ -8575,7 +8575,7 @@
option_not_supported(c); option_not_supported(c);
do_pci(); do_pci();
return; return;
--- crash/alpha.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/alpha.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/alpha.c 2006-08-02 10:30:58.000000000 -0400 +++ crash/alpha.c 2006-08-02 10:30:58.000000000 -0400
@@ -186,7 +186,8 @@ @@ -186,7 +186,8 @@
"irq_desc", NULL, 0); "irq_desc", NULL, 0);
@ -8596,7 +8596,7 @@
fprintf(fp, ")\n"); fprintf(fp, ")\n");
fprintf(fp, " kvbase: %lx\n", machdep->kvbase); fprintf(fp, " kvbase: %lx\n", machdep->kvbase);
fprintf(fp, " identity_map_base: %lx\n", machdep->identity_map_base); fprintf(fp, " identity_map_base: %lx\n", machdep->identity_map_base);
--- crash/x86.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/x86.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/x86.c 2006-08-03 11:15:55.000000000 -0400 +++ crash/x86.c 2006-08-03 11:15:55.000000000 -0400
@@ -176,6 +176,7 @@ @@ -176,6 +176,7 @@
static void db_symbol_values(db_sym_t, char **, db_expr_t *); static void db_symbol_values(db_sym_t, char **, db_expr_t *);
@ -10543,7 +10543,7 @@
+ return machdep->get_stack_frame(bt, eip, esp); + return machdep->get_stack_frame(bt, eip, esp);
+} +}
#endif /* X86 */ #endif /* X86 */
--- crash/ppc.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/ppc.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/ppc.c 2006-08-02 10:31:13.000000000 -0400 +++ crash/ppc.c 2006-08-02 10:31:13.000000000 -0400
@@ -135,9 +135,13 @@ @@ -135,9 +135,13 @@
"irq_desc", NULL, 0); "irq_desc", NULL, 0);
@ -10581,7 +10581,7 @@
fprintf(fp, " machspec: %lx\n", (ulong)machdep->machspec); fprintf(fp, " machspec: %lx\n", (ulong)machdep->machspec);
} }
--- crash/ia64.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/ia64.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/ia64.c 2006-08-03 14:28:37.000000000 -0400 +++ crash/ia64.c 2006-08-03 14:28:37.000000000 -0400
@@ -1,8 +1,8 @@ @@ -1,8 +1,8 @@
/* ia64.c - core analysis suite /* ia64.c - core analysis suite
@ -11105,7 +11105,7 @@
if (DUMPFILE() && ia64_in_init_stack(SWITCH_STACK_ADDR(CURRENT_TASK()))) if (DUMPFILE() && ia64_in_init_stack(SWITCH_STACK_ADDR(CURRENT_TASK())))
machdep->flags |= INIT; machdep->flags |= INIT;
--- crash/s390.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/s390.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/s390.c 2006-08-02 10:31:22.000000000 -0400 +++ crash/s390.c 2006-08-02 10:31:22.000000000 -0400
@@ -158,7 +158,8 @@ @@ -158,7 +158,8 @@
machdep->nr_irqs = 0; /* TBD */ machdep->nr_irqs = 0; /* TBD */
@ -11137,7 +11137,7 @@
} }
for(j=0; j< frame_size; j+=4){ for(j=0; j< frame_size; j+=4){
if(j % 16 == 0){ if(j % 16 == 0){
--- crash/s390x.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/s390x.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/s390x.c 2006-08-02 10:31:24.000000000 -0400 +++ crash/s390x.c 2006-08-02 10:31:24.000000000 -0400
@@ -173,7 +173,8 @@ @@ -173,7 +173,8 @@
machdep->nr_irqs = 0; /* TBD */ machdep->nr_irqs = 0; /* TBD */
@ -11169,7 +11169,7 @@
} }
for(j=0; j< frame_size; j+=4){ for(j=0; j< frame_size; j+=4){
if(j % 16 == 0){ if(j % 16 == 0){
--- crash/ppc64.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/ppc64.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/ppc64.c 2006-08-02 10:31:29.000000000 -0400 +++ crash/ppc64.c 2006-08-02 10:31:29.000000000 -0400
@@ -47,6 +47,9 @@ @@ -47,6 +47,9 @@
static char * ppc64_check_eframe(struct ppc64_pt_regs *); static char * ppc64_check_eframe(struct ppc64_pt_regs *);
@ -11746,7 +11746,7 @@
+ machdep->machspec->last_level4_read = 0; + machdep->machspec->last_level4_read = 0;
+} +}
#endif /* PPC64 */ #endif /* PPC64 */
--- crash/x86_64.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/x86_64.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/x86_64.c 2006-08-02 10:31:34.000000000 -0400 +++ crash/x86_64.c 2006-08-02 10:31:34.000000000 -0400
@@ -18,7 +18,10 @@ @@ -18,7 +18,10 @@
#ifdef X86_64 #ifdef X86_64
@ -13698,7 +13698,7 @@
+ } + }
+} +}
#endif /* X86_64 */ #endif /* X86_64 */
--- crash/extensions.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/extensions.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/extensions.c 2005-11-10 09:47:46.000000000 -0500 +++ crash/extensions.c 2005-11-10 09:47:46.000000000 -0500
@@ -18,9 +18,6 @@ @@ -18,9 +18,6 @@
#include "defs.h" #include "defs.h"
@ -13728,7 +13728,7 @@
unload_extension(char *lib) unload_extension(char *lib)
{ {
struct extension_table *ext; struct extension_table *ext;
--- crash/va_server.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/va_server.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/va_server.c 2006-03-22 08:55:34.000000000 -0500 +++ crash/va_server.c 2006-03-22 08:55:34.000000000 -0500
@@ -57,13 +57,15 @@ @@ -57,13 +57,15 @@
@ -13747,7 +13747,7 @@
if(read_map(crash_file)) { if(read_map(crash_file)) {
if(va_server_init_v1(crash_file, start, end, stride)) if(va_server_init_v1(crash_file, start, end, stride))
return -1; return -1;
--- crash/symbols.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/symbols.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/symbols.c 2006-08-03 14:43:54.000000000 -0400 +++ crash/symbols.c 2006-08-03 14:43:54.000000000 -0400
@@ -1,8 +1,8 @@ @@ -1,8 +1,8 @@
/* symbols.c - core analysis suite /* symbols.c - core analysis suite
@ -13911,7 +13911,7 @@
fprintf(fp, "\n array_table:\n"); fprintf(fp, "\n array_table:\n");
/* /*
--- crash/cmdline.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/cmdline.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/cmdline.c 2006-07-10 10:59:57.000000000 -0400 +++ crash/cmdline.c 2006-07-10 10:59:57.000000000 -0400
@@ -71,14 +71,17 @@ @@ -71,14 +71,17 @@
* 4. from a terminal. * 4. from a terminal.
@ -13951,7 +13951,7 @@
restore_gdb_sanity(); restore_gdb_sanity();
--- crash/lkcd_common.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/lkcd_common.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/lkcd_common.c 2006-06-15 10:34:53.000000000 -0400 +++ crash/lkcd_common.c 2006-06-15 10:34:53.000000000 -0400
@@ -53,6 +53,8 @@ @@ -53,6 +53,8 @@
@ -14131,7 +14131,7 @@
if ((lkcd->flags & LKCD_VALID) && (page > lkcd->total_pages)) if ((lkcd->flags & LKCD_VALID) && (page > lkcd->total_pages))
lkcd->total_pages = page; lkcd->total_pages = page;
--- crash/lkcd_v7.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/lkcd_v7.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/lkcd_v7.c 2005-11-10 15:21:50.000000000 -0500 +++ crash/lkcd_v7.c 2005-11-10 15:21:50.000000000 -0500
@@ -89,7 +89,11 @@ @@ -89,7 +89,11 @@
ifd = 0; ifd = 0;
@ -14146,7 +14146,7 @@
dump_index_size = (lkcd->memory_pages * sizeof(off_t)); dump_index_size = (lkcd->memory_pages * sizeof(off_t));
lkcd->page_offsets = 0; lkcd->page_offsets = 0;
strcpy(dumpfile_index_name, dumpfile); strcpy(dumpfile_index_name, dumpfile);
--- crash/lkcd_v8.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/lkcd_v8.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/lkcd_v8.c 2005-12-15 08:59:52.000000000 -0500 +++ crash/lkcd_v8.c 2005-12-15 08:59:52.000000000 -0500
@@ -26,6 +26,7 @@ @@ -26,6 +26,7 @@
// static dump_header_asm_t dump_header_asm_v8 = { 0 }; // static dump_header_asm_t dump_header_asm_v8 = { 0 };
@ -14207,7 +14207,7 @@
set_mb_benchmark((granularity * (i+1))/lkcd->page_size); set_mb_benchmark((granularity * (i+1))/lkcd->page_size);
} }
} }
--- crash/s390_dump.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/s390_dump.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/s390_dump.c 2006-05-15 17:15:56.000000000 -0400 +++ crash/s390_dump.c 2006-05-15 17:15:56.000000000 -0400
@@ -16,7 +16,7 @@ @@ -16,7 +16,7 @@
* GNU General Public License for more details. * GNU General Public License for more details.
@ -14233,7 +14233,7 @@
} }
int int
--- crash/lkcd_x86_trace.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/lkcd_x86_trace.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/lkcd_x86_trace.c 2006-05-15 16:28:35.000000000 -0400 +++ crash/lkcd_x86_trace.c 2006-05-15 16:28:35.000000000 -0400
@@ -47,11 +47,13 @@ @@ -47,11 +47,13 @@
static int setup_trace_rec(kaddr_t, kaddr_t, int, trace_t *); static int setup_trace_rec(kaddr_t, kaddr_t, int, trace_t *);
@ -14603,7 +14603,7 @@
* Cache 2k starting from the passed-in text address. This sits on top * Cache 2k starting from the passed-in text address. This sits on top
* of the instrbuf 256-byte cache, but we don't want to extend its size * of the instrbuf 256-byte cache, but we don't want to extend its size
* because we can run off the end of a module segment -- if this routine * because we can run off the end of a module segment -- if this routine
--- crash/netdump.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/netdump.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/netdump.c 2006-07-10 11:01:03.000000000 -0400 +++ crash/netdump.c 2006-07-10 11:01:03.000000000 -0400
@@ -22,12 +22,12 @@ @@ -22,12 +22,12 @@
physaddr_t phys_end; physaddr_t phys_end;
@ -15778,7 +15778,7 @@
+ +
+ return paddr; + return paddr;
+} +}
--- crash/diskdump.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/diskdump.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/diskdump.c 2006-03-23 14:29:25.000000000 -0500 +++ crash/diskdump.c 2006-03-23 14:29:25.000000000 -0500
@@ -1,16 +1,16 @@ @@ -1,16 +1,16 @@
/* /*
@ -16302,7 +16302,7 @@
} }
/* /*
--- crash/xendump.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/xendump.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/xendump.c 2006-07-11 09:36:03.000000000 -0400 +++ crash/xendump.c 2006-07-11 09:36:03.000000000 -0400
@@ -0,0 +1,1170 @@ @@ -0,0 +1,1170 @@
+/* +/*
@ -17475,7 +17475,7 @@
+ } + }
+ } + }
+} +}
--- crash/unwind.c.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/unwind.c.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/unwind.c 2005-11-23 09:37:52.000000000 -0500 +++ crash/unwind.c 2005-11-23 09:37:52.000000000 -0500
@@ -1397,9 +1397,22 @@ @@ -1397,9 +1397,22 @@
req = &request; req = &request;
@ -17503,7 +17503,7 @@
machdep->machspec->unw_tables_offset = machdep->machspec->unw_tables_offset =
req->member_offset/BITS_PER_BYTE; req->member_offset/BITS_PER_BYTE;
--- crash/defs.h.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/defs.h.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/defs.h 2006-08-03 17:25:55.000000000 -0400 +++ crash/defs.h 2006-08-03 17:25:55.000000000 -0400
@@ -1,8 +1,8 @@ @@ -1,8 +1,8 @@
/* defs.h - core analysis suite /* defs.h - core analysis suite
@ -18473,7 +18473,7 @@
#define LKCD_DUMP_VERSION_NUMBER_MASK (0xf) #define LKCD_DUMP_VERSION_NUMBER_MASK (0xf)
#define LKCD_DUMP_RAW (0x1) /* DUMP_[DH_]RAW */ #define LKCD_DUMP_RAW (0x1) /* DUMP_[DH_]RAW */
--- crash/vas_crash.h.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/vas_crash.h.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/vas_crash.h 2006-05-15 16:50:28.000000000 -0400 +++ crash/vas_crash.h 2006-05-15 16:50:28.000000000 -0400
@@ -19,7 +19,7 @@ @@ -19,7 +19,7 @@
*/ */
@ -18484,7 +18484,7 @@
void save_core(void); void save_core(void);
--- crash/netdump.h.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/netdump.h.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/netdump.h 2006-06-28 14:16:16.000000000 -0400 +++ crash/netdump.h 2006-06-28 14:16:16.000000000 -0400
@@ -24,3 +24,37 @@ @@ -24,3 +24,37 @@
@ -18524,7 +18524,7 @@
+#define KDUMP_MFN_LIST (0x4) +#define KDUMP_MFN_LIST (0x4)
+ +
+#define P2M_FAILURE ((physaddr_t)(0xffffffffffffffffLL)) +#define P2M_FAILURE ((physaddr_t)(0xffffffffffffffffLL))
--- crash/diskdump.h.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/diskdump.h.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/diskdump.h 2005-11-30 15:15:00.000000000 -0500 +++ crash/diskdump.h 2005-11-30 15:15:00.000000000 -0500
@@ -3,6 +3,8 @@ @@ -3,6 +3,8 @@
* *
@ -18597,7 +18597,7 @@
+#define PAGE_VALID (0x1) /* flags */ +#define PAGE_VALID (0x1) /* flags */
+#define DISKDUMP_VALID_PAGE(flags) ((flags) & PAGE_VALID) +#define DISKDUMP_VALID_PAGE(flags) ((flags) & PAGE_VALID)
+ +
--- crash/xendump.h.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/xendump.h.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/xendump.h 2006-06-09 11:26:09.000000000 -0400 +++ crash/xendump.h 2006-06-09 11:26:09.000000000 -0400
@@ -0,0 +1,97 @@ @@ -0,0 +1,97 @@
+/* +/*
@ -18697,7 +18697,22 @@
+ +
+#define MFN_NOT_FOUND (-1) +#define MFN_NOT_FOUND (-1)
+#define PFN_NOT_FOUND (-1) +#define PFN_NOT_FOUND (-1)
--- crash/lkcd_dump_v5.h.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/lkcd_vmdump_v1.h.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/lkcd_vmdump_v1.h 2006-08-07 13:50:37.000000000 -0400
@@ -114,8 +114,12 @@
/* the dump registers */
#ifndef IA64
+#ifndef S390
+#ifndef S390X
struct pt_regs dh_regs;
#endif
+#endif
+#endif
/* the address of the current task */
struct task_struct *dh_current_task;
--- crash/lkcd_dump_v5.h.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/lkcd_dump_v5.h 2006-03-22 08:45:35.000000000 -0500 +++ crash/lkcd_dump_v5.h 2006-03-22 08:45:35.000000000 -0500
@@ -35,7 +35,7 @@ @@ -35,7 +35,7 @@
#ifndef _DUMP_H #ifndef _DUMP_H
@ -18708,7 +18723,7 @@
/* define TRUE and FALSE for use in our dump modules */ /* define TRUE and FALSE for use in our dump modules */
#ifndef FALSE #ifndef FALSE
--- crash/lkcd_dump_v7.h.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/lkcd_dump_v7.h.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/lkcd_dump_v7.h 2006-03-22 08:45:57.000000000 -0500 +++ crash/lkcd_dump_v7.h 2006-03-22 08:45:57.000000000 -0500
@@ -35,7 +35,7 @@ @@ -35,7 +35,7 @@
#ifndef _DUMP_H #ifndef _DUMP_H
@ -18719,8 +18734,8 @@
/* define TRUE and FALSE for use in our dump modules */ /* define TRUE and FALSE for use in our dump modules */
#ifndef FALSE #ifndef FALSE
--- crash/Makefile.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/Makefile.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/Makefile 2006-08-07 11:31:15.000000000 -0400 +++ crash/Makefile 2006-08-07 13:51:46.000000000 -0400
@@ -3,8 +3,8 @@ @@ -3,8 +3,8 @@
# Copyright (C) 1999, 2000, 2001, 2002 Mission Critical Linux, Inc. # Copyright (C) 1999, 2000, 2001, 2002 Mission Critical Linux, Inc.
# www.missioncriticallinux.com, info@missioncriticallinux.com # www.missioncriticallinux.com, info@missioncriticallinux.com
@ -18896,7 +18911,7 @@
+ +
+do_extensions: +do_extensions:
+ @(cd extensions; make -i OBJECTS="$(EXTENSION_OBJECT_FILES)" TARGET=$(TARGET)) + @(cd extensions; make -i OBJECTS="$(EXTENSION_OBJECT_FILES)" TARGET=$(TARGET))
--- crash/gdb-6.1.patch.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/gdb-6.1.patch.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/gdb-6.1.patch 2006-01-03 13:36:25.000000000 -0500 +++ crash/gdb-6.1.patch 2006-01-03 13:36:25.000000000 -0500
@@ -0,0 +1,11 @@ @@ -0,0 +1,11 @@
+--- gdb-6.1/bfd/coff-alpha.c.orig +--- gdb-6.1/bfd/coff-alpha.c.orig
@ -18910,8 +18925,8 @@
+ } + }
+ +
+ if (lita_sec_data->gp != 0) + if (lita_sec_data->gp != 0)
--- crash/README.orig 2006-08-07 11:31:15.000000000 -0400 --- crash/README.orig 2006-08-07 13:51:46.000000000 -0400
+++ crash/README 2006-08-07 11:31:12.000000000 -0400 +++ crash/README 2006-08-07 13:51:42.000000000 -0400
@@ -69,7 +69,7 @@ @@ -69,7 +69,7 @@
After the kernel is re-compiled, the uncompressed "vmlinux" kernel After the kernel is re-compiled, the uncompressed "vmlinux" kernel
that is created in the top-level kernel build directory must be saved. that is created in the top-level kernel build directory must be saved.
@ -18943,7 +18958,7 @@
DUMPFILE: /dev/mem DUMPFILE: /dev/mem
CPUS: 1 CPUS: 1
- DATE: Wed Jul 13 13:26:00 2005 - DATE: Wed Jul 13 13:26:00 2005
+ DATE: Mon Aug 7 11:31:12 2006 + DATE: Mon Aug 7 13:51:42 2006
UPTIME: 10 days, 22:55:18 UPTIME: 10 days, 22:55:18
LOAD AVERAGE: 0.08, 0.03, 0.01 LOAD AVERAGE: 0.08, 0.03, 0.01
TASKS: 42 TASKS: 42