new upstream release 8.17, defuzz patches
This commit is contained in:
parent
618e468330
commit
315471e18a
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
|||||||
/coreutils-8.14.tar.xz
|
/coreutils-8.14.tar.xz
|
||||||
/coreutils-8.15.tar.xz
|
/coreutils-8.15.tar.xz
|
||||||
/coreutils-8.16.tar.xz
|
/coreutils-8.16.tar.xz
|
||||||
|
/coreutils-8.17.tar.xz
|
||||||
|
@ -111,13 +111,13 @@ diff -urNp coreutils-8.13-orig/gnulib-tests/gnulib.mk coreutils-8.13/gnulib-test
|
|||||||
|
|
||||||
## end gnulib module utimens-tests
|
## end gnulib module utimens-tests
|
||||||
|
|
||||||
diff -urNp coreutils-8.13-orig/tests/Makefile.am coreutils-8.13/tests/Makefile.am
|
diff -urNp coreutils-8.17-orig/tests/Makefile.am coreutils-8.17/tests/Makefile.am
|
||||||
--- coreutils-8.13-orig/tests/Makefile.am 2011-09-02 14:08:40.000000000 +0200
|
--- coreutils-8.17-orig/tests/Makefile.am
|
||||||
+++ coreutils-8.13/tests/Makefile.am 2011-09-09 10:12:56.364814725 +0200
|
+++ coreutils-8.17/tests/Makefile.am
|
||||||
@@ -86,7 +86,6 @@ TESTS = \
|
@@ -87,7 +87,6 @@ TESTS = \
|
||||||
rm/ext3-perf \
|
|
||||||
rm/cycle \
|
rm/cycle \
|
||||||
cp/link-heap \
|
cp/link-heap \
|
||||||
|
misc/tty-eof \
|
||||||
- tail-2/inotify-hash-abuse \
|
- tail-2/inotify-hash-abuse \
|
||||||
tail-2/inotify-hash-abuse2 \
|
tail-2/inotify-hash-abuse2 \
|
||||||
tail-2/F-vs-missing \
|
tail-2/F-vs-missing \
|
||||||
|
@ -2003,13 +2003,13 @@ diff -urNp coreutils-8.16-orig/src/pr.c coreutils-8.16/src/pr.c
|
|||||||
}
|
}
|
||||||
/* It's rather pointless to define a TAB separator with column
|
/* It's rather pointless to define a TAB separator with column
|
||||||
@@ -1279,11 +1410,11 @@ init_parameters (int number_of_files)
|
@@ -1279,11 +1410,11 @@ init_parameters (int number_of_files)
|
||||||
TAB_WIDTH (chars_per_input_tab, chars_per_number); */
|
+ TAB_WIDTH (chars_per_input_tab, chars_per_number); */
|
||||||
|
|
||||||
/* Estimate chars_per_text without any margin and keep it constant. */
|
/* Estimate chars_per_text without any margin and keep it constant. */
|
||||||
- if (number_separator == '\t')
|
- if (number_separator == '\t')
|
||||||
+ if (number_separator[0] == '\t')
|
+ if (number_separator[0] == '\t')
|
||||||
number_width = chars_per_number +
|
number_width = (chars_per_number
|
||||||
TAB_WIDTH (chars_per_default_tab, chars_per_number);
|
+ TAB_WIDTH (chars_per_default_tab, chars_per_number));
|
||||||
else
|
else
|
||||||
- number_width = chars_per_number + 1;
|
- number_width = chars_per_number + 1;
|
||||||
+ number_width = chars_per_number + number_separator_width;
|
+ number_width = chars_per_number + number_separator_width;
|
||||||
@ -2019,9 +2019,9 @@ diff -urNp coreutils-8.16-orig/src/pr.c coreutils-8.16/src/pr.c
|
|||||||
@@ -1298,7 +1429,7 @@ init_parameters (int number_of_files)
|
@@ -1298,7 +1429,7 @@ init_parameters (int number_of_files)
|
||||||
}
|
}
|
||||||
|
|
||||||
chars_per_column = (chars_per_line - chars_used_by_number -
|
chars_per_column = (chars_per_line - chars_used_by_number
|
||||||
- (columns - 1) * col_sep_length) / columns;
|
- - (columns - 1) * col_sep_length) / columns;
|
||||||
+ (columns - 1) * col_sep_width) / columns;
|
+ - (columns - 1) * col_sep_width) / columns;
|
||||||
|
|
||||||
if (chars_per_column < 1)
|
if (chars_per_column < 1)
|
||||||
error (EXIT_FAILURE, 0, _("page width too narrow"));
|
error (EXIT_FAILURE, 0, _("page width too narrow"));
|
||||||
@ -2447,16 +2447,17 @@ diff -urNp coreutils-8.16-orig/src/pr.c coreutils-8.16/src/pr.c
|
|||||||
/* We've just printed some files and need to clean up things before
|
/* We've just printed some files and need to clean up things before
|
||||||
looking for more options and printing the next batch of files.
|
looking for more options and printing the next batch of files.
|
||||||
|
|
||||||
diff -urNp coreutils-8.16-orig/src/sort.c coreutils-8.16/src/sort.c
|
diff -urNp coreutils-8.17-orig/src/sort.c coreutils-8.17/src/sort.c
|
||||||
--- coreutils-8.16-orig/src/sort.c 2012-03-24 21:26:51.000000000 +0100
|
--- coreutils-8.17-orig/src/sort.c
|
||||||
+++ coreutils-8.16/src/sort.c 2012-03-26 17:35:09.000000000 +0200
|
+++ coreutils-8.17/src/sort.c
|
||||||
@@ -22,11 +22,20 @@
|
@@ -22,12 +22,21 @@
|
||||||
|
|
||||||
#include <config.h>
|
#include <config.h>
|
||||||
|
|
||||||
+#include <assert.h>
|
+#include <assert.h>
|
||||||
#include <getopt.h>
|
#include <getopt.h>
|
||||||
#include <pthread.h>
|
#include <pthread.h>
|
||||||
|
#include <sys/resource.h>
|
||||||
#include <sys/types.h>
|
#include <sys/types.h>
|
||||||
#include <sys/wait.h>
|
#include <sys/wait.h>
|
||||||
#include <signal.h>
|
#include <signal.h>
|
||||||
|
@ -416,8 +416,8 @@ diff -urNp coreutils-8.13-orig/src/ls.c coreutils-8.13/src/ls.c
|
|||||||
+ && (format == long_format || format == security_format
|
+ && (format == long_format || format == security_format
|
||||||
+ || check_symlink_color))
|
+ || check_symlink_color))
|
||||||
{
|
{
|
||||||
char *linkname;
|
|
||||||
struct stat linkstats;
|
struct stat linkstats;
|
||||||
|
|
||||||
@@ -2931,6 +2959,7 @@ gobble_file (char const *name, enum file
|
@@ -2931,6 +2959,7 @@ gobble_file (char const *name, enum file
|
||||||
command line are automatically traced if not being
|
command line are automatically traced if not being
|
||||||
listed as files. */
|
listed as files. */
|
||||||
@ -628,29 +628,29 @@ diff -urNp coreutils-8.13-orig/src/runcon.c coreutils-8.13/src/runcon.c
|
|||||||
With neither CONTEXT nor COMMAND, print the current security context.\n\
|
With neither CONTEXT nor COMMAND, print the current security context.\n\
|
||||||
\n\
|
\n\
|
||||||
CONTEXT Complete security context\n\
|
CONTEXT Complete security context\n\
|
||||||
diff -urNp coreutils-8.13-orig/tests/init.cfg coreutils-8.13/tests/init.cfg
|
diff -urNp coreutils-8.17-orig/tests/init.cfg coreutils-8.17/tests/init.cfg
|
||||||
--- coreutils-8.13-orig/tests/init.cfg 2011-09-07 18:00:55.000000000 +0200
|
--- coreutils-8.17-orig/tests/init.cfg
|
||||||
+++ coreutils-8.13/tests/init.cfg 2011-09-09 10:32:17.031688699 +0200
|
+++ coreutils-8.17/tests/init.cfg
|
||||||
@@ -253,8 +253,8 @@ require_selinux_()
|
@@ -253,8 +253,8 @@ require_selinux_()
|
||||||
|
|
||||||
# Independent of whether SELinux is enabled system-wide,
|
# Independent of whether SELinux is enabled system-wide,
|
||||||
# the current file system may lack SELinux support.
|
# the current file system may lack SELinux support.
|
||||||
- case `ls -Zd .` in
|
- case $(ls -Zd .) in
|
||||||
- '? .'|'unlabeled .')
|
- '? .'|'unlabeled .')
|
||||||
+ case `ls -Zd . | cut -f4 -d" "` in
|
+ case $(ls -Zd . | cut -f4 -d" ") in
|
||||||
+ '?'|'unlabeled')
|
+ '?'|'unlabeled')
|
||||||
skip_ "this system (or maybe just" \
|
skip_ "this system (or maybe just" \
|
||||||
"the current file system) lacks SELinux support"
|
"the current file system) lacks SELinux support"
|
||||||
;;
|
;;
|
||||||
diff -urNp coreutils-8.13-orig/tests/misc/selinux coreutils-8.13/tests/misc/selinux
|
diff -urNp coreutils-8.17-orig/tests/misc/selinux coreutils-8.17/tests/misc/selinux
|
||||||
--- coreutils-8.13-orig/tests/misc/selinux 2011-08-08 09:42:16.000000000 +0200
|
--- coreutils-8.17-orig/tests/misc/selinux
|
||||||
+++ coreutils-8.13/tests/misc/selinux 2011-09-09 10:30:39.586563144 +0200
|
+++ coreutils-8.17/tests/misc/selinux
|
||||||
@@ -37,7 +37,7 @@ chcon $ctx f d p ||
|
@@ -37,7 +37,7 @@ chcon $ctx f d p ||
|
||||||
|
|
||||||
# inspect that context with both ls -Z and stat.
|
# inspect that context with both ls -Z and stat.
|
||||||
for i in d f p; do
|
for i in d f p; do
|
||||||
- c=`ls -dogZ $i|cut -d' ' -f3`; test x$c = x$ctx || fail=1
|
- c=$(ls -dogZ $i|cut -d' ' -f3); test x$c = x$ctx || fail=1
|
||||||
+ c=`ls -dogZ $i|cut -d' ' -f4`; test x$c = x$ctx || fail=1
|
+ c=$(ls -dogZ $i|cut -d' ' -f4); test x$c = x$ctx || fail=1
|
||||||
c=`stat --printf %C $i`; test x$c = x$ctx || fail=1
|
c=$(stat --printf %C $i); test x$c = x$ctx || fail=1
|
||||||
done
|
done
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||||
Name: coreutils
|
Name: coreutils
|
||||||
Version: 8.16
|
Version: 8.17
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.gnu.org/software/coreutils/
|
Url: http://www.gnu.org/software/coreutils/
|
||||||
@ -416,6 +416,9 @@ fi
|
|||||||
%{?!norunuser:%{_sbindir}/runuser}
|
%{?!norunuser:%{_sbindir}/runuser}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 11 2012 Ondrej Vasik <ovasik@redhat.com> 8.17-1
|
||||||
|
- new upstream release 8.17
|
||||||
|
|
||||||
* Fri May 04 2012 Ondrej Vasik <ovasik@redhat.com> 8.16-3
|
* Fri May 04 2012 Ondrej Vasik <ovasik@redhat.com> 8.16-3
|
||||||
- add .htm and .shtml to colorized DIR_COLORS document
|
- add .htm and .shtml to colorized DIR_COLORS document
|
||||||
type (#817218)
|
type (#817218)
|
||||||
|
Loading…
Reference in New Issue
Block a user