From 315471e18a21148a14e6877a59458a6db57950e2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ond=C5=99ej=20Va=C5=A1=C3=ADk?= <ovasik@redhat.com>
Date: Fri, 11 May 2012 09:58:08 +0200
Subject: [PATCH] new upstream release 8.17, defuzz patches

---
 .gitignore                         |  1 +
 coreutils-6.10-configuration.patch | 10 +++++-----
 coreutils-i18n.patch               | 21 +++++++++++----------
 coreutils-selinux.patch            | 24 ++++++++++++------------
 coreutils.spec                     |  7 +++++--
 sources                            |  2 +-
 6 files changed, 35 insertions(+), 30 deletions(-)

diff --git a/.gitignore b/.gitignore
index ab26cd4..c059bb4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
 /coreutils-8.14.tar.xz
 /coreutils-8.15.tar.xz
 /coreutils-8.16.tar.xz
+/coreutils-8.17.tar.xz
diff --git a/coreutils-6.10-configuration.patch b/coreutils-6.10-configuration.patch
index 1e3be91..7f5e6ee 100644
--- a/coreutils-6.10-configuration.patch
+++ b/coreutils-6.10-configuration.patch
@@ -111,13 +111,13 @@ diff -urNp coreutils-8.13-orig/gnulib-tests/gnulib.mk coreutils-8.13/gnulib-test
  
  ## end   gnulib module utimens-tests
  
-diff -urNp coreutils-8.13-orig/tests/Makefile.am coreutils-8.13/tests/Makefile.am
---- coreutils-8.13-orig/tests/Makefile.am	2011-09-02 14:08:40.000000000 +0200
-+++ coreutils-8.13/tests/Makefile.am	2011-09-09 10:12:56.364814725 +0200
-@@ -86,7 +86,6 @@ TESTS =						\
-   rm/ext3-perf					\
+diff -urNp coreutils-8.17-orig/tests/Makefile.am coreutils-8.17/tests/Makefile.am
+--- coreutils-8.17-orig/tests/Makefile.am
++++ coreutils-8.17/tests/Makefile.am
+@@ -87,7 +87,6 @@ TESTS =						\
    rm/cycle					\
    cp/link-heap					\
+   misc/tty-eof					\
 -  tail-2/inotify-hash-abuse			\
    tail-2/inotify-hash-abuse2			\
    tail-2/F-vs-missing				\
diff --git a/coreutils-i18n.patch b/coreutils-i18n.patch
index ee2cf73..5b0d3b8 100644
--- a/coreutils-i18n.patch
+++ b/coreutils-i18n.patch
@@ -2003,13 +2003,13 @@ diff -urNp coreutils-8.16-orig/src/pr.c coreutils-8.16/src/pr.c
          }
        /* It's rather pointless to define a TAB separator with column
 @@ -1279,11 +1410,11 @@ init_parameters (int number_of_files)
-              TAB_WIDTH (chars_per_input_tab, chars_per_number);   */
+              + TAB_WIDTH (chars_per_input_tab, chars_per_number);   */
  
        /* Estimate chars_per_text without any margin and keep it constant. */
 -      if (number_separator == '\t')
 +      if (number_separator[0] == '\t')
-         number_width = chars_per_number +
-           TAB_WIDTH (chars_per_default_tab, chars_per_number);
+         number_width = (chars_per_number
+                         + TAB_WIDTH (chars_per_default_tab, chars_per_number));
        else
 -        number_width = chars_per_number + 1;
 +        number_width = chars_per_number + number_separator_width;
@@ -2019,9 +2019,9 @@ diff -urNp coreutils-8.16-orig/src/pr.c coreutils-8.16/src/pr.c
 @@ -1298,7 +1429,7 @@ init_parameters (int number_of_files)
      }
  
-   chars_per_column = (chars_per_line - chars_used_by_number -
--                     (columns - 1) * col_sep_length) / columns;
-+                     (columns - 1) * col_sep_width) / columns;
+   chars_per_column = (chars_per_line - chars_used_by_number
+-                      - (columns - 1) * col_sep_length) / columns;
++                      - (columns - 1) * col_sep_width) / columns;
  
    if (chars_per_column < 1)
      error (EXIT_FAILURE, 0, _("page width too narrow"));
@@ -2447,16 +2447,17 @@ diff -urNp coreutils-8.16-orig/src/pr.c coreutils-8.16/src/pr.c
  /* We've just printed some files and need to clean up things before
     looking for more options and printing the next batch of files.
  
-diff -urNp coreutils-8.16-orig/src/sort.c coreutils-8.16/src/sort.c
---- coreutils-8.16-orig/src/sort.c	2012-03-24 21:26:51.000000000 +0100
-+++ coreutils-8.16/src/sort.c	2012-03-26 17:35:09.000000000 +0200
-@@ -22,11 +22,20 @@
+diff -urNp coreutils-8.17-orig/src/sort.c coreutils-8.17/src/sort.c
+--- coreutils-8.17-orig/src/sort.c
++++ coreutils-8.17/src/sort.c
+@@ -22,12 +22,21 @@
  
  #include <config.h>
  
 +#include <assert.h>
  #include <getopt.h>
  #include <pthread.h>
+ #include <sys/resource.h>
  #include <sys/types.h>
  #include <sys/wait.h>
  #include <signal.h>
diff --git a/coreutils-selinux.patch b/coreutils-selinux.patch
index 0db3acb..501b33e 100644
--- a/coreutils-selinux.patch
+++ b/coreutils-selinux.patch
@@ -416,8 +416,8 @@ diff -urNp coreutils-8.13-orig/src/ls.c coreutils-8.13/src/ls.c
 +          && (format == long_format || format == security_format
 +              || check_symlink_color))
          {
-           char *linkname;
            struct stat linkstats;
+ 
 @@ -2931,6 +2959,7 @@ gobble_file (char const *name, enum file
                   command line are automatically traced if not being
                   listed as files.  */
@@ -628,29 +628,29 @@ diff -urNp coreutils-8.13-orig/src/runcon.c coreutils-8.13/src/runcon.c
  With neither CONTEXT nor COMMAND, print the current security context.\n\
  \n\
    CONTEXT            Complete security context\n\
-diff -urNp coreutils-8.13-orig/tests/init.cfg coreutils-8.13/tests/init.cfg
---- coreutils-8.13-orig/tests/init.cfg	2011-09-07 18:00:55.000000000 +0200
-+++ coreutils-8.13/tests/init.cfg	2011-09-09 10:32:17.031688699 +0200
+diff -urNp coreutils-8.17-orig/tests/init.cfg coreutils-8.17/tests/init.cfg
+--- coreutils-8.17-orig/tests/init.cfg
++++ coreutils-8.17/tests/init.cfg
 @@ -253,8 +253,8 @@ require_selinux_()
  
    # Independent of whether SELinux is enabled system-wide,
    # the current file system may lack SELinux support.
--  case `ls -Zd .` in
+-  case $(ls -Zd .) in
 -    '? .'|'unlabeled .')
-+  case `ls -Zd . | cut -f4 -d" "` in
++  case $(ls -Zd . | cut -f4 -d" ") in
 +    '?'|'unlabeled')
        skip_ "this system (or maybe just" \
          "the current file system) lacks SELinux support"
      ;;
-diff -urNp coreutils-8.13-orig/tests/misc/selinux coreutils-8.13/tests/misc/selinux
---- coreutils-8.13-orig/tests/misc/selinux	2011-08-08 09:42:16.000000000 +0200
-+++ coreutils-8.13/tests/misc/selinux	2011-09-09 10:30:39.586563144 +0200
+diff -urNp coreutils-8.17-orig/tests/misc/selinux coreutils-8.17/tests/misc/selinux
+--- coreutils-8.17-orig/tests/misc/selinux
++++ coreutils-8.17/tests/misc/selinux
 @@ -37,7 +37,7 @@ chcon $ctx f d p ||
  
  # inspect that context with both ls -Z and stat.
  for i in d f p; do
--  c=`ls -dogZ $i|cut -d' ' -f3`; test x$c = x$ctx || fail=1
-+  c=`ls -dogZ $i|cut -d' ' -f4`; test x$c = x$ctx || fail=1
-   c=`stat --printf %C $i`; test x$c = x$ctx || fail=1
+-  c=$(ls -dogZ $i|cut -d' ' -f3); test x$c = x$ctx || fail=1
++  c=$(ls -dogZ $i|cut -d' ' -f4); test x$c = x$ctx || fail=1
+   c=$(stat --printf %C $i); test x$c = x$ctx || fail=1
  done
  
diff --git a/coreutils.spec b/coreutils.spec
index e574ded..9e81b26 100644
--- a/coreutils.spec
+++ b/coreutils.spec
@@ -1,7 +1,7 @@
 Summary: A set of basic GNU tools commonly used in shell scripts
 Name:    coreutils
-Version: 8.16
-Release: 3%{?dist}
+Version: 8.17
+Release: 1%{?dist}
 License: GPLv3+
 Group:   System Environment/Base
 Url:     http://www.gnu.org/software/coreutils/
@@ -416,6 +416,9 @@ fi
 %{?!norunuser:%{_sbindir}/runuser}
 
 %changelog
+* Fri May 11 2012 Ondrej Vasik <ovasik@redhat.com> 8.17-1
+- new upstream release 8.17
+
 * Fri May 04 2012 Ondrej Vasik <ovasik@redhat.com> 8.16-3
 - add .htm and .shtml to colorized DIR_COLORS document
   type (#817218)
diff --git a/sources b/sources
index 6df33ae..44109bd 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-89b06f91634208dceba7b36ad1f9e8b9  coreutils-8.16.tar.xz
+bbda656ce8ca2c6903948f9faa204ba3  coreutils-8.17.tar.xz