381b080c4f
Resolves: rhbz#2061041
38 lines
1.3 KiB
Diff
38 lines
1.3 KiB
Diff
commit b18bde7a9bd6ed80f5721c47c805f0158b4fe9f8
|
|
Author: Timm Bäder <tbaeder@redhat.com>
|
|
Date: Wed Mar 9 07:17:21 2022 +0100
|
|
|
|
[compiler-rt] Add LLVM cmake package in standalone builds
|
|
|
|
So the other files from the toplevel cmake/Modules directory have a
|
|
chance of being found.
|
|
|
|
diff --git a/compiler-rt/CMakeLists.txt b/compiler-rt/CMakeLists.txt
|
|
index 3a41aa43e406..6516e10fa3c5 100644
|
|
--- a/compiler-rt/CMakeLists.txt
|
|
+++ b/compiler-rt/CMakeLists.txt
|
|
@@ -28,6 +28,12 @@ else()
|
|
set(CMAKE_CFG_RESOLVED_INTDIR "")
|
|
endif()
|
|
|
|
+if(COMPILER_RT_STANDALONE_BUILD)
|
|
+ # Needed to find the other modules from the toplevel cmake/Modules dir
|
|
+ find_package(LLVM REQUIRED HINTS "${LLVM_CMAKE_DIR}")
|
|
+ list(APPEND CMAKE_MODULE_PATH "${LLVM_DIR}")
|
|
+endif()
|
|
+
|
|
include(SetPlatformToolchainTools)
|
|
include(base-config-ix)
|
|
include(CompilerRTUtils)
|
|
diff --git a/compiler-rt/test/CMakeLists.txt b/compiler-rt/test/CMakeLists.txt
|
|
index 5c2b634e1180..098fb0481517 100644
|
|
--- a/compiler-rt/test/CMakeLists.txt
|
|
+++ b/compiler-rt/test/CMakeLists.txt
|
|
@@ -1,6 +1,3 @@
|
|
-# Needed for lit support in standalone builds.
|
|
-include(AddLLVM)
|
|
-
|
|
option(COMPILER_RT_TEST_STANDALONE_BUILD_LIBS
|
|
"When set to ON and testing in a standalone build, test the runtime \
|
|
libraries built by this standalone build rather than the runtime libraries \
|